apache startet nicht über control center

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

apache startet nicht über control center

Postby el3ment » 19. September 2008 13:04

hallo,

habe xp pro und die neuste xampp version installiert. nur leider startet apache nicht mit dem control center.
wenn ich die apache_start.bat starte funktionierts.
woran liegt das?habe schon geschaut ob irgendein Programm Port 80 oder 443 blockiert, ist alles offen.
el3ment
 
Posts: 9
Joined: 19. September 2008 12:57

Postby Wiedmann » 19. September 2008 13:30

Apache ist als Dienst installiert?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby el3ment » 19. September 2008 13:40

Ja ist er. Wenn ich über Verwaltung/Dienste probiere diesen zu starten bekomme ich folgende Meldung:

Fehler 3: Das System kann den angegebenen Pfad nicht finden.
el3ment
 
Posts: 9
Joined: 19. September 2008 12:57

Postby Wiedmann » 19. September 2008 14:17

Fehler 3: Das System kann den angegebenen Pfad nicht finden.

Indem Fall musst du den vorhandenen Dienst entfernen und neu installieren.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby el3ment » 19. September 2008 14:37

ich habe die apache_uninstallservice.bat ausgeführt.
nun starte ich die apache_installservice.bat, da bekomem ich foglende Meldung:

Systemfehler: 1058 aufgetreten.

Der angegebene Dienst kann nicht gestartet werden. Er ist deaktiviert oder nicht mit aktivierten Geräten verbunden.

Drücken Sie eine beliebige...
el3ment
 
Posts: 9
Joined: 19. September 2008 12:57

Postby glitzi85 » 19. September 2008 15:12

Start -> Ausführen -> regedit

Im Registrierungseditor nun diesen Ordner suchen:

HKEY_LOCAL_COMPUTER\SYSTEM\CurrentControlSet\Services

und dort einen Ordner suchen der Apache oder so ähnlich heißt. Diesen Ordner löschen und den Rechner neu starten. Danach ist der Dienst weg.

Dann kannst es erneut versuchen.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Wiedmann » 19. September 2008 16:57

Start -> Ausführen -> regedit

Anstatt regedit tut es normal auch:
Code: Select all
sc delete Apache2.2
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby el3ment » 19. September 2008 17:24

hat funktioniert, vielen dank!

schönes wochenende!
el3ment
 
Posts: 9
Joined: 19. September 2008 12:57

Re: apache startet nicht über control center

Postby elecsniper2000 » 15. February 2009 00:35

Wo muss man diesen Code eingeben??

sc delete Apache2.2

Denn bei mir geht es auch nicht!!!!!!!!!!!!!!!!!! HILFE
elecsniper2000
 
Posts: 8
Joined: 15. February 2009 00:33

Re: apache startet nicht über control center

Postby Wiedmann » 15. February 2009 00:40

Wo muss man diesen Code eingeben??

In der Eingabeaufforderung.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: apache startet nicht über control center

Postby elecsniper2000 » 15. February 2009 00:43

Dann habe ich ein Problem! Denn ich habe keine Eingabeaufforderung!

Bei mir öffnet sich immer dieses Beschissene Fenster!!!

Ursache!!

Habe xampp installiert!
habe es nach einer Woche wieder deinstalliert.
und jetzt habe ich es wieder gebraucht, wollte es installieren und nach der installation, hupft mir andauernt das fenster auf!

Habe es nun wieder deinstalliert, aber das fenster kommt immer wieder, nur wenn ich die Ampel unten abdrehe, hört es auf!!

Kannst du einen Newbie helfen?

DANKE
elecsniper2000
 
Posts: 8
Joined: 15. February 2009 00:33

Re: apache startet nicht über control center

Postby Wiedmann » 15. February 2009 00:47

Denn ich habe keine Eingabeaufforderung!

Dann hast du kein Windows... Lass dir mal von der Windows-Hilfe dabei helfen :idea:

aber das fenster kommt immer wieder, nur wenn ich die Ampel unten abdrehe, hört es auf!!

Dann hast du bestimmt das Programm "WinMySQL.Admin.exe" gestartet. Beende dieses, entferne es aus dem Autostart, und starte es nie wieder.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: apache startet nicht über control center

Postby elecsniper2000 » 15. February 2009 00:52

Hoffe das war nur ironisch gemeint, dass ich kein Windows habe!
Natürlich habe ich Windwos, nur Helfe die mir nicht wirklich weiter *gg*

Ich werde es ganz sicher nicht mehr starten, nur sag mir bitte noch wo ich dir Autostart-Funktion finde, weil dann Deaktiviere ich gleich mehrere Programme die da so unnötig aufgehen, wie msn usw.

DANKE für deine Hilfe
elecsniper2000
 
Posts: 8
Joined: 15. February 2009 00:33

Re: apache startet nicht über control center

Postby elecsniper2000 » 15. February 2009 01:00

Habe es gefunden!!

msconfig

nur was muss ich da deaktivieren?

SSBkgdupdate
soundman
opware SE4
CNSLMAIN
BJMyPrt
avgnt
READER_sl
ctfmon
Reminder
WinMySQLadmin
msnmsgr

Das sind die Datei die aufgeführt sind!
Kannst mir vll. auch einen Tipp geben welche ich noch deaktivieren kann um den Startvorgang zu beschleunigen!
Weil wie ich weis kann ich msnmsgr aus dieser liste streichen!
elecsniper2000
 
Posts: 8
Joined: 15. February 2009 00:33

Re: apache startet nicht über control center

Postby elecsniper2000 » 15. February 2009 01:34

So habe nun xampp neu installiert und gestartet!
Folgendes Problem ist aufgetretten:

Control Panel Startet ohne Probleme!
Alle Haken sind gesetzt
Apache und File Zilla sind am Runnin nur MySQL nicht!

Bei Start bekomme ich immer unden folgende Fehlermeldung:

ERROR: MySql service not started [-1]
elecsniper2000
 
Posts: 8
Joined: 15. February 2009 00:33

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests