Apache Portänderung wird nicht angenommen!?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache Portänderung wird nicht angenommen!?

Postby bierzart » 21. August 2008 00:03

Hallo,

nach langer Sucher in diesem Forum habe ich mich dazu entschlossen zu diesem ärgerlichen Problem noch einmal zu posten...

Mein Systemumgebung:
MS Windows Server 2003 Ent R2 SP2, IIS 6 wird für Exchange 2003 verwendet und muss auf Port 80 laufen. Installation von XAMPP 1.6.7 wurde ohne Probleme abgeschlossen - allerdings am Ende der Installation die erwartete Fehlermeldung, dass Port 80 eben schon belegt ist.

Kein Problem denke ich mir, da ich ja in der httpd.conf den Listener auf Port 8080 stellen kann (Port wird nicht verwendet). Also im Control Panel den Apache starten (Dienstneustart fällt ja weg, da er nicht läuft)... Allerdings sagt das Control Panel "Apache started [Port 80]" aber der Dienst startet nicht. Daraus folgt für micht, dass das Control Panel den angepasste Ports nicht anzeigt. Testweise mal den Server neu gestartet aber erneut kein besseres Ergebnis. Wieso startet also der Apache auf dem angepassten Port 8080 nicht? Starte ich Apache durch die Batch-Datei "apache_start.bat" aus dem XAMPP Stammverzeichniss manuell kommt folgende Fehlermeldung:
Code: Select all
Apache 2 is starting ...
(OS 10048) Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder Anschluss) nur jeweils einmal verwendet werden.  : make_sock: could not bind to address 0.0.0.0:8080 ...
no listening sockets available, shutting down
...Unable to open logs


Der Port 8080 ist definitv frei. Ach wenn ich den Listener auf die IP bspw. 192.168.0.2:8080 setze kommt die o. g. Fehlermeldung.

Wurde dieses Problem schon einmal gelöst? Ich weiss, dass die Portanpassung bei einer manuellen Installation von Apache, also nicht mit XAMPP installiert, funktioniert...

Vielen Dank für Eure Hilfe...

EDIT: Nur zur Information: MySQL Dienst läuft...
bierzart
 
Posts: 3
Joined: 20. August 2008 23:26

Postby Wiedmann » 21. August 2008 00:10

(OS 10048) Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder Anschluss) nur jeweils einmal verwendet werden. : make_sock: could not bind to address 0.0.0.0:8080 ...

Der Port 8080 ist definitv frei.

Zum Zeitpunkt dieser Fehlermeldung definitiv nicht (deshalb ja diese Fehlermeldung).

Könnte natürlich auch noch eine FW sein, die es verhindert, dass sich ein Server an diesen Port bindet.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby bierzart » 21. August 2008 00:26

Ich habe per Netstat Port 8080 überprüft - er wird nicht verwendet. Ich habe aber auch andere Ports getestet wie z. B. 8081, 8082, 4872 etc. Es kommt immer diese Meldung (siehe Code-Bereich mit dem jeweiligen Port)...

Auf dem Server läuft keine Software-Firewall...
bierzart
 
Posts: 3
Joined: 20. August 2008 23:26

Postby bierzart » 21. August 2008 01:02

Ich habe den Apache einzeln installiert (XAMPP davor deinstalliert), da funktioniert der Port 8080... Werde das halt manuell hochziehen.

Grüße
bierzart
 
Posts: 3
Joined: 20. August 2008 23:26

Postby FlavioB » 21. August 2008 08:11

bierzart wrote:Ich habe den Apache einzeln installiert (XAMPP davor deinstalliert), da funktioniert der Port 8080... Werde das halt manuell hochziehen.

Grüße


Hy... hab das gleiche Problem: kann man es wirklich nur lösen indem man kein XAMPP benutzt? Das finde ich echt schade... ich dachte XAMPP würde mir jeglichen Konfigurationsstress ersparen...

Hat jemand eine andere Lösung für dieses Problem beim umstellen des Ports für Apache?!

Grüsse...
FlavioB
 
Posts: 3
Joined: 21. August 2008 08:03

Postby Hanspeter Thöni » 21. August 2008 09:35

Warum sollte das mit XAMPP nicht funktionieren? Habe hier auch 2 XAMPP (prod/test) auf verschiednenen Ports.
Es gilt aber zu beachten, dass der XAMPP Apache in der Grundkonfigration 2 Ports braucht (80er hppt und 443 https) daher allenfalls beide umkonfigurieren (aber nicht auf den gleichen!!).
Gruss Hanspeter
User avatar
Hanspeter Thöni
 
Posts: 233
Joined: 17. August 2004 10:29
Location: Schweiz

Postby FlavioB » 21. August 2008 10:03

Hallo Hanspeter,
ich habe lediglich XAMPP installiert und danach

- in httpd.conf von 80 auf 81 umgestellt (Listen und ServerName)
- in extra\httpd-ssl.conf von 443 auf 4499 umgestellt (Listen, <VirtualHost _default_:4499>, ServerName localhost:4499)

Wieso auch immer dies nicht funktioniert, weiss ich auch nicht! Wenn ich aus dem ControlPanel den MySQL starte, dann bleibt es auch "running", aber mit Apache nicht!

PS: folgende Info hab ich gelesen:

# XAMPP requires port 80 to work. If you already have a server occupying port 80 (e.g. ColdFusion Server, IIS Server, etc.), you will not be able to launch XAMPP after installing it due to a port-binding conflict. The safest (albeit perhaps not the most convenient) solution is to uninstall whatever system/application that is already binding the port. IIS Server is often a common culprit because it's already a part of your PC; so if you have a port-binding conflict, see if you need to disable IIS Server on your system.

(Quelle: http://textbook.textpattern.net/wiki/in ... L-PHP-Perl)_for_Windows )

Stimmt es also wenn ich davon ausgehen muss dass nun XAMPP *nur* auf port 80 den Apache laufen lassen kann?
FlavioB
 
Posts: 3
Joined: 21. August 2008 08:03

Postby Hanspeter Thöni » 21. August 2008 11:35

Hmm, ich bin jetzt nicht sicher, aber es könnte sein, dass das Control-Panel nicht mit anderen Ports klarkommt.

Ich habe die Apache's als Dienst laufen und arbeite nicht mit den Control-Panel, daher keine Probleme.
Du müsstest allenfalls den Apchen in der Konsole (cmd) oder als Dienst starten.
Gruss Hanspeter
User avatar
Hanspeter Thöni
 
Posts: 233
Joined: 17. August 2004 10:29
Location: Schweiz

Postby deepsurfer » 21. August 2008 11:45

Stimmt es also wenn ich davon ausgehen muss dass nun XAMPP *nur* auf port 80 den Apache laufen lassen kann?

Nein, es stimmt nicht.

Wie Du schon selbst umgeändert hattest sollte es funktionieren, auch hier bei mir arbeite ich zu testzecken mit bis zu 4 Paralell laufenden XAMPP-Apachen auf verschiedenen ports.

Warum es bei dir nicht ging, ist nur eine reine Vermutung, ich denke das Du einfach die falsche httpd.conf editiert hattest.
Der XAMPP Controll prüft zwar den Port 80 und gibt dann eine Fehlermeldung aus aber der XAMPP-Apache sollte dennoch anlaufen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby FlavioB » 21. August 2008 12:40

OK, Fehler gefunden (und gelöst): ein typo auf einer alleinstehende Zeile meldete "Error"... Zeile gelöscht = Problem gelöst.

Vielen Dank!
FlavioB
 
Posts: 3
Joined: 21. August 2008 08:03


Return to XAMPP für Windows

Who is online

Users browsing this forum: wodim and 21 guests