ioncube und php 5.2.6

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

ioncube und php 5.2.6

Postby goldfisch2k » 13. August 2008 19:18

Hallo,

Ich habe auf einem Windows System Xampp in der aktuellen Version installiert.
Allerdings bekomme ich den Ioncube (loader) nicht zum laufen.
Ich habe mir den Loader für Windows runtergeladen und folgendes in meine PHP.ini eingefügt.
Was ihr hier seht, ist das ENDE der php.ini.

[Zend]
zend_extension_ts = "D:\webserver\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "D:\webserver\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 1
zend_optimizer.optimization_level=15
;zend_optimizer.license_path =
zend_extension = "D:\webserver\ioncube\ioncube\ioncube_loader_win_5.2.dll"
zend_extension_ts = "D:\webserver\ioncube\ioncube\ioncube_loader_win_5.2.dll"

; Local Variables:
; tab-width: 4
; End:

PHP Version ist auf dem Server die 5.2.6
Die 4er ist wohl auch drauf, jedoch meldet er, wenn ich die php-switch.bat Datei ausführe permanent, dass der Apache noch läuft, was nicht stimmt. Er wurde sogar über den Taskmanager mal brutal deaktiviert, weil ich dachte, die Stoptaste klappt vielleicht nicht richtig
Soweit mir jedoch bekannt ist, arbeitet ioncube (loader) auch mit der 5er Version.

Wo liegt hier der Fehler...

Die Pfadanpassung habe ich auch schon ohne das _ts versucht und auch im Verzeichnis "htdocs".

EDIT: Auf Port 80 läuft ein anderer, der Xampp-Webserver läuft auf einem anderen Port. Evt geht daher der php switch nicht.
Wo bringt man dem Switch in diesem Fall den neuen port bei?
goldfisch2k
 
Posts: 19
Joined: 13. August 2008 18:58

Postby Wiedmann » 13. August 2008 21:20

Code: Select all
zend_extension_ts = "D:\webserver\ioncube\ioncube\ioncube_loader_win_5.2.dll"

IMHO ist das der einzigste EIntrag der aktviert sein darf.

Wo liegt hier der Fehler...

Keine Ahnung. Gibt es denn eine Fehlermeldung, bzw. was tut denn überhaupt nicht?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby goldfisch2k » 14. August 2008 23:50

danke für den Tipp - nu klappt alles :-)
goldfisch2k
 
Posts: 19
Joined: 13. August 2008 18:58


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests