Mode Rewrite

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Mode Rewrite

Postby morrers » 10. August 2008 18:55

Hi
mode rewrite wird nur teilweise akzeptiert.
folgende Regel kommt anscheinend nicht zum Einsatz.

RewriteRule ^(.*)/variable/([^/]+)(.*)$ $1.php?var=$2#$3 [L]
RewriteRule ^(.*)/variable/([^/]+)$ $1.php?var=$2 [L]

$var ist nicht vorhanden.

Im Gegenzug funktioniert aber das hier
RewriteRule ^(.*).html$ $1.php [L]

Gruß
Morrers

PS: Mode Rewrite ist aktiviert worden.
Nur php zu html funktioniert, alle anderen Regeln 10 an der Zahl werden ignoriert.

Fehlermeldung gibt es keine aber ohne diese Variable werden keine Daten aus der Datenbank geholt.
morrers
 
Posts: 12
Joined: 13. July 2008 09:56

Postby Wiedmann » 10. August 2008 19:42

$var ist nicht vorhanden.

Du meinst "$_GET['var']"?

Nur php zu html funktioniert, alle anderen Regeln 10 an der Zahl werden ignoriert.

Ist das nicht ".html zu .php"? Das dies aber die letzte Regel ist, werden weitere danach auch nicht mehr ausgeführt.

folgende Regel kommt anscheinend nicht zum Einsatz. ... Fehlermeldung gibt es keine

- Müsste man jetzt natürlich auch eine Beispieluri kennen.
- wo diese Regeln stehen
- welche jetzt genau in welcher Reihenfolge da stehen. (ist html zu php denn die Erste? Du schriebst ja von anderen danach)
- müsstest du das RewriteLog aktivieren um zu sehen was genau passiert. bzw. uns dieses Log hier posten.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby morrers » 10. August 2008 19:51

Hallo
nein ich meine $variable ist nicht vorhanden, da diese ja über die Adresszeile übergeben wird.

Code: Select all
RewriteRule ^(.*)/variable/([^/]+)(.*)$ $1.php?variable=$2#$3 [L]


Meine Regeln stehen natürlich alle in der .htaccess

Online funktioniert alles, nur offline hat er anscheinend ein Problem mit der rewrite Regel.

Gruß
Morrers
morrers
 
Posts: 12
Joined: 13. July 2008 09:56

Postby Xardas der Dunkle » 10. August 2008 19:59

Ist den $_GET['variable'] vorhanden? $variable ist nur vorhanden wenn register_globals aktiviert ist.
(Und soviel seih gesagt, wenn es deaktiviert ist, lass es lieber dabei).
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests