WebDav Problem

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Postby phb » 07. August 2008 16:36

Hi,

ich kann mich diesem Problem nur anschließen!
Sobald man, ein XAMPP Passwort für den xampp user erstellt hat, ist es nicht mehr möglich http://localhost/ aufzurufen.

Ich habe heute die aktuelle Version von XAMPP heruntergeladen.

Der Error-Log besagt folgendes:

[Thu Aug 07 17:13:28 2008] [error] [client 127.0.0.1] user xampp user not found: /xampp/

Wie kann man diesen Fehler korrigieren?

(Nutze gerade zum ersten mal einen Appache)


MfG,
phb
phb
 
Posts: 7
Joined: 07. August 2008 16:23

Postby glitzi85 » 07. August 2008 17:23

Hallo,

@phb: Im XAMPP-Ordner gibt es einen Ordner htdocs. Darin sollte sich eine .htaccess befinden. Poste den Inhalt dieser Datei hier.

@AKidwaDream: Inside the XAMPP-Folder you will find an Folder called htdocs. Inside this folder there should be a file called .htacess. Post the content of this file here.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby phb » 07. August 2008 17:43

Ohje...
ich muss mich entschuldigen... ich sitze seit heute morgen am Apache (XAMPP) und als ich zu diesem Punkt kam, habe ich analog zum Root-Passwort für SQL zwei mal das Passwort für XAMPP eingegeben... allerdings ist es hier nötig einmal den Login und einmal das Passwort anzugeben. :roll:

Falls du dich schon etwas mit Apache auskennst und über webdav und htaccess bescheid weißt, würde ich mich über eine PN freuen. Ich habe fragen dazu, die mir simpel erscheinen, sich mir aber nicht erschließen...

Thx,
phb
phb
 
Posts: 7
Joined: 07. August 2008 16:23

Postby glitzi85 » 07. August 2008 18:28

Hallo,

mit webdav kenne ich mich nicht aus, mit htaccess respektive der Konfiguration vom Apache im allgemeinen schon.

Stell die Fragen einfach hier, dann haben andere auch was davon.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby phb » 07. August 2008 18:57

Okay,

ich versuch zuerst mal das Szenario zu erklären.

Ich möchte einen webdav Server aufsetzen, um damit Kalender zu verwalten. Sprich, ich will mit Mozilla Sunbird (oder Lightning) auf den Sever zugreifen und Kalenderdaten hochladen bzw. runterladen.

Laut der Doku soll man einen dav aktivieren, indem man folgendes in der httpd.conf einfügt:

<Location /kalender>

Dav On

</Location>

Soweit so gut... mir ist soweit klar, dass damit jeder, der den Server erreicht volle Zugriffsrechte auf "http://servername/kalender/" haben wird. Allerdings ist es mir nicht möglich, dieses Verzeichnis zu erreichen.

Ich habe nebenbei auch den Ordner "C:\xampp\kalender" angelegt... ist das nötig oder sollte das automatisch geschehen, wenn der Server startet?

Soweit ich das erkenne, sind auch alle Rechte unter Windows für die Ordner freigegeben...

Wenn ich ohne Zugriffskontrolle schonmal Daten draufschieben könnte, wäre schonmal ein Anfang ?!? Aber wie schon erwähnt... ich kann den Pfad weder über Firefox/IExplorer erreichen, noch klappt das publizieren in Sunbird. Das einzige, was ich mal hingekriegt habe, war die User und PW abfrage beim publizieren eines Kalenders... aber meine Eingaben wurden nie als korrekt angenommen.

Aktuelle Fehlermeldung bei dem Code oben ist: Error 404

MfG
phb
 
Posts: 7
Joined: 07. August 2008 16:23

Postby glitzi85 » 07. August 2008 20:13

Hallo,

Location zeigt im Gegensatz zu Directory nicht auf einen Punkt im Dateisystem, sondern bezieht sich auf die URI. Beispiel:

Wenn du http://localhost aufrufst, dann wird auf C:\xampp\htdocs zugegriffen. Wenn du nun auf http://localhost/kalender/ aufrufen willst, dann muss die Ordnerstruktur folglich so aussehen: C:\xampp\htdocs\kalender

Das heißt, du musst den Ordner anstatt im xampp-Verzeichnis im htdocs-Verzeichnis erstellen, dann sollte es funktionieren.

Aufpassen musst du nur bei der Zugriffskontrolle. Du könntest den Location-Bereich z.B. so gestalten:

Code: Select all
<Location "/kalender">
   Dav on
   Order allow,deny
   allow from localhost
</Location>


In dem Fall kannst du nur vom eigenen Rechner aus drauf zugreifen. Angenommen du hast jetzt aber einen vHost "example.com", dessen DocRoot du auf C:\xampp\htdocs\kalender gesetzt hast, dann könnte jeder durch Aufruf von example.com den Kalender-Ordner erreichen, weil in der URI kein /kalender drinsteht.
Wenn du es allerdings so machst:

Code: Select all
<Location "/kalender">
   Dav on
</Location>
<Directory "/xampp/htdocs/kalender">
   Order allow,deny
   allow from localhost
</Directory>


dann kann das nicht passieren. Auch eine .htaccess im kalender-Ordner mit einer Passwortabfrage ist in Ordnung, lediglich bei Location-Anweisungen musst du aufpassen was du machst, da es wie gesagt auf die URI aufsetzt und nicht auf das Dateisystem.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby glitzi85 » 08. August 2008 07:02

Zusatz: Das dav-Modul muss natürlich geladen werden, also in der httpd.conf ziemlich am Anfang die Reihen mit LoadModule suchen und darin die mod_dav.so ausfindig machen. Sollte davor ein Rautezeichen (#) stehen, dieses entfernen und den Apachen neu starten!

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby phb » 08. August 2008 08:58

Danke, ich habe es gestern geschafft, mein Szenario grundlegend umzusetzen! :D

Was ich zwar bisher nicht erneut getestet habe, aber gestern nicht funktionieren wollte, war der in XAMPP vorbereitete webdav. Wenn ich das richtig verstehte soll man auf den /xampp/webdav/ zugreifen können. Login und PW sind dafür wampp & xampp. Aber das wollte nicht funktionieren!

Hast du eine Ahnung, was ich da falsch gemacht haben könnte?
Einstellungen sind die Grundeinstellungen nach der Installation.

MfG,
phb
phb
 
Posts: 7
Joined: 07. August 2008 16:23

Postby deepsurfer » 08. August 2008 09:50

Moderator Vorgang

Habe diesen Threadteil "aufgeteilt" da der Inhalt komplett nichts mehr mit dem Hauptfragesteller zutun hatte.


grüsse
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby glitzi85 » 08. August 2008 10:55

@deepsurfer: Ja, ist besser so. Wusste gar nicht dass das geht

@phb: Hab jetzt schon seit ein paar Stunden mit DAV rumgespielt, bis jetzt hab ich die Authentifizierung auch noch nicht an's laufen bekommen. Scheint ein Problem von Windows beim Übergeben des Benutzernamens zu sein. Die Adresse wäre übrigens http://localhost/webdav, nichts mit xampp und so.

Ich werd heut Abend oder morgen mal noch Versuche mit anderen WebDAV-Clients machen, vielleicht bekomm ich noch was raus. Im Netz hab ich bisher auch noch nichts drüber gefunden.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby deepsurfer » 08. August 2008 11:55

Welches Windows benutzt Du ?

Wenn Vista, dann könnte es eventuell daran liegen.
Nach meinem Kenntnisstand kam leider, bezüglich XAMPP auf Vista, in der Betaphase kein FeddBack wegen WebDav.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby glitzi85 » 08. August 2008 13:11

Ich verwende XP SP3.

Allerdings hab ich mir auch noch nicht die Mühe gemacht und die Suchergebnisse des Forums bezüglich WebDAV durchzuarbeiten. Hab ja vorhin erst erfahren was das überhaupt ist ;-)
Interessiert mich aber brennend, da mir FTP eigentlich noch nie so richtig zugesagt hat. Werd mich die nächsten Tage wohl näher damit beschäftigen und dann hoffentlich auch dieses Problem gelöst bekommen.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby phb » 08. August 2008 14:28

Hi,

das mit der Adresse: http://localhost/webdav war mir sogar schon klar :)
Ich nutze hier Windows XP mit SP2.

MfG
phb
 
Posts: 7
Joined: 07. August 2008 16:23

Postby glitzi85 » 09. August 2008 16:02

OK, das Problem ist nun gelöst.

Digest scheint unter XP nicht ohne weiteres implementierbar zu sein, deshalb hier mit Basic:

Authentifizierung in der httpd-dav.conf so Einstellen, falls nicht schon so drin:

AuthName DAV-upload
AuthType Basic
AuthUserFile "C:/xampp/security/webdav.htpasswd"

Die Pfade natürlich anpassen. In der Standardinstallation ist das glaub schon so voreingestellt. Die webdav.htpasswd-Datei löschen, wird im nächsten Schritt neu angelegt.

Jetzt in der Kommandozeile das hier ausführen:

Code: Select all
C:\xampp\apache\bin\htpasswd.exe -c C:\xampp\security\webdav.htpasswd test


für test kann natürlich ein beliebiger Benutzername eingesetzt werden. Zweimal das gewünschte Passwort eingeben und die Kommandozeile danach wieder verlassen.

Jetzt den Apache starten.

Netzwerkumgebung öffnen, Netzwerkumgebung hinzufügen auswählen. Zweimal auf Weiter klicken. Jetzt kommt der Clue: Als Adresse http://localhost:80/webdav eingeben. Die Port-Angabe ist wichtig, sonst funktioniert es nicht!

Anleitung hier gefunden: https://www.bsdwiki.de/Webdav_mit_Apache

Ich werde wohl nicht den Windows-Client verwenden, DAVExplorer scheint nicht schlecht zu sein, es wird wohl genug freie DAV-Clients geben.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Nobbie » 09. August 2008 16:34

>Ich werde wohl nicht den Windows-Client verwenden, DAVExplorer scheint nicht schlecht zu sein, es wird wohl genug freie DAV-Clients geben.

Da sehe ich genau das Problem - wenn man dann doch spezielle Clients benutzen muss, was ist dann noch der Wert von WebDAV? Da ist FTP viel ausgewachsener, es gibt massig gute Serverprogramme, tonnenweise gute Clients und unter diesen auch jede Menge explorer-artige - und last not least sogar welche, die einen FTP-Server als Remote Laufwerksbuchstaben in den Explorer einbinden können.

Das ist für mich ein K.O.-Kriterium für WebDAV - es bringt nichts wirklich neues und kann allenfalls weniger als FTP. Wie steht es beispielsweise mit RESUME (und in diesem Zusammenhang mit sehr großen Datentransfers)?
Nobbie
 
Posts: 8762
Joined: 09. March 2008 13:04

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests