phpMyAdmin startet nicht mehr

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

phpMyAdmin startet nicht mehr

Postby kjhofmann » 03. August 2008 15:21

Hallo,
nach einer Neuinstallation des Betriebssystem und danach XAMPP, (xampp-win32-1.6.7.zip) startet mein phpMyAdmin nicht mehr.
Es kommt eine Fehlereldung:
Die Sitzung konnte nicht ohne Fehler gestartet werden, schauen Sie bitte in das Fehlerprokoll von PHP und/oder Ihres Webservers und konfigurieren Sie PHP entsprechend (session.save_path, Schreibrechte).

Session-Pfad ist in der php.ini nur einer frei:
Code: Select all
 session.save_path = "F:\xampp\tmp"

Weitere sind auskommentiert. z.B.:
Code: Select all
session.save_path = "N;/path" oder
session.save_path = "N;MODE;/path"

Und XAMPP hat alle Schreibrechte.
Ich habe auch mal eine ältere Version installiert, mit WinInstaller probiert, es bleibt immer das gleiche Ergebnis.
Auch Umgebungsvariable habe ich eingerichtet, ohne Erfolg.

Was kann ich tun, um wieder Arbeitsfähig zu werden?
Gruß, Hoffi aus Radeberg
User avatar
kjhofmann
 
Posts: 41
Joined: 06. February 2006 12:07

Postby Nobbie » 03. August 2008 15:25

Handelt es sich bei F: um ein Netzwerklaufwerk?

>Und XAMPP hat alle Schreibrechte.

Was heißt das? Was ist "Xampp" in diesem Kontext? Windows kennt keinen "Xampp", sondern nur registrierte Anwender und Gruppen.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Postby kjhofmann » 03. August 2008 15:49

F:\ ist ein normales Laufwerk, bzw. Partition.

Schreibrechte bedeutet, das ich in der Fehlermeldung auch die Frage nach den Schreibrechten hatte, da habe ich alle Schreibrechte für das Verzeichnis XAMPP und Unterverzeichnisse über Eigenschaften auch ja gestellt.

Ist möglicherweise eine Verzweiflungstat.

Man muss es verstehen, ich arbeite als Webdesigner und teste hier meine Arbeiten, bevor sie ins Netz gehen.
Gruß, Hoffi aus Radeberg
User avatar
kjhofmann
 
Posts: 41
Joined: 06. February 2006 12:07

Postby Nobbie » 03. August 2008 16:00

Ist das denn jemals gelaufen? Und welches Windows? Wieso F:? Xampp wird per Standard nach C:\Xampp installiert!?
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Postby kjhofmann » 03. August 2008 16:46

XAMPP ist seit mehreren Jahren immer bei mir gelaufen.
XAMPP kann auf jedes Laufwerk oder Partition installiert werden.
Es muss nur im Basisverzeichnis installiert werden.
Ich nutze WinXP Pro SP2.
Gruß, Hoffi aus Radeberg
User avatar
kjhofmann
 
Posts: 41
Joined: 06. February 2006 12:07

Postby Xardas der Dunkle » 03. August 2008 17:34

Es muss nur im Basisverzeichnis installiert werden.

Nö, man kann es überall installieren.
Bei mir liegt es z.B. unter I:\www\xampp\

schauen Sie bitte in das Fehlerprokoll von PHP und/oder Ihres Webservers

Dann du das doch mal ;)
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Postby kjhofmann » 03. August 2008 18:17

Ich habe eine Datei gefunden: home-a.err (home-a ist der Name meines PC)
Nur kann ich da nichts finden, was mir weiter hilft.
Ich drucke sie hier mal ab:
InnoDB: The first specified data file F:\xampp\mysql\ibdata1 did not exist:
InnoDB: a new database to be created!
080803 14:58:59 InnoDB: Setting file F:\xampp\mysql\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
080803 14:59:00 InnoDB: Log file F:\xampp\mysql\ib_logfile0 did not exist: new to be created
InnoDB: Setting log file F:\xampp\mysql\ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
080803 14:59:00 InnoDB: Log file F:\xampp\mysql\ib_logfile1 did not exist: new to be created
InnoDB: Setting log file F:\xampp\mysql\ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
080803 14:59:05 InnoDB: Started; log sequence number 0 0
080803 14:59:08 [Note] mysql\bin\mysqld.exe: ready for connections.
Version: '5.0.51b-community' socket: '' port: 3306 MySQL Community Edition (GPL)
080803 15:01:11 [Note] mysql\bin\mysqld.exe: Normal shutdown

080803 15:01:11 InnoDB: Starting shutdown...
080803 15:01:13 InnoDB: Shutdown completed; log sequence number 0 43655
080803 15:01:13 [Note] mysql\bin\mysqld.exe: Shutdown complete

080803 15:16:59 [Note] mysql\bin\mysqld.exe: ready for connections.
Version: '5.0.51' socket: '' port: 3306 Source distribution
080803 15:19:50 [Note] mysql\bin\mysqld.exe: Normal shutdown

080803 15:19:50 [Note] mysql\bin\mysqld.exe: Shutdown complete

080803 15:21:08 [Note] mysql\bin\mysqld.exe: ready for connections.
Version: '5.0.51b-community' socket: '' port: 3306 MySQL Community Edition (GPL)
080803 15:22:58 [Note] mysql\bin\mysqld.exe: Normal shutdown

080803 15:22:58 [Note] mysql\bin\mysqld.exe: Shutdown complete

080803 15:22:59 [Note] mysql\bin\mysqld.exe: ready for connections.
Version: '5.0.51b-community' socket: '' port: 3306 MySQL Community Edition (GPL)
080803 15:23:02 [Note] mysql\bin\mysqld.exe: Normal shutdown

080803 15:23:02 [Note] mysql\bin\mysqld.exe: Shutdown complete

InnoDB: The first specified data file F:\xampp\mysql\ibdata1 did not exist:
InnoDB: a new database to be created!
080803 15:35:12 InnoDB: Setting file F:\xampp\mysql\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
080803 15:35:13 InnoDB: Log file F:\xampp\mysql\ib_logfile0 did not exist: new to be created
InnoDB: Setting log file F:\xampp\mysql\ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
080803 15:35:13 InnoDB: Log file F:\xampp\mysql\ib_logfile1 did not exist: new to be created
InnoDB: Setting log file F:\xampp\mysql\ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
080803 15:35:16 InnoDB: Started; log sequence number 0 0
080803 15:35:19 [Note] mysql\bin\mysqld.exe: ready for connections.
Version: '5.0.51b-community' socket: '' port: 3306 MySQL Community Edition (GPL)


Kannst Du da was erkennen?

Übrigens: Ich habe XAMPP noch einmal gelöscht und in einem anderen Verzeichnis installiert, gleiches Ergebnis. Bin da ratlos.
Gruß, Hoffi aus Radeberg
User avatar
kjhofmann
 
Posts: 41
Joined: 06. February 2006 12:07

Postby Xardas der Dunkle » 03. August 2008 18:20

Ähm, das ist der Error-log von MySQL. Guck mal in: F:\xampp\apache\logs\error.log ;)
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Postby deepsurfer » 04. August 2008 09:20

Nach dem Installieren auf F: die setup.bat ausführen damit im XAMPP auch die Partition eingetragen wird.

Solltest Du ein TuningTool nutzen das Dein CMD (Terminalfenster/DosBox) immer auf c:\ stellt, so bitte dieses Tool veranlassen wieder auf standard zu gehen, denn das setup Programm benutzt die DosBox standard vorgabe um selber heraus zu bekommen wo es aufgerufen wird.
Mit dem Tuning ist das nicht mehr möglich.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Nobbie » 04. August 2008 11:45

>Kannst Du da was erkennen?

Aber natürlich!

>The first specified data file F:\xampp\mysql\ibdata1 did not exist:

Offensichtlich ist InnoDB als DBMS-Treiber (statt MyISAM) aktiviert und es fehlt aber die spezifizierte Datenbank. Und zwar bei jedem Start wird das angemault - da ist richtig was kaputt!

Kann es sein, dass die Partition "voll" ist? Oder was hat das ganze MySQL so zerschossen?
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Postby Xardas der Dunkle » 04. August 2008 17:38

Offensichtlich ist InnoDB als DBMS-Treiber (statt MyISAM) aktiviert und es fehlt aber die spezifizierte Datenbank.

Unter Windoof ist InnoDB eig. immer Standard, außer man stellt es um, so wie ich (ich hasse InnoDB).
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Postby kjhofmann » 05. August 2008 10:04

Sorry!
Ich habe eher den Verdacht gehabt, dass es hier nicht ein Fehler im XAMMP ist, sondern im System des Rechners.
Ob es stimmt, weiß ich nicht. Aber ich habe alles noch einmal rausgeschmissen und das ganze System noch einmal neu installiert. Kein Wunder bei Windoofs.
Nun funktioniert auch XAMPP wieder.
Danke für Eure Bemühungen.
Gruß, Hoffi aus Radeberg
User avatar
kjhofmann
 
Posts: 41
Joined: 06. February 2006 12:07


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests