Error: MySQL service not started [-1]

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Error: MySQL service not started [-1]

Postby BartTheDevil89 » 01. August 2008 12:52

Hallo,

also ich habe Xampp installiert und wollte es nun starten. Über das Controll panel kann ich zwar Apache starten, allerdings kommt es dann dazu, dass ich MySQL starten möchte und dann kommt eben die Fehlermeldung: Error: MySQL service not started [-1]

Woran kann das liegen, wie bekomm ich es gestartet? Hab es bis dato nur einfach installiert und gut.

Nutze Win Vista.

Danke

Ps.: Und dann noch ne zweite Frage. Wie kann ich es schaffen, dass der htdocs-Ordner leer ist und ich den damit übersichtlicher bekomm? Ebenso die MySQL-db? (hatte es schon vor länger zeit mal installiert, deswegen weiß ich, dass da ne ganze menge dbs drin sind) :wink: Kann man das alles einfach löschen?

Danke
BartTheDevil89
 
Posts: 32
Joined: 01. August 2008 12:42

Postby deepsurfer » 01. August 2008 14:47

Wegen 1) .....schau mal in der Prozessliste ob auch der MySQL Dienst abgeschaltet ist.


wegen 2)
Wenn Du die Inhalte des HTDOCS komplett leer machst, dann ist das XAMPP-Webinterface nicht mehr zu gebrauchen, weil gelöscht, so auch einige Funktionen des XAMPP-Controll Panels, weil dort auf dinge innerhalb des htdocs/xampps gerüft wird.

Wenn Du in MySQL alle DBs löschst werden die (falls noch vorhanden) Testprogramme im XAMPP.Webinterface nicht mehr funktionieren.

Zwei von den DBs werden für den reibungslosen Gebrauch von phpMyAdmin benötigt. Es sei denn Du willst phpMyAdmin ohne weitere Sonderrechten nutzen.

Prinzipiell kannst Du aber alles löschen was Du da aufgezählt hast.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby BartTheDevil89 » 01. August 2008 15:20

deepsurfer wrote:Wegen 1) .....schau mal in der Prozessliste ob auch der MySQL Dienst abgeschaltet ist.


wegen 2)
Wenn Du die Inhalte des HTDOCS komplett leer machst, dann ist das XAMPP-Webinterface nicht mehr zu gebrauchen, weil gelöscht, so auch einige Funktionen des XAMPP-Controll Panels, weil dort auf dinge innerhalb des htdocs/xampps gerüft wird.

Wenn Du in MySQL alle DBs löschst werden die (falls noch vorhanden) Testprogramme im XAMPP.Webinterface nicht mehr funktionieren.

Zwei von den DBs werden für den reibungslosen Gebrauch von phpMyAdmin benötigt. Es sei denn Du willst phpMyAdmin ohne weitere Sonderrechten nutzen.

Prinzipiell kannst Du aber alles löschen was Du da aufgezählt hast.

Hallo,

zu 1.: Wo finde ich das denn? Also hab jetzt zwar gesucht aber das leider nicht gefunden.
zu 2.: Dankeschön
BartTheDevil89
 
Posts: 32
Joined: 01. August 2008 12:42

Postby deepsurfer » 01. August 2008 23:19

Hab kein Vista, bei XP konntest du einfach mit rechter maustaste auf die Uhrzeit (rechts unten in der Taskleiste) und dann TASK MANAGER aufrufen, der dir Anzeig welche Prozesse aktiv sind.

Ansonsten auch mal die BAT datei von XAMPP benutzen um den DIENST von MySQL zu stoppen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby BartTheDevil89 » 02. August 2008 01:01

deepsurfer wrote:Hab kein Vista, bei XP konntest du einfach mit rechter maustaste auf die Uhrzeit (rechts unten in der Taskleiste) und dann TASK MANAGER aufrufen, der dir Anzeig welche Prozesse aktiv sind.

Ansonsten auch mal die BAT datei von XAMPP benutzen um den DIENST von MySQL zu stoppen.

Achso, ja die Prozesse sind bei Vista auch so. Da ist jetzt nach Start des Apache einmal eben der controllprozess drin und zweimal apache.exe. Allerdings lässt sich der mysql-Prozess nicht starten und da ändert sich auch an den prozessen nichts.
BartTheDevil89
 
Posts: 32
Joined: 01. August 2008 12:42

Postby BartTheDevil89 » 03. August 2008 13:02

Kann mir keiner helfen? :(
BartTheDevil89
 
Posts: 32
Joined: 01. August 2008 12:42

Postby deepsurfer » 03. August 2008 14:37

chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby BartTheDevil89 » 03. August 2008 18:49

deepsurfer wrote:http://community.apachefriends.org/f/viewtopic.php?t=28748&highlight=mysql+startet


Hi,

danke für den Link. Allerdings gehts damit nicht...aber hab ihn jetzt zum Laufen gebracht und zwar so:

Über die Datei mysql_start.bat....wenn ich diese nutze, lädt er alles richtig und es läuft. Allerdings über das Control-Panel läuft es noch immer nicht. Also übers Controll-Panel kann ich es nicht starten. Gibts jetzt noch irgendwie ne Ideen, wie ich es schaffe, dass das Control-Panel es noch starten kann?
BartTheDevil89
 
Posts: 32
Joined: 01. August 2008 12:42

Postby BartTheDevil89 » 03. August 2008 20:28

deepsurfer wrote:http://community.apachefriends.org/f/viewtopic.php?t=28748&highlight=mysql+startet


Achso, hab es jetzt doch noch gefunden...allerdings bei der Eingabe des Befehls bekomm ich die Meldung "Zugriff verweigert".....wie kann ich das irgendwie schaffen?
BartTheDevil89
 
Posts: 32
Joined: 01. August 2008 12:42

Postby BartTheDevil89 » 04. August 2008 13:23

Hab nochmal was gefunden und zwar lässt sich über die Datei xampp_start Xampp inkl. dem MySQL richtig starten. Nur eben über das Controllpanel nicht und wie schon gesagt der Service lässt sich eben auch nicht installieren oder deinstallieren, da der zugriff verweigert wird.
BartTheDevil89
 
Posts: 32
Joined: 01. August 2008 12:42

Postby Lamello » 07. August 2008 15:16

Versuche mal die Haken im Control Panel bei MySQL und Apache weg zu klicken.
Kann sein, das er Dich zwei mal danach fragt. Wenn sie weg sind dann einfach nochmal beides per "Start" starten.
Wenns funzt, schreib einen kurzen Post für andere Hilfesuchende!
User avatar
Lamello
 
Posts: 3
Joined: 07. August 2008 14:56
Location: Flensburg

Postby BartTheDevil89 » 07. August 2008 17:25

Lamello wrote:Versuche mal die Haken im Control Panel bei MySQL und Apache weg zu klicken.
Kann sein, das er Dich zwei mal danach fragt. Wenn sie weg sind dann einfach nochmal beides per "Start" starten.
Wenns funzt, schreib einen kurzen Post für andere Hilfesuchende!


Bei Apache ist garkein Hacken und bei MySQL ist zwar ein Hacken, allerdings wenn ich den wegmache, kommt eben die Abfrage, ob ich das deinstallieren möchte, dann sag ich ja und der Hacken ist weg. Nach ein paar Sekunden ist er allerdings dann wieder da. Dieses Spielchen kann ich ewig wiederholen....kann eventuell damit zusammenhängen, dass diese mysql_installservice.bat oder die passende deinstall-Datei manuell aufrufe, kommt ja auch Zugriff verweigert.
BartTheDevil89
 
Posts: 32
Joined: 01. August 2008 12:42

Postby Storyline1981 » 07. August 2008 21:10

Bei mir hat das deinstallieren der Dienste (Häkchen aus dem Control-Panel vor dem MySql/Apache Dienst) gereicht. Nachfolgend war es möglich diese einfach über das Control Panel zu starten. Das zweite Problem von mir den Apache Server zu starten lies sich durch beenden von Skype lösen. Skype scheint zu blockieren.

Mfg

Florian
Storyline1981
 
Posts: 1
Joined: 07. August 2008 21:07

Postby BartTheDevil89 » 08. August 2008 07:07

Storyline1981 wrote:Bei mir hat das deinstallieren der Dienste (Häkchen aus dem Control-Panel vor dem MySql/Apache Dienst) gereicht. Nachfolgend war es möglich diese einfach über das Control Panel zu starten. Das zweite Problem von mir den Apache Server zu starten lies sich durch beenden von Skype lösen. Skype scheint zu blockieren.

Mfg

Florian

Ja, bei mir eben leider nicht...und Skype ist nicht drauf. Außerdem hat der portcheck ergeben, dass der mysql-port frei ist. Lediglich bei zwei apache-ports steht System drin.
BartTheDevil89
 
Posts: 32
Joined: 01. August 2008 12:42

Postby BartTheDevil89 » 11. August 2008 16:28

Hi,

hab noch was rausgefunden:

Und zwar ist unter der Dienste-Übersicht von Vista ein Eintrag für MySQL drin, der allerdings zwar aufs xampp-Verzeichnis verweiste, allerdings nicht korrekt ist. Kann es damit zusammenhängen?

Danke
BartTheDevil89
 
Posts: 32
Joined: 01. August 2008 12:42

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests