nach install von perl wird der SQL-Server nicht mehr gefunde

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

nach install von perl wird der SQL-Server nicht mehr gefunde

Postby Grazioli » 14. July 2008 17:38

Hallo zusammen,

ich habe Xampp 1.6.7 als Installer-Version installiert und dort ging auch mein Joomla! Nun habe ich das Addon Perl als Installer-Version installiert.

Wenn ich jetzt http://localhost/ aufrufe geht es bis dahin!
Wenn ich jetzt http://localhost/domain aufrufe erhalte ich folgendes: Database Error: Unable to connect to the database:Could not connect to MySQL


Ich habe auch über Xampp noch modperl und modperlasp aufgerufen, wobei das modperl geht und das andere nicht! Dort erhalte ich eine Fehlermeldung: Objekt nicht gefunden!

Bei Xampp Status habe ich noch festgestellt, das MySQL-Datenbank DEAKTIVIERT ist, obwohl bei den Diensten in der Computerverwaltung der mySQL-Server als gestartet angezeigt wird!

Bei modperl habe ich 4 Dateien zum aufrufen und bei perlinfo.pl erhalte ich die Server Variablen:
Code: Select all
Server Variablen


Allgemeine Perlinfos:
Betriebssystem: MSWin32
Perl Version: 5.010000
Pfade zu Perl:
Pade zu


Umgebungsvariablen:
SCRIPT_NAME:   /modperl/perlinfo.pl
REQUEST_METHOD:   GET
HTTP_ACCEPT:   text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
SCRIPT_FILENAME:   E:/xampp/htdocs/modperl/perlinfo.pl
SERVER_SOFTWARE:   Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8h mod_autoindex_color PHP/5.2.6 mod_perl/2.0.4 Perl/v5.10.0
QUERY_STRING:   
REMOTE_PORT:   1133
PATHEXT:   .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
HTTP_USER_AGENT:   Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008052906 Firefox/3.0
SERVER_SIGNATURE:   
Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8h mod_autoindex_color PHP/5.2.6 mod_perl/2.0.4 Perl/v5.10.0 Server at localhost Port 80
HTTP_ACCEPT_LANGUAGE:   de-de,de;q=0.8,en-us;q=0.5,en;q=0.3
HTTP_KEEP_ALIVE:   300
MOD_PERL_API_VERSION:   2
PATH:   C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Programme\Gemeinsame Dateien\Adobe\AGL;C:\Programme\Gemeinsame Dateien\Autodesk Shared\;C:\Programme\Gemeinsame Dateien\Teleca Shared;C:\Programme\QuickTime\QTSystem\;C:\Programme\Smart Projects\IsoBuster
GATEWAY_INTERFACE:   CGI/1.1
DOCUMENT_ROOT:   E:/xampp/htdocs
SERVER_NAME:   localhost
HTTP_REFERER:   http://localhost/modperl/
SystemRoot:   C:\WINDOWS
HTTP_ACCEPT_ENCODING:   gzip,deflate
SERVER_ADMIN:   admin@localhost
HTTP_CONNECTION:   keep-alive
COMSPEC:   C:\WINDOWS\system32\cmd.exe
HTTP_ACCEPT_CHARSET:   ISO-8859-1,utf-8;q=0.7,*;q=0.7
WINDIR:   C:\WINDOWS
SERVER_PORT:   80
HTTP_COOKIE:   session-id=0f13aed54ac4755859bd5bdee172489a; bb5bc9e45b91dd9ea2067e3246e4c73e=4064290366e6688278456de98af9de5d
REMOTE_ADDR:   127.0.0.1
SERVER_PROTOCOL:   HTTP/1.1
REQUEST_URI:   /modperl/perlinfo.pl
SERVER_ADDR:   127.0.0.1
HTTP_HOST:   localhost
MOD_PERL:   mod_perl/2.0.4


Weis jemand Rat für mich?!?

Danke und Gruss
Grazioli
Grazioli
 
Posts: 23
Joined: 05. January 2006 19:42

Postby deepsurfer » 19. July 2008 14:48

Gehen denn die Beispiel-Bereiche im XAMPP-Webinterface ?
Diese greifen aud MySQL zu.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests