mehrfache MySQL Query mit laufendem XAMPP (lokal)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

mehrfache MySQL Query mit laufendem XAMPP (lokal)

Postby CoD » 25. June 2008 09:11

Hallo @all.

nachdem ich letztens mehrere Stunden nach einem Fehler in einem Script gesucht habe, welches vorher einwandfrei funktionierte, fiel mir etwas sehr merkwürdiges auf... ich hoffe, jemand anderes hatte dieses Problem auch schon, und kann evtl Erfahrungsberichte, Lösungsansätze liefern.

zur Ausgangslage:

zur Entwicklung und zum Test von Seiten läuft der xampp (1.6.6) mit aktiviertem Apache und MySQL (PHP 5.2.5).

zum Problem:

beim Aufruf eines Scriptes mit Datenbank-Query und vorher gestarteter Session fiel mir dann auf, dass die Query, die aus POST Daten gespeist wird, mehrfach ausgeführt wird; und das auch nach einem erneuten Aufruf der Seite ohne erneuten Submit der POST Daten. Es ist, als würde die query und POST Daten gecacht werden und dann nochmal ausgeführt werden.

Ich habe den entsprechenden Funktionsaufruf überprüft, die funktion wird nur einmal aufgerufen und ausgeführt.

Weiterhin bemerkenswert ist, dass dieses Problem nicht nur lokal auftritt, sondern auch bei Seiten, die im Netz zugänglich sind, und die ebenfalls mit Querys und Sessions arbeiten.

zur temporären Lösung:

Wenn dieses Problem auftritt, dann hilft es, erst den Browser (Firefox 2.0.0.14) zu beenden (dabei werden alle persönlichen Daten gelöscht), danach den Apache und mysql auszuschalten, danach xampp über exit zu beenden. Dann wieder einschalten.

Danach läuft alles fehlerfrei.

Dieses Problem tritt nicht periodisch auf, sondern zufällig

Ich hoffe, ich habe das Problem einigermaßen verstädnlich beschrieben. bin für jede Hilfe dankbar, da ich mit meinem Latein einigermaßen am Ende bin

so far

CoD
CoD
 
Posts: 3
Joined: 25. June 2008 08:53

Postby CoD » 30. July 2008 16:30

Hmmm, schon merkwürdig... schon 263 Hits und keine Antwort. Sieht so aus, als wäre ich der einzige mit diesem Problem...


:?:
CoD
 
Posts: 3
Joined: 25. June 2008 08:53

Postby deepsurfer » 30. July 2008 16:37

hhmm...weil dei über 200 Leute auch nicht nachvoll ziehen können was da los ist.

Laut Fehlerbeschreibung liegt es nicht am XAMPP, also muss etwas im CODE sein der das verursacht.

Lässt Du jeden Abruf der Funktion mit einer neuen Session durchführen oder wird immer die selbe Session benutzt und dadurch das Cacheverhalten hervorgerufen ?

Wenn Du schon soweit eingrenzen konntest wo dieses Verhalten auftaucht, wäre der Code schnipsel dieser stelle hilfreich.

Damit die PHP-Gurus da eher was draus lesen können.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Xardas der Dunkle » 30. July 2008 17:13

Am besten währe es natürlich wenn du den entsprechenden Code-Ausschnitt mal posten würdest, vllt kann man dann besser nach verfolgen was da schief läuft. :D
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests