4 Fehlermeldungen beim Start

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

4 Fehlermeldungen beim Start

Postby jpwitte » 15. June 2008 15:27

nach dem starten kommen folgende 2 fehler 2x hintereinander:

Die Anwendung konnte nicht gestartet werden, weil LIBPQ.dll nicht gefunden wurde. Neuinstallation könnte das Problem beheben.

Der Prozedureinsprungspunkt "xmlXPathCompiledEvalToBoolean" wurde in der DLL "php5ts.dll" nicht gefunden.


das ganze seit dem update auf die neueste version 1.6.6a von 1.6.1

dann habe ich mir zuerst mal das neuste paket für windows noch mal geholt, kann darin aber keine libpq.dll finden :shock:

wahrscheinlich bin ich da zu doof dafür, die müsste ja da enthalten sein...

ich denke mal, wenn ich diese datei wieder an der richtigen stelle habe, dann sollte auch der andere fehler behoben sein, sowie die beiden im error-log, wobei diese beiden dll's an der richtigen stelle sind, wundert mich, dass er die nicht finden kann.

Error-Log:

[Sun Jun 15 16:04:45 2008] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\xampp\\php\\ext\\php_pgsql.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\xampp\\php\\ext\\php_xsl.dll' - Die angegebene Prozedur wurde nicht gefunden.\r\n in Unknown on line 0
[Sun Jun 15 16:04:48 2008] [notice] Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Sun Jun 15 16:04:48 2008] [notice] Server built: Jan 18 2008 00:37:19
[Sun Jun 15 16:04:48 2008] [notice] Parent: Created child process 1492
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\xampp\\php\\ext\\php_pgsql.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\xampp\\php\\ext\\php_xsl.dll' - Die angegebene Prozedur wurde nicht gefunden.\r\n in Unknown on line 0
[Sun Jun 15 16:04:50 2008] [notice] Child 1492: Child process is running
[Sun Jun 15 16:04:50 2008] [notice] Child 1492: Acquired the start mutex.
[Sun Jun 15 16:04:50 2008] [notice] Child 1492: Starting 250 worker threads.
[Sun Jun 15 16:04:50 2008] [notice] Child 1492: Starting thread to listen on port 443.
[Sun Jun 15 16:04:50 2008] [notice] Child 1492: Starting thread to listen on port 80.


nunja, vielleicht kann mir jemand sagen, wo nun diese libpq.dll hingehört? danke.
jpwitte
 
Posts: 4
Joined: 09. June 2008 19:21

Postby deepsurfer » 15. June 2008 23:46

Muss jetzt gerade zugeben das ich etliche Zeit nicht mehr da war, aber ein Update von 1.6.1 auf 1.6.6a wäre falsch, denn dazwischen gab es noch die

1.6.2
1.6.3
1.6.3a
1.6.4
1.6.5
1.6.6

und ein Update ist immer nur gültig auf die nächst höhere Version, dann fehlen bei Dir summa Sumarum 6 Updates dazwischen.

http://sourceforge.net/project/showfile ... e_id=89552
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby jpwitte » 16. June 2008 10:54

hm, update war wohl etwas falsch ausgedrückt, ich hab die neueste version 1.6.6a draufgepackt und dann mein htdocs verzechnis sowie die datenbanken da reinkopiert, und die config files reinkopiert, ist für mich halt igrendwie auch ein update, wenn auch nicht durch ein update-paket/installer, sondern duch installation der neuesten version.

aber dennoch müsste diese datei doch in dem paket enthalten sein?
jpwitte
 
Posts: 4
Joined: 09. June 2008 19:21

Postby Wiedmann » 16. June 2008 11:23

Code: Select all
Die Anwendung konnte nicht gestartet werden, weil LIBPQ.dll nicht gefunden wurde. Neuinstallation könnte das Problem beheben.

Code: Select all
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\xampp\\php\\ext\\php_pgsql.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0

aber dennoch müsste diese datei doch in dem paket enthalten sein?

Eine "libpq.dll" ist beim XAMPP nicht dabei, da die Extension "php_pgsql.dll" vom XAMPP keine Abhängigkeit zu dieser DLL hat.

(Oder anders gesagt: Diese Extension kann man beim XAMPP/Win laden, selbst wenn kein PostgreSQL Server/Client auf dem PC installiert ist.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jpwitte » 16. June 2008 14:30

gut, dann bin ich doch nicht zu blöd zum suchen :D

es funzt ja seoweit auch alles, jedenfalls konnte ich bis jetzt noch keine probleme feststellen, nur wie kommt es nun zu der fehelrmeldung?
da die dll ja wahrscheinlich was mit PostgreSQL zu tun hat, ich dieses aber eh nicht benötige, hilft es vielleicht, eine extension zu deaktivieren, damit der/die fehler nicht mehr kommt/en?

und warum kommt der hier:
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\xampp\\php\\ext\\php_pgsql.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0


obwohl diese datei an der angegebenen stelle existiert?

alles iwie setlsam, besonders, da es an sich nur die reine grundversion 1.6.6a ist, wundert mich, dass sonst keiner solche fehler hatte (hab die suche hoffe ich ausreichend bemüht), aber vielleicht hab ich ja mal wieder irgendwo blödsinn gebaut, ohne es zu merken :?
jpwitte
 
Posts: 4
Joined: 09. June 2008 19:21

Postby jpwitte » 17. June 2008 21:26

problem behoben, lag an dem anschließenden update auf die neueste php version, naja, dann halt doch wieder mit 5.2.5 :(
jpwitte
 
Posts: 4
Joined: 09. June 2008 19:21


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests