XP: fehlende Schreibrechte für phpmyadmin-DB

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XP: fehlende Schreibrechte für phpmyadmin-DB

Postby Eddie » 27. May 2008 21:47

Hallo allerseits,

ich habe leider ein Problem, das möglicherweise mit der Benutzerverwaltung von Windows XP zusammenhängt. Ich habe XAMPP als Administrator installiert, dummerweise fehlen jetzt den anderen Benutzern die nötigen Schreibrechte :-(
Beim Bearbeiten der Apache-Config-Files konnte ich es noch hinbiegen mittels "attrib -R * /S /D" unter der Kommandozeile. Die Verzeichnisse werden allerdings von Windows weiterhin als schreibgeschützt gelistet, Ändern geht nicht...

So, nun läuft alles aber soweit halbwegs, aber wenn ich irgendwas mit phpmyadmin mache (z.B. eine Tabelle löschen, oder ein Insert), funktioniert das zwar, aber mit der unschönen Meldung:

Table 'pma_column_info' is read only


Und wenn ich das richtig sehe, liegt die entsprechende Datei unter C:\xampp\mysql\data\phpmyadmin\: sie ist nicht als schreibgeschützt markiert, löschen kann ich sie trotzdem nicht. Und MySQL kann sie nicht beschreiben...

Was kann ich da nur tun???

Eddie
Eddie
 
Posts: 19
Joined: 24. February 2006 21:38

Postby Mario Lanz » 27. May 2008 22:03

Was für Rechte sind dann im Windows im Register Sicherheit vergeben?
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Postby Eddie » 27. May 2008 22:30

Hallo Mario,

Was für Rechte sind dann im Windows im Register Sicherheit vergeben?


Mmmh, das Register gibt's bei mir nicht :-( Ich bin als Admin angemeldet, habe aber nur 3 Register: Allgemein, Freigabe und Anpassen. Unter "Freigabe" gibt's aber nur "Lokale Freigabe und Sicherheit". Da heisst es, ich soll das Verzeichnis in "Gemeinsame Dokumente" verschieben, was ja aber völlig schwachsinnig wäre...

Mmmh, stimmt da was nicht, oder muss ich woanders gucken?

Eddie
Eddie
 
Posts: 19
Joined: 24. February 2006 21:38

Postby Mario Lanz » 28. May 2008 06:27

ne das stimmt so schon..., gehe mal in die Orderoptionen und deaktiviere die einfache Freigabe.. ;)

Danach solltest du das Register Sicherheit erhalten...
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Postby Eddie » 28. May 2008 09:44

Sehr sehr geil!!! Echt, so was Simples, da wär ich aber im Leben nicht drauf gekommen. Ist aber auch völlig hirnrissig, wie Windows ständig versucht, einen zu bevormunden und für blöd zu verkaufen...

Jetzt funktioniert endlich alles, da kann ich nur sagen: geiligeil, vielen Dank!

Eddie
Eddie
 
Posts: 19
Joined: 24. February 2006 21:38


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests