test.php wird im IE7 nicht angezeigt

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

test.php wird im IE7 nicht angezeigt

Postby eclairbaer » 25. May 2008 21:58

Sehr geehrte Helfer!

habe alle FAQs durchstöbert und bin blutiger Neuling. Versuche mir mit Franzis "Dynamische Webseiten mit PHP 5.1 / MySQL 5 für Schnelleinsteiger" die Grundlagen beizubringen. XAMPP wurde installiert, Apache und SQL laufen, Root und SQL wurden mit Passwort gesichert.
Die php-Dateien im XAMPP - Ordner werden angezeigt. Wenn ich jedoch auf die test.php laut Buch:
<?php
phpinfo();
?>
klicke, wird der Explorer geöffnet und ich kann zwischen Öffnen, Speichern und Abbrechen wählen. Bei der Auswahl der ersten beiden Optionen erscheint kurz ein grüner Balken. Danach taucht das gleiche Fenster wieder auf. Werkann mir helfen. Eigentlich wollte ich heute beginnen das Programmieren zu lernen, komme so jedoch nicht weiter.

Im Voraus vielen herzlichen Dank - MfG eclairbaer
eclairbaer
 
Posts: 3
Joined: 25. May 2008 21:22
Location: an der Ostsee

Postby Wiedmann » 25. May 2008 22:48

Man kann auf PHP-Dateien nicht klicken. Man muss sie über "http://" im Browser ansurfen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Mario Lanz » 25. May 2008 22:58

aber über localhost sollte auch gehen, nicht? also es geht auf jeden fall bei mir... ;)
User avatar
Mario Lanz
 
Posts: 104
Joined: 13. October 2004 22:47
Location: CH, Volketswil

Postby eclairbaer » 26. May 2008 13:19

Sehr geehrte Herren Wiedmann und Lanz,

vielen Dank für die schnelle Antwort. Die Datei befindet sich unter C:/xampp/htdocs/

habe im Browser:

http://127.0.0.1/xampp/htdocs/test.php

eingegeben und erhalte die Meldung:

"Objekt nicht gefunden!
Der angeforderte URL konnte auf dem Server nicht gefunden werden. Sofern Sie den URL manuell eingegeben haben, überprüfen Sie bitte die Schreibweise und versuchen Sie es erneut.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.

Error 404
127.0.0.1
05/26/08 14:09:12
Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5"

Wenn ich das mit der Originaldatei index.php mache kommt die gleiche Meldung. Und nun ist bei mir wieder Ratlosigkeit angesagt.

Bitte helfen Sie mir weiter.
eclairbaer
 
Posts: 3
Joined: 25. May 2008 21:22
Location: an der Ostsee

Postby Wiedmann » 26. May 2008 14:53

Die Datei befindet sich unter C:/xampp/htdocs/

habe im Browser: http://127.0.0.1/xampp/htdocs/test.php

--> http://127.0.0.1/test.php
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby eclairbaer » 26. May 2008 15:22

Vielen herzlichen Dank Herr Wiedmann!!!

Es sind immer wieder die Grundlagenkenntnisse.

JETZT FUNKTIONIERT ALLES !!!

Nochmals Dankeschön ! MfG - eclairbaer
eclairbaer
 
Posts: 3
Joined: 25. May 2008 21:22
Location: an der Ostsee


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests