XAMPP läuft nicht mehr nach Tomcat-Installation

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP läuft nicht mehr nach Tomcat-Installation

Postby badblueboy » 22. May 2008 19:38

sers @ll

benutze nun schon eine Weile lang XAMPP als Webserver da ich mit PHP programmiere. Ich musste heute aus schulischen Gründen kurz den Tomcat 6.0 installieren. Hab ihn mittlerweile wieder deinstalliert, habe aber nun nach ettlichen Neustarts gemerkt, dass mein Apache einfach nciht mehr starten will. Öffne ich das Apache-Control-Panel, so zeigt es mir an, dass der MySQL-Service läuft. Klicke ich bei Apache auf START so steht zwar im unteren Fenster, dass der Apache gestartet wurde, eine Verbindung zum localhost kann allerdings keine hergestellt werden :-S

Könnt ihr mir da weiterhelfen?

Hier noch ein Screenshot vom Contro Panel:

http://img329.imageshack.us/my.php?image=apachegr5.jpg

ich arbeite mit Windows Vista Home Premium, Service Pack 1.


mfg

BBB
badblueboy
 
Posts: 6
Joined: 22. May 2008 19:30

Postby badblueboy » 23. May 2008 15:23

kann denn niemand helfen? Hab xampp mittlerweile deinstalliert und wieder installiert - allerdings hat das Setup nach der Installation gemeldet, dass Apache 2.2 nicht gestartet werden kann, da die benötigten Ports belegt sind - wie kann ich diese Ports wieder freigeben?

Arbeite mit Windows Vista Home Premium SP1.

PS: Bei der Tomcat Installation musste ich den Port 8080 angeben...


mfg BBB
badblueboy
 
Posts: 6
Joined: 22. May 2008 19:30

Postby badblueboy » 25. May 2008 03:01

kann denn niemand helfen? :-(

ich brauche unbedingt einen php-server auf meinem laptop...


mfg BBB
badblueboy
 
Posts: 6
Joined: 22. May 2008 19:30

Postby Wiedmann » 25. May 2008 03:20

wie kann ich diese Ports wieder freigeben?

Mit z.B. netstat, TCPView, xampp-portchack kann man herausfinden, welche Ports durch welches Programm belegt ist.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby badblueboy » 26. May 2008 12:34

mit dem xampp-portcheck erhalte ich folgendes:
http://img86.imageshack.us/my.php?image=portcheckas0.jpg

Was nun? Bin was solches Zeugs angeht ein ziemlicher n00b, daher...


mfg BBB
badblueboy
 
Posts: 6
Joined: 22. May 2008 19:30

Postby badblueboy » 28. May 2008 11:01

kann denn niemand helfen?
badblueboy
 
Posts: 6
Joined: 22. May 2008 19:30

Postby Dungeonwatcher » 28. May 2008 11:13

Moin! 8)

Was steht denn in der .../apache/logs/error.log

Bye
User avatar
Dungeonwatcher
 
Posts: 94
Joined: 15. August 2007 02:53
Operating System: XP

Postby badblueboy » 28. May 2008 17:20

moin moin!

[Sun May 25 03:52:08 2008] [notice] Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Sun May 25 03:52:08 2008] [notice] Server built: Jan 18 2008 00:37:19
[Sun May 25 03:52:08 2008] [notice] Parent: Created child process 2508
[Sun May 25 03:52:12 2008] [notice] Child 2508: Child process is running
[Sun May 25 03:52:12 2008] [notice] Child 2508: Acquired the start mutex.
[Sun May 25 03:52:12 2008] [notice] Child 2508: Starting 250 worker threads.
[Sun May 25 03:52:12 2008] [notice] Child 2508: Starting thread to listen on port 443.
[Sun May 25 03:52:12 2008] [notice] Child 2508: Starting thread to listen on port 80.
[Mon May 26 19:54:55 2008] [notice] Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Mon May 26 19:54:55 2008] [notice] Server built: Jan 18 2008 00:37:19
[Mon May 26 19:54:55 2008] [notice] Parent: Created child process 2656
[Mon May 26 19:55:04 2008] [notice] Child 2656: Child process is running
[Mon May 26 19:55:04 2008] [notice] Child 2656: Acquired the start mutex.
[Mon May 26 19:55:04 2008] [notice] Child 2656: Starting 250 worker threads.
[Mon May 26 19:55:04 2008] [notice] Child 2656: Starting thread to listen on port 443.
[Mon May 26 19:55:04 2008] [notice] Child 2656: Starting thread to listen on port 80.
[Tue May 27 10:18:10 2008] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue May 27 10:18:17 2008] [notice] Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Tue May 27 10:18:17 2008] [notice] Server built: Jan 18 2008 00:37:19
[Tue May 27 10:18:18 2008] [notice] Parent: Created child process 3020
[Tue May 27 10:18:24 2008] [notice] Child 3020: Child process is running
[Tue May 27 10:18:24 2008] [notice] Child 3020: Acquired the start mutex.
[Tue May 27 10:18:24 2008] [notice] Child 3020: Starting 250 worker threads.
[Tue May 27 10:18:29 2008] [notice] Child 3020: Starting thread to listen on port 443.
[Tue May 27 10:18:29 2008] [notice] Child 3020: Starting thread to listen on port 80.
[Wed May 28 10:32:01 2008] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed May 28 10:32:14 2008] [notice] Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Wed May 28 10:32:14 2008] [notice] Server built: Jan 18 2008 00:37:19
[Wed May 28 10:32:14 2008] [notice] Parent: Created child process 3228
[Wed May 28 10:32:30 2008] [notice] Child 3228: Child process is running
[Wed May 28 10:32:30 2008] [notice] Child 3228: Acquired the start mutex.
[Wed May 28 10:32:30 2008] [notice] Child 3228: Starting 250 worker threads.
[Wed May 28 10:32:30 2008] [notice] Child 3228: Starting thread to listen on port 80.
[Wed May 28 10:32:30 2008] [notice] Child 3228: Starting thread to listen on port 443.
[Wed May 28 15:47:02 2008] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed May 28 15:47:04 2008] [notice] Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Wed May 28 15:47:04 2008] [notice] Server built: Jan 18 2008 00:37:19
[Wed May 28 15:47:04 2008] [notice] Parent: Created child process 2488
[Wed May 28 15:47:08 2008] [notice] Child 2488: Child process is running
[Wed May 28 15:47:08 2008] [notice] Child 2488: Acquired the start mutex.
[Wed May 28 15:47:08 2008] [notice] Child 2488: Starting 250 worker threads.
[Wed May 28 15:47:08 2008] [notice] Child 2488: Starting thread to listen on port 80.
[Wed May 28 15:47:08 2008] [notice] Child 2488: Starting thread to listen on port 443.
[Wed May 28 18:14:29 2008] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed May 28 18:14:33 2008] [notice] Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Wed May 28 18:14:33 2008] [notice] Server built: Jan 18 2008 00:37:19
[Wed May 28 18:14:33 2008] [notice] Parent: Created child process 2772
[Wed May 28 18:14:41 2008] [notice] Child 2772: Child process is running
[Wed May 28 18:14:41 2008] [notice] Child 2772: Acquired the start mutex.
[Wed May 28 18:14:41 2008] [notice] Child 2772: Starting 250 worker threads.
[Wed May 28 18:14:41 2008] [notice] Child 2772: Starting thread to listen on port 443.
[Wed May 28 18:14:41 2008] [notice] Child 2772: Starting thread to listen on port 80.


Viel sagt mir das aber nicht ^^

Ich brauche unbedingt einen php-webserver à la Apache, da ich private Websites verwalte und so langsam muss ich diese updaten...


mfg BBB
badblueboy
 
Posts: 6
Joined: 22. May 2008 19:30


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests