.pl dateien werden nicht ausgeführt

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

.pl dateien werden nicht ausgeführt

Postby darnouar » 25. October 2003 21:43

Hi, ich hab xampp full, und es heißt auf der seite meines scripts, dass alle dateien die sich in htdocs befinden mit der endung .pl auch mit perl ausgeführt werden. Aber dass passiert nicht. Vielleicht muss ich irgendwas einstellen. plz help!
darnouar
 

Postby steini » 25. October 2003 21:48

die scripte mit der .pl oder .cgi müssen im verzeichnis: "C:\xampp\cgi-bin" (wodurch c, natürlich dem laufwerk entspricht wo du dein xampp liegen hast, passe einfach den Pfad an) liegen

un dann solltest du in den scripten vielleicht noich folgendes ändern, da du ja windows hast und nich linux :):


#!/usr/bin/perl -->>> ersetzen durch ->> #!c:\xampp\perl\bin\perl.exe

natürlich auch da wieder den Pfad anpassen, dann sollt es funktionieren.
V-Server ab 7,90€ bei simplyroot
---
Image
User avatar
steini
 
Posts: 191
Joined: 24. October 2003 00:24
Location: Helmstedt
Operating System: Windows 10 Tech Preview

Postby darnouar » 25. October 2003 21:51

ähm wo muss das geändert werden
darnouar
 

Postby steini » 25. October 2003 21:52

in der scriptdatei selber, am besten öffnen mit Editor. steht meistens in der ersten zeil.
V-Server ab 7,90€ bei simplyroot
---
Image
User avatar
steini
 
Posts: 191
Joined: 24. October 2003 00:24
Location: Helmstedt
Operating System: Windows 10 Tech Preview

Postby Guest » 25. October 2003 21:53

und wie führe ich die dateien aus, wenn sie ins cgi-bin verzeichnis kommen?
Guest
 

Postby steini » 25. October 2003 21:54

V-Server ab 7,90€ bei simplyroot
---
Image
User avatar
steini
 
Posts: 191
Joined: 24. October 2003 00:24
Location: Helmstedt
Operating System: Windows 10 Tech Preview

Postby Guest » 25. October 2003 21:58

funktioniert nicht (das mit cgi-bin). Kannst du mir bitte die genaue datei nennen, indem ich den ich was ändern muss?
Guest
 

Postby steini » 25. October 2003 22:00

schick mir ma bitte das script an steini19@knuddels.de dann mach ich dir das schnell ;) , bracuhe aber acuh dann dein xampp-pfad
V-Server ab 7,90€ bei simplyroot
---
Image
User avatar
steini
 
Posts: 191
Joined: 24. October 2003 00:24
Location: Helmstedt
Operating System: Windows 10 Tech Preview

Postby darnouar » 25. October 2003 22:02

ich weis schon was ich ändern muss, aber welche datei meinst du? Meinst du die Datei, die ich mit Perl ausführen will?
Also ja ich geh jetzt pennen bis morgen...
darnouar
 

Postby steini » 25. October 2003 22:04

ja die datei die du ausführen willst,, kann aber auch sein das du vielleicht alle ändern musst! also vorsichtshalber mal in alle reingucken.
V-Server ab 7,90€ bei simplyroot
---
Image
User avatar
steini
 
Posts: 191
Joined: 24. October 2003 00:24
Location: Helmstedt
Operating System: Windows 10 Tech Preview

Postby Guest » 25. October 2003 22:04

achja, #!/usr/bin/perl steht in der datei. Alles verstanden :)
Guest
 

Postby steini » 25. October 2003 22:05

genau un das in den text den ich dir oben genannt hab umändern, dann sollte es gehn. aber wie gesagt guck bei den andern auch noch mal rein
V-Server ab 7,90€ bei simplyroot
---
Image
User avatar
steini
 
Posts: 191
Joined: 24. October 2003 00:24
Location: Helmstedt
Operating System: Windows 10 Tech Preview

Postby Guest » 05. November 2003 11:07

ziemlich unlogisch den .cgi dateien gehen auch im htdocs ordner (selber ausprobiert)
Guest
 


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests