MYSQL Fehler @ 2003

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MYSQL Fehler @ 2003

Postby xampp-azubi » 01. May 2008 10:02

Guten Tag liebe Leute
Schlage mich mit mit folgendem Problem herum.
Habe auf einem jungfräulichem WinXPP mit SP2 und allen Updates ein Xampp 1.4.11 mit Hindernissen zum laufen gebracht. ( Bei den Diensten wurde MYSQL nicht gestartet, was aber in zwischen behoben ist. Letzte Einträge in der Ereignisanzeige gestern: "....... \bin\mysql-nt: shutdown complete". Die heutigen Einträge in der Ereignisanzeige betreffen nur Info zum SecurityCenter).
Wenn ich nun im Browser "localhost" aufrufe erscheint XAMPP- Willkommensseite und unter "Status" ist:

PHP, HTTPS, Common Gateway Interface und Server Side Includes AKTIVIERT
ABER!!! MYSQL ist deaktiviert! Wenn ich dann bei den Tools auf " phpMyAdmin" gehe sehe ich auch warum "MYsQL meldet: #2003 - Der Server antwortet nicht."

Ich finde aber auf keinem mir bekannten Forum ( in deutsch, englisch verstehe ich zu wenig) Hinweise zu diesem Fehler. Ich vermute es ist ein fehlender oder falsche Pfad.
Wer kann mir helfen? Danke
Robert
xampp-azubi
 
Posts: 6
Joined: 26. March 2008 09:14

Postby Wiedmann » 01. May 2008 19:13

Läuft MySQL denn?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby xampp-azubi » 02. May 2008 10:46

Wiedmann wrote:Läuft MySQL denn?


Wie kann ich das kontrollieren? Wenn ich das Ding neu aufgesetzt habe, habe ich auch keine Datenbank die ich abfragen kann.

Grüsse
Robert

( Bin eben Anfänger vom Dienst)
xampp-azubi
 
Posts: 6
Joined: 26. March 2008 09:14

Postby Wiedmann » 02. May 2008 11:18

Wie kann ich das kontrollieren?

z.B. im Taskmanager von Windows.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby xampp-azubi » 02. May 2008 13:13

Wiedmann wrote:
Wie kann ich das kontrollieren?

z.B. im Taskmanager von Windows.


Da ist unter anderem in dieser Reihenfolge,

Apache.exe Speicher: 18.266k
mysql-nt.exe Speicher: 5.080k
Apache.exe Speicher: 12.536k

warum da Apche zwei mal aufgeführt ist...... Wird schon seine Richtigkeit haben.

Grüsse
Robert
xampp-azubi
 
Posts: 6
Joined: 26. March 2008 09:14

Postby Wiedmann » 02. May 2008 13:27

Also wenn MySQL läuft (siehe dein Taskmanager) und phpMyAdmin mein der antwortet nicht, dann blockiert eine Firewall die Verbindung.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby xampp-azubi » 02. May 2008 14:30

Wiedmann wrote:......................... dann blockiert eine Firewall die Verbindung.


Wiedmann Du hast mich auf eine Fährte gebracht, die , ich kanns nicht aufs Komma nachvollziehen, zum Erfolg geführt hat!!!!

1. Die Einstellungen der Windows eigenen Firewall hatten alle notwendigen Ausnahmen aufgeführt. Dennoch habe ich sie ausgeschaltet.
2. Die Einstellungen des Internetexplorers für " Lokales Intranet", habe ich auf "sehr niedrig" eingestellt, ohne Erfolg.
Danach habe ich bei den Einstellungen des Explorers "Internetoptionen / Sicherheit " "alle Zonen auf Standard zurück setzen" gewählt. (Ich habe keine Ahnung was an dieser Stelle geändert war)

JETZT HAT ES FUNKTIONIERT!!
Auch wenn ich jetzt:
Pishingfilter einstelle,
die Intranet Optionen verschärfe,
die Windows Firewall wieder einstelle (ohne etwas an den Berechtigungen zu ändern),
beim abfragen des Status ist nun MySQL aktiviert!
Mit phpMyAdmin sehe ich auch die XAMPP eigenen Datenbanken!

Fazit: es muss jetzt weitergehen mit der Installation von neuen Datenbanken!

Wiedmann ,danke für Deine Hilfe!!!!

Viele Grüsse
Robert
xampp-azubi
 
Posts: 6
Joined: 26. March 2008 09:14


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests