GET-Variablen funktionieren nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

GET-Variablen funktionieren nicht

Postby Myon1402 » 29. April 2008 19:49

Hallo,
ich habe neulich xampp auf meinem rechner mit windows vista installirt.
als ich mittendrin im php-schreiben war fiehl mir auf, dass keine GET-Variable funktionirte. ich hab erst gedacht ich habe irgendwo einen fehler gemacht und hab es mal zur probe auf meinen webserver geladen.
dort hat alles wunderbar geklappt. :shock:

woran kann es liegen, dass die auf xampp nicht gehn?
MfG Myon1402
Myon1402
 
Posts: 6
Joined: 25. August 2007 15:00

Postby Wiedmann » 29. April 2008 19:50

woran kann es liegen, dass die auf xampp nicht gehn?

An deinem Code.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Myon1402 » 29. April 2008 19:54

aber auf meinem webserver funktionirt es doch einbahnfrei...
Myon1402
 
Posts: 6
Joined: 25. August 2007 15:00

Postby Wiedmann » 29. April 2008 19:56

aber auf meinem webserver funktionirt es doch einbahnfrei...

Zufall...

Machs einfach so wie im PHP-Manual beschrieben, dann funktioniert es auf jedem Server (ohne die PHP-Konfiguration ändern zu müssen).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Myon1402 » 29. April 2008 19:58

glaub ich nich
Myon1402
 
Posts: 6
Joined: 25. August 2007 15:00

Postby Nobbie » 29. April 2008 21:12

Ich aber.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Postby Myon1402 » 29. April 2008 21:18

in
<?php
$GET_['page'];
echo "$page";
?>


is doch kein fehler... und wenn ich auf localhost/test.php?page=home gehe, passirt nichts. und aufm webserver gehts...
Myon1402
 
Posts: 6
Joined: 25. August 2007 15:00

Postby Wiedmann » 29. April 2008 21:33

in ... is doch kein fehler...

Logisch. Entweder:
Code: Select all
$page = $_GET['page'];
echo $page;

oder einfach:
Code: Select all
echo $_GET['page'];
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests