XAMPP MySQL problem

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP MySQL problem

Postby Test01 » 24. April 2008 17:48

Hallo,

ich habe mir gestern xampp installiert weil es eigentlich schnell gehen soll *lach* nun läuft noch immer nicht alles und ich weis nicht mehr warum. MySQL ist zwar gestartet aber ich kann nichts damit mache, keine db erstellen, reports usw... einfach nichts, die ampel ist auf grun aber das wars.
Phpmyadmin sagt immer nur: "Die Erweiterung mysql kann nicht geladen werden. Bitte überprüfen Sie Ihre PHP-Konfiguration. - Dokumentation"

Ich habe nichts geändert, alles standart gelassen um solche fehler zu vermeiden und nun komme die erst recht!

Wie kann ich den fehler beheben?

lg
Test01
 
Posts: 5
Joined: 24. April 2008 17:34

Postby Wiedmann » 24. April 2008 17:52

Wie kann ich den fehler beheben?

Du hast noch irgendwo eine alte "php.ini" rumliegen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Test01 » 24. April 2008 17:53

Hallo,

nein, nur die sich mit xampp installiert hat, davon habe ich 3 stück.

lg
Test01
 
Posts: 5
Joined: 24. April 2008 17:34

Postby Wiedmann » 24. April 2008 17:55

nein, nur die sich mit xampp installiert hat,

phpinfo() ist auch deiner Meinung?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Test01 » 24. April 2008 17:59

Configuration File (php.ini) Path C:\WINNT
Loaded Configuration File C:\xampp\apache\bin\php.ini
Test01
 
Posts: 5
Joined: 24. April 2008 17:34

Postby Wiedmann » 24. April 2008 18:10

- Taucht in phpinfo() die MySQL-Extension auf?
- Was ist das extension_dir in phpinfo()?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Test01 » 24. April 2008 18:11

1. Nein

2. C:\xampp\php\ext\
Test01
 
Posts: 5
Joined: 24. April 2008 17:34

Postby Wiedmann » 24. April 2008 18:16

Taucht was im error.log auf?
(bzw. auch nachdem man "display_startup_errors" in "php.ini" aktiviert hat)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Test01 » 24. April 2008 18:35

Im error.log sind ein paar sachen.

display_startup_errors habe ich nun auf on gesetzt.
Test01
 
Posts: 5
Joined: 24. April 2008 17:34

Postby purchaser » 06. May 2008 10:12

servus,

den fehler hatte ich gestern auch.
ursache war vermutlich das "dynamic extensions" nicht so lief wie erwartet.

kann dir nur meinen lösungsweg nennen.

in der PHP5.ini die einträge in "dynamic extensions" aktiviert (also ";" vor dem eintrag löschen).
ebenfalls überprüft ob die "php_mysql" in dem angebenen pfad "extensions" liegt.
fazit .. wollte trotzdem nicht.
also hab ich apache über xampp beendet / gestoppt ..
die "php-switcher.bat" genommen .. und auf PHP4 umgestellt.
diese ini bearbeitet und siehe da ..es geht.

versuch das mal .. sofern die PHP 4 ausreicht .. ne andere lösung hab ich auf die schnelle auch nicht gefunden...

greetz
IT Einkäufer der sich nach 8 Jahren mal wieder mit PHP/SQL/Apache auseinandersetzt. Und es kommt mir gerade noch viel länger vor .. 0.o .. XAMPP 1.4.16 ( apache 2.0.54 )
purchaser
 
Posts: 15
Joined: 06. May 2008 09:56


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests

cron