localhost auf externem Netz-Laufwerk möglich?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

localhost auf externem Netz-Laufwerk möglich?

Postby hagozi » 25. March 2008 09:08

Hallo,

ich möchte gerne "DocumentRoot" auf ein externes Netz-Laufwerk legen.
In Apaches httpd.conf habe ich die entsprechenden Eintrge gemacht, jetzt will Apache aber nicht mehr starten: "The requested operation has failed!"

Das Laufwerk ist natürlich nicht schreibgeschützt und ist mit dem Laufwerksbuchstaben Z:\ im Dateisystem eingebunden.

Mit anderen Programmen, wie zB. einem BackUp Programm, kann ich problemlos darauf zugreifen.

Ahnt vielleicht jemand, was ich falsch mache, oder geht das vielleicht gar nicht?

Gruß, Hago
hagozi
 
Posts: 24
Joined: 06. March 2008 09:50

Postby Stepke-DSL » 25. March 2008 09:10

Hallo,

Poste mal deine Anpassungen von der httpd.conf.

MfG Stepke
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
Operating System: Win XP Pro SP3 + SuSe Linux

Postby hagozi » 25. March 2008 09:15

hier ist, was ich angepasst habe:

.................
DocumentRoot "Z:/aserver"

<Directory "Z:/aserver">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
.................

Hago
hagozi
 
Posts: 24
Joined: 06. March 2008 09:50

Postby hagozi » 25. March 2008 09:19

Übrigens, zuvor stand da einfach

.................
DocumentRoot "C:/aserver"

<Directory "C:/aserver">...
................

und das hat perfekt funktioniert.

Hago
hagozi
 
Posts: 24
Joined: 06. March 2008 09:50

Postby hagozi » 25. March 2008 09:28

Ich hab's rausbekommen :-)

"Z:/" ist nur ein Alias für einen längeren Laufwerksnamen.
Wenn ich den in der httpd.conf angebe klappt alles prima.

Grüße, Hago
hagozi
 
Posts: 24
Joined: 06. March 2008 09:50

Postby rolan » 03. April 2008 16:40

ich habe dasselbe problem, aber egal was ich angebe, apache startet nicht

netzwerklauwerk ist als Buchstabe "Z:/ " und damit
DocumentRoot "Z:/"
<Directory "Z:/">

(auch ohne slash probiert)
rolan
 
Posts: 6
Joined: 09. December 2007 23:37

Postby Wiedmann » 03. April 2008 16:43

Du nusst den Orginalen Netzwek-Share-Namen nehmen. Und nivht den Buchstaben, auf den du die Share gemapped hast.

(User des Apachedienst noch entsprechend anpassen
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests