Problem mit Xampp

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit Xampp

Postby namor144 » 22. March 2008 02:17

Habe ein Problem mit Xampp!

Und zwar

Habe mir vor ungefähr einer Woche Xampp runtergeladen und installiert!
Doch gleich nach der Instalation war ich mit meinem Latein am Ende, denn soweit ich informiert bin (auch anhand diesem Forum) muss man seinen Datein die man Anzeigen lassen will in den Ordner "htdocs" speichern!

Doch Leider immer wenn ich das mache Bekomme ich vom Browser eine Fehlermeldung die wie folgt lautet:

("Objekt nicht gefunden!

Der angeforderte URL konnte auf dem Server nicht gefunden werden. Sofern Sie den URL manuell eingegeben haben, überprüfen Sie bitte die Schreibweise und versuchen Sie es erneut.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.

Error 404
localhost
03/22/08 02:16:09
Apache/2.2.8 (Win32) DAV/2 mod_ssl/2.2.8 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 ")

Könnt ihr mir da vielleicht weiterhelfen?!

Danke im Voraus :D
namor144
 
Posts: 5
Joined: 22. March 2008 02:11

Postby Wiedmann » 22. March 2008 02:28

muss man seinen Datein die man Anzeigen lassen will in den Ordner "htdocs" speichern!

Wo genau ist dein Ordner "htdocs" auf der Platte?

Doch Leider immer wenn ich das mache Bekomme ich vom Browser eine Fehlermeldung die wie folgt lautet: "Objekt nicht gefunden!"

Und was genau rufst du im Browser auf?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby namor144 » 22. March 2008 02:30

Wo genau:

ja auf der C: Festplatte unter C:Windows/Programme/Xampp

ja und mit Mozilla Firefox und localhost/XXX
namor144
 
Posts: 5
Joined: 22. March 2008 02:11

Postby Wiedmann » 22. March 2008 02:39

ja auf der C: Festplatte unter C:Windows/Programme/Xampp

a) wieso ist dein Programme unterhalb von Windows?
b) nennt sich dein DocumentRoot wirklich "Xampp" und nicht "htdocs"?

oder ist c) die eigentlich korrekte Antwort "C:\Programme\xampp\htdocs"?

ja und mit Mozilla Firefox und localhost/XXX

a) du meinst eigentlich "http://localhost/XXX"?
b) dann gibt es also in deinem htdocs-Order eine Datei mit genau dem Namen "XXX"?

bzw. in der Eingabeaufforderung kannst du folgendes korrekt ausführen (wenn wir den obigen Pfad für's htdocs annehmen)?
Code: Select all
dir "C:\Programme\xampp\htdocs\XXX"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby namor144 » 22. March 2008 02:47

Sry oba leider kenn ich mich zu wenig aus mit den ganzen unterordner!!

ich weiß nur das ich wenn ich auf meine C Festplatte gehe ich dann auf Xampp gehe und dann dort alles drinnen ist!

und ich habe bei mir in der Schule auch schon nachgefragt undn die können sich das problem bei mir auch nicht erklären!

mfg
namor144
 
Posts: 5
Joined: 22. March 2008 02:11

Postby Xardas der Dunkle » 22. March 2008 02:59

Wenn du nicht mal weißt wo du Xampp installiert hast, frage ich mich: Was willst du mit Xampp?
Zudem ist C keine Festplatte sondern eine Partition.

Hast du beim Aufruf der Adresse im Browser auch auf die korrekte Schreibweise geachtet?
Groß und Kleinschreibung sollte keine Rolle spielen, da Windows.
Aber Umlaute etc. im Dateinamen können schon zu Problemen führen.
Auch die richtige Dateiendung spielt eine Rolle. Mach mal folgendes, klick im Arbeistplatz im Menüpunkt Extras auf Ordneroptionen. Wählst die Registerkarte Ansicht und machst den Hacken raus bei "Erweiterungen bei bekannten Dateitypen ausblenden." (Wer vernüftig arbeiten will, sollte dies immer machen ...).
Nun siehst du den follen Dateinamen und kannst die Datei auch richtig im Browser aufrufen.

http://localhost/meinedatei.htm

mfG
User avatar
Xardas der Dunkle
 
Posts: 482
Joined: 09. March 2008 19:40
Location: /var/www

Postby namor144 » 22. March 2008 19:12

ja des weis ich eh das C: nur eine Partition is!

owa i kann mir nicht erklären warum bei mir Xampp nicht richtig läuft da ich (laut anleitung im internet und freunden) alles richtig gemacht habe!

Ich war leider gestern in der Nacht nicht mehr gut drauf darum schrieb ich so einen murks!

Mein Xampp ist unter Xampp C:\xampp!

Danke für rückmeldung
namor144
 
Posts: 5
Joined: 22. March 2008 02:11


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests