memcache startet nicht - Apache verursacht Bluescreen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

memcache startet nicht - Apache verursacht Bluescreen

Postby Herbi » 13. March 2008 21:47

Hallo!

Ich habe XAMPP 1.6.6a installiert unter Vista 64bit.
Nun möchte ich die memcache Erweiterung nutzen und habe daher in der /apache/bin/php.ini die Zeile "extension=php_memcache.dll" auskommentiert.
Allerdings bekomme ich bei der Zeile $cache = new Memcache; immer noch die Meldung "Class 'Memcache' not found". In der phpinfo() ist memcache auch nicht aufgelistet.

Wie bekomme ich die Erweiterung lauffähig?

Gruß,
Herbi
Last edited by Herbi on 14. March 2008 11:18, edited 1 time in total.
Herbi
 
Posts: 5
Joined: 13. March 2008 21:41

Postby Nobbie » 13. March 2008 22:30

Ist das denn die richtige php.ini?
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Postby Herbi » 13. March 2008 23:04

Sollte es sein.
Herbi
 
Posts: 5
Joined: 13. March 2008 21:41

Postby Herbi » 14. March 2008 11:24

Update:

Als ich heute morgen den Apachen nochmal starten wollte, ist das System mit einem Bluescreen abgestürzt.
daraufhin habe ich XAMPP deinstalliert, genauso wie die Treiber meines NIC. Der NIC hat sich nach dem Neustart wieder installiert. XAMPP draufgepackt und konfiguriert. Der Apache startete danach auch wieder wie gewohnt.

Als ich dann an meiner Webseite ein paar Konfigurationsfehler ausmerzte, beschwerte sich diese wieder, dass die Klasse Memcache nicht gefunden werden kann. Also habe ich den Apachen gestoppt, mir die php.ini angeschaut (da war alles in Ordnung, memcache eig aktiviert) und den Apachen gestartet: Bluescreen.

Wie kann ich das Problem lösen?

edit:
Mein System:
Vista Business 64bit
Asus P5N-E SLI: NVIDIA NIC also
Herbi
 
Posts: 5
Joined: 13. March 2008 21:41

Postby Wiedmann » 14. March 2008 11:37

Nun möchte ich die memcache Erweiterung nutzen und habe daher in der /apache/bin/php.ini die Zeile "extension=php_memcache.dll" auskommentiert.

Den separat zu installierenden memcached Server hast du auch installiert?

(Ansonsten frag doch mal beim Support/Author für diese PECL-Extension noch. IMHO ist diese Extension auch bei meinem XAMPP 1.6.6a gar nihct dabei...)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Herbi » 14. March 2008 11:58

Imo musste man da gar nix dazu installieren. Semikolon weg und dann hat es bei mir eig immer direkt funktioniert. ;) Liegt vielleich daran, dass ich da ne ältere Version vom XAMPP verwendet habe.
Herbi
 
Posts: 5
Joined: 13. March 2008 21:41

Postby Wiedmann » 14. March 2008 12:15

Imo musste man da gar nix dazu installieren.

Die Doku zu dieser Extension und memcache an sich sagt was anderes.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Herbi » 14. March 2008 12:20

Jo, habe nun von http://pecl4win.php.net/ext.php/php_memcache.dll die DLL dazu gepack und memcache wird gestartet, schmeißt nun aber ne Menge Fehler aus.
Wenigstens keine Bluescreens mehr... ;)
Herbi
 
Posts: 5
Joined: 13. March 2008 21:41

Postby Wiedmann » 14. March 2008 12:26

Jo, habe nun von http://pecl4win.php.net/ext.php/php_memcache.dll die DLL dazu gepack

Das ist eben nur die PHP-Extension (Verbindung von PHP mit dem memcache Server).

und memcache wird gestartet,

Das kann nur passieren, wenn du auch den eigentlichen memcache Server installierst und startest. (Aber er läd jetzt wohl die Extension)

(Im PHP-Manual findest du den Link zum eigentlichen memcache Project. Auch in den UCN's auf dieser Seite findest du Hinweise zum memcache Server unter Windows)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby piratos » 16. March 2008 15:39

PHP Memcache ist nur eine DLL die den Dienst memcache nutzt.

Dazu muss man die Software memcache holen und als Dienst installieren.

Funktioniert einwandfrei.
piratos
 
Posts: 45
Joined: 28. October 2004 10:10

hi

Postby Dicker1 » 16. March 2008 22:38

hi sowas ähnliche hatte ich auch schohn mal aber bei mir lag es an der festplatte , die war da fast über den jordan gehüpft. Es gibt doch programme die die sektoren der festplatte auf fehler prüfen, lass da mal eins durchlaufen.
Dicker1
 
Posts: 13
Joined: 16. August 2007 00:49


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests