phpMyAdmin funktioniert, aber mysql_connect() nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

phpMyAdmin funktioniert, aber mysql_connect() nicht

Postby naitSirch » 06. February 2008 12:35

Hallo,
ich habe ein ziemlich komisches Problem.
phpMyAdmin funktioniert bei mir ohne Probleme, aber wenn ich die Funktion mysql_connect(...) benutzen möchte, erhalte ich die Fehlermeldung

Fatal error: Call to undefined function mysql_connect() in C:\Programme\xampp\htdocs\test\Anwendung.php on line 40


In der php.ini (...\xampp\apache\bin) ist sowohl der Pfad zu den Extensions,
extension_dir = "C:\Programme\xampp\php\ext\"

Als auch die Extension aktiviert
extension=php_mysql.dll
extension=php_mysqli.dll

(also ohne Semikolon davor).

Weiß jemand, woran das liegen könnte?
Weil phpMyAdmin doch mit sicherheit auch mysql_connect(...) benutzt.
naitSirch
 
Posts: 3
Joined: 06. February 2008 12:21

Postby Wiedmann » 06. February 2008 13:04

In der php.ini (...\xampp\apache\bin)

Wird diese "php.ini" denn benutzt?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sari42 » 06. February 2008 13:18

Weiß jemand, woran das liegen könnte?
das kannst nur Du selbst herausfinden, indem Du php befragst:
Code: Select all
<?php
phpinfo();
?>

gespeichert als C:\Programme\xampp\htdocs\test\info.php
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby naitSirch » 06. February 2008 13:41

Bei phpinfo() wird unter anderem folgendes ausegegben:
Configuration File (php.ini) Path : C:\WINDOWS
Loaded Configuration File : C:\Programme\xampp\apache\bin\php.ini


Und bei den MySQL-Einstellungen:
MySQL Support: enabled
Active Persistent Links : 0
Active Links: 0
Client API version: 5.0.51

Directive . Local Value . Master Value
mysql.allow_persistent: On On
mysql.connect_timeout: 60 60
mysql.default_host: no value no value
mysql.default_password: no value no value
mysql.default_port: no value no value
mysql.default_socket: no value no value
mysql.default_user: no value no value
mysql.max_links Unlimited: Unlimited
mysql.max_persistent: Unlimited Unlimited
mysql.trace_mode: Off Off

(Das müsst ihr Euch als Tabelle vorstellen)

Weiß jetzt nicht, ob die Einstellungen richtig sind. Aber ich versteh' nicht, wie phpMyAdmin laufen kann?!
naitSirch
 
Posts: 3
Joined: 06. February 2008 12:21

Postby Wiedmann » 06. February 2008 13:54

In der php.ini (...\xampp\apache\bin)

In Wirklichlichkeit meinst du hier also diese Datei: "C:\Programme\xampp\apache\bin\php.ini"?

Jedenfalls scheint diese benutzt zu werden, und die MySQL-Extension ist wohl auch geladen.

Fatal error: Call to undefined function mysql_connect() in C:\Programme\xampp\htdocs\test\Anwendung.php on line 40

Wie rufst du die Datei "Anwendung.php" denn auf?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sari42 » 06. February 2008 15:51

...und was steht in Zeile 40? Tippfehler?
(daß sich die Leut' immer erst alles aus der Nase ziehen lassen müssen...)
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby naitSirch » 06. February 2008 16:07

Oha...
ich seh grad, dass es nur mit Eclipse nicht funktioniert :oops:
Ich programmiere PHP mit der Entwicklungsumgebung Eclipse (kennen wahrscheinlich die meisten)... und da kommt dieser mysql_connect() - Fehler.

Jetzt eben habe ich es mit http://127.0.0.1/test/Anwendung.php im Browser ausprobiert und da klappt alles reibungslos.

Wahrscheinlich liegt das daran, dass Eclipse seine "eigene PHP" Maschine hat, die total unabhängig von der php.ini läuft und auch unabhängig von meiner Datenbank.

Tut mir Leid, das wusste ich nicht... voll blöd.
naitSirch
 
Posts: 3
Joined: 06. February 2008 12:21

Postby Wiedmann » 06. February 2008 17:00

Ich programmiere PHP mit der Entwicklungsumgebung Eclipse ... Wahrscheinlich liegt das daran, dass Eclipse seine "eigene PHP" Maschine hat,

Dann solltest du die "info.php" auch aus Eclipse heraus aufrufen, um zu sehen welche "php.ini" dort benutzt wird, bzw. welche Extensions da aktiv sind.

Evtl. kann man dieser Software ja auch beibringen, dass PHP vom XAMPP, inkl. dessen "php.ini", zu benutzen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests