FATAL: emalloc() unter Windowssever mit XAMPP

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

FATAL: emalloc() unter Windowssever mit XAMPP

Postby ven » 04. February 2008 14:00

Hallo,

seit heute Morgen gibts Probleme mit meinem Apache. Zuerst war die Webseite nicht erreichbar, es gab immer eine Fehlermeldung beim Seitenaufrug ala "Fehler: Verbindung unterbrochen. Die Verbindung zum Server wurde zurückgesetzt, während die Seite geladen wurde."

Ich habe kurz in der Errorlog des Apache nachgeschaut und folgendes gefunden:

FATAL: emalloc(): Unable to allocate 148720 bytes
[Mon Feb 04 12:51:59 2008] [notice] Parent: child process exited with status 1 -- Restarting.

[Mon Feb 04 12:51:59 2008] [notice] Apache/2.0.54 (Win32) mod_ssl/2.0.54 OpenSSL/0.9.8 PHP/4.4.0 mod_autoindex_color configured -- resuming normal operations
[Mon Feb 04 12:52:00 2008] [notice] Server built: Jul 28 2005 18:10:37
[Mon Feb 04 12:52:00 2008] [notice] Parent: Created child process 1500
[Mon Feb 04 12:52:00 2008] [notice] Disabled use of AcceptEx() WinSock2 API
[Mon Feb 04 12:52:01 2008] [notice] Child 1500: Child process is running
[Mon Feb 04 12:52:01 2008] [notice] Child 1500: Acquired the start mutex.
[Mon Feb 04 12:52:01 2008] [notice] Child 1500: Starting 50 worker threads.
[Mon Feb 04 12:52:01 2008] [notice] Child 1500: Listening on port 443.
[Mon Feb 04 12:52:01 2008] [notice] Child 1500: Listening on port 80.


Nach googlen bin ich auf "Win32DisableAcceptEx" und "Threadsperchild" aufmerksam geworden. Win32DisableAcceptEx habe ich in der htttpd.conf hinzugefügt, sowie die Threadsperchild von 250 auf 50 heruntergesetzt (Wie oben im Auszug auch einsehbar).

Nun funktioniert die Seite wieder, allerdings kommt zwischendurch immer noch der Fehler, dass die Seite nicht augebaut werden kann. Wenn ich die Threadsperchild höher setze funktioniert die Seite komplett nicht mehr.

Wie mir jetzt allerdings auffällt, schmiert nach den oben genannten Änderungen MySQL immer ab.

Ich bin ratlos, woran kann das liegen? Die Webseite ist stark Datenbankbasierend, kann es evtl damit zusammenhängen?

Viele Grüße,
Dennis
Last edited by ven on 04. February 2008 14:21, edited 2 times in total.
ven
 
Posts: 11
Joined: 21. July 2006 12:32

Re: FATAL: emalloc() unter Windowssever mit XAMPP

Postby ven » 04. February 2008 14:05

Siehe oben.
ven
 
Posts: 11
Joined: 21. July 2006 12:32


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests