mod_rewrite und localhost

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

mod_rewrite und localhost

Postby hmp » 23. January 2008 12:35

Hallo,

ich arbeite schon lange mit XAMPP allerdings fange ich erst jetzt an ein wenig mit mod_rewrite zu arbeiten.

Allerdings scheint da bei mir was nicht zu klappen. Ich habe .htaccess in meinem Ordner http://localhost/owave/ und hab in htaccess folgendes reingeschrieben:

Code: Select all
RewriteEngine on
RewriteRule index.html$ index.php


index.html und index.php sind beide vorhanden trotzdem kommt eine Serverfehlermeldung:

Serverfehler!
Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist. Der Server ist entweder überlastet oder ein Fehler in einem CGI-Skript ist aufgetreten.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.

Error 500


Was mache ich falsch?
hmp
 
Posts: 6
Joined: 23. January 2008 12:31

Postby Wiedmann » 23. January 2008 13:07

Error 500

Was steht im "error.log"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby hmp » 23. January 2008 13:19

[Wed Jan 23 12:34:57 2008] [alert] [client 127.0.0.1] C:/xampp/htdocs/owave/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration

Hm denke das sagt schon alles. Aber den Code hab ich von einer Tutorialseite. Denke das der richtig sein sollte. Fehlt mir evtl. eine Datei?
hmp
 
Posts: 6
Joined: 23. January 2008 12:31

Postby hmp » 23. January 2008 13:28

Hm wie ich sehe ist auf meinem Apache garkein mod_reqrite drauf. Habs grad mit phpinfo() nachgeguckt. Gibt es etwa eine neuere Version als meine (1.6.3a) oder muss ich was aktivieren?
hmp
 
Posts: 6
Joined: 23. January 2008 12:31

Postby Wiedmann » 23. January 2008 13:28

Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration

"mod_rewrite" hast du in der "httpd.conf" aktiviert?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby hmp » 23. January 2008 14:48

Ok sorry habs war nicht geladen. Danke :)

edit: Hab die Raute vor Load weg genommen muss ich danach irgendwas machen? Apache neustarten? Weil der Fehler immernoch angezeigt wird.
hmp
 
Posts: 6
Joined: 23. January 2008 12:31

Postby Wiedmann » 23. January 2008 14:54

Apache neustarten?

Ja (, nur dann wird die Konfigurationsdatei eingelesen).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby hmp » 23. January 2008 15:39

Ok danke hat soweit geklappt nur jetzt kommt der nächste Fehler:

[Wed Jan 23 15:23:19 2008] [alert] [client 127.0.0.1] C:/xampp/htdocs/owave/.htaccess: Invalid command '1', perhaps misspelled or defined by a module not included in the server configuration


Inhalt von htaccess:

Code: Select all
1 RewriteEngine On
2 Options +FollowSymlinks
3 RewriteBase /
4
5 # Fuer die Kleinanzeigen
6 RewriteRule ^index,(.*),(.*)(\.html?)$ index\.php?c=$1&newsid=$2 [L]
7
8 # Rule Fuer die Module
9 RewriteRule ^(.*)(\.html?)$ index.php?c=$1
hmp
 
Posts: 6
Joined: 23. January 2008 12:31

Postby Wiedmann » 23. January 2008 15:46

Inhalt von htaccess:

Was sollen die Ziffern von 1 bis 9 da?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby hmp » 23. January 2008 15:49

Ok danke daran lag es ^^
hmp
 
Posts: 6
Joined: 23. January 2008 12:31


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 3 guests