Fehler bei PHPMYADMIN

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Fehler bei PHPMYADMIN

Postby BlackMoon » 15. October 2003 18:20

Hi,

benutze seit einiger Zeit xampp (v 1.0) auf WinXP.
Apache/2.0.47 (Win32) mod_ssl/2.0.47 OpenSSL/0.9.7b PHP/4.3.3

Läuft auch alles ganz wunderbar bis auf einen Fehler bei PHPMYADMIN. Wenn ich mir eine Tabelle im Detail Menü angucken will kommt folgender Fehler!

:?:
Es ist ein Laufzeitfehler aufgetreten.
Soll der Debugmodus gestartet werden?

Zeile: 764
Fehler: 'top.frames.queryframe.document' ist Null oder kein Objekt

:?:

Danke schon im Vorraus für die Hilfe!
BlackMoon
 

schneller, schneller :-P

Postby MartinBln » 15. October 2003 18:26

Hmm, da hat also jemand das gleiche Problem wie ich und hat es nur eine Minute später gepostet *ggg* Gut zu wissen, dass ich damit nicht allein bin.

Aber wie gesagt, ich habe schon neuere Versionen von PHPmyAdmin probiert, immer das gleiche Problem wie Du es auch beschreibst. Leider ist auf der PHPmyAdmin-Seite auch noch nichts zu finden darüber.
MartinBln
 

top.frames.queryframe.document -- message

Postby Günter » 15. October 2003 19:06

sowas ist ja ´ne Javascript-Fehlermeldung, die ich auch immer sehe, wenn ich im XAMPP-Kontext mit PhpMyAdmin zugange bin. XAMPP integriert ja PhpMyAdmin in seinen eigenen Frames-Kontext -- bloss liegt das nicht im Verantwortungsbereich der MyAdmin - Entwickler.

OK, was das bedeutet: mit "top.frames.queryframe.document" adressiert MyAdmin per JavaScript eine bestimmte Seite ihres eigenen Frames-Sets -- das blöde ist bloss, dass "top" (also ´ne Frames-Hirarchieebene drüber) jetzt leider durch XAMPP´s eigenes Frames-Set überschrieben wird, und dieses besitzt halt keinen "queryframe" - Frames-Namen, was wiederum dazu führt, daß halt immer diese Kack-Fehlermeldung kommt :D Hoffentlich versteht einer diesen ganzen Quatsch überhaupt :D

Kleine Abhilfe: Versuch mal, wenn Du in XAMPP bist auf auf den Link klickst, die PhpMyAdmin - Seite(n) in einem eigenen Browser-Fenster zu öffnen, das müsste ja klappen.

Günter
Günter
 

Postby Guest » 16. October 2003 00:36

Danke für den guten Tipp,

habe alles verstanden :D !

Also für alle PhpmyAdmin in einem eigenen Fenster öffnen und der Fehler ist weg. (da hätte ich auch selber drauf kommen können)

Ciao
Guest
 

Postby MartinBln » 16. October 2003 10:06

Zu dumm nur, dass das überhaupt nichts ändert ... Auch in eigenem Fenster und direkt gestartet wird bei mir dieser Laufzeitfehler erzeugt. bei mir sind es die folgenden Zeilen, die den Ärger verursachen ...

Code: Select all
if (top.frames.queryframe && top.frames.queryframe.document && top.frames.queryframe.document.queryframeform) {
        top.frames.queryframe.document.queryframeform.db.value = "xyz";
        top.frames.queryframe.document.queryframeform.table.value = "pra_user";
    }


Merkwürdigerweise passiert dieser Fehler nicht, wenn ich online auf die selbe Version bei meinem Hoster zugreife ?!
MartinBln
 

Postby Julia » 27. October 2003 19:16

Hallo,

habe auch einen Javascriptfehler in PHPMYADMIN der neusten WAMPP-Version.
Außerdem braucht PhHPMyAdmin voll lange bei dem Leitenaufbau, manchmal ist stürzt es sogar völlig ab!

So long

Julia
Julia
 


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests