phpmyadmin Import dauert ewig & 100% CPU auslastung

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

phpmyadmin Import dauert ewig & 100% CPU auslastung

Postby Eisenbroiler » 27. December 2007 22:03

Moinsen,

ich habe die aktuelle XAMPP Version für Windows auf einem Win2K SP4 installiert und möchte eine DB per phpmyadmin importieren (Größe ca. 300k zip) - doch der Import dauert ewig, die Seite lädt nicht und die CPU Auslastung steht auf 100%. Ansonsten läuft XAMPP ok. Ich hab eigentlich nix weiter geändert an der Installation ausser dass ich vhosts eingerichtet habe... kann es daran liegen?

EDIT: breche ich ab, finde ich Teile der DB (Tabellen) im MySQL, aber nicht alles... und es hört nicht von allein auf
Eisenbroiler
 
Posts: 1
Joined: 27. December 2007 21:58

Postby sari42 » 28. December 2007 14:43

hast Du mal die "UploadDir" - Methode aus Documentation.html#faq1_16 versucht?
Man braucht
Code: Select all
$cfg['UploadDir'] = 'd:/ausserhalbHtdocs/impex';
$cfg['SaveDir']   = 'd:/ausserhalbHtdocs/impex';
(in config.inc.php)

Auf den Import-/Export-Seiten erscheint dann ein neuer Menüpunkt
(bei Import allerdings nur, wenn dort passende Dateien vorhanden sind, z.B. mit FTP hochgeladen, falls der Rechner woanders steht).
___

p.s.
wenn die .zip Datei von einem anderen OS/php erzeugt wurde gibt's auch manchmal Probleme (gzip funktionierte bei mir immer, auch OS-übergreifend). Dann hilft manuell zu entzippen und die .sql-Datei ins UploadDir zu stellen.
sari42
 
Posts: 800
Joined: 27. November 2005 18:28


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests