Kennt sich jemand damit aus?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Kennt sich jemand damit aus?

Postby eurytheus » 21. December 2007 14:42

Hallo Forumfreunde,
ich bin neu hier. Nach der Xampp- und Dyndns-Installation, kann ich meinen Homeserver(xp-Home) übers Internet ansprechen. Wenn ich die Domain aufrufe, zeigt sich mir die Xampp-Startseite, allerdings möchte ich, dass mir die Joomla-Seite gezeigt wird, die ich bereits unter der MySql-Dtb laufen lasse. Wie stelle ich das an?
Ich habe schon probiert, die htdocs-Dateien zu löschen und den Inhalt meiner dtb dort einzufügen, allerdings wird mir der Inhalt ohne css angezeigt...
Danke erstmal,
Eurytheus
Last edited by eurytheus on 22. December 2007 13:09, edited 2 times in total.
eurytheus
 
Posts: 12
Joined: 21. December 2007 13:36

Postby eurytheus » 22. December 2007 09:24

Also, ich habe herausgefunden, wie ich die Joomla-dtb ansprechen kann, allerdings zeigt sich die Frontpage ganz ohne CSS an und ich weiß nicht wo das Problem liegt...
eurytheus
 
Posts: 12
Joined: 21. December 2007 13:36

Postby eurytheus » 22. December 2007 10:39

noch was, in meinen MySql kommt folgender Fehler vor:
"Die Erweiterung mcrypt kann nicht geladen werden. Bitte überprüfen Sie Ihre PHP-Konfiguration."
Was kann ich dagegen tun? Und hat es vielleicht mit dem oben genannten Problem zu tun?
eurytheus
 
Posts: 12
Joined: 21. December 2007 13:36

Postby eurytheus » 22. December 2007 12:23

Es macht auch Spaß mit sich selbst zu schreiben;-)
ich habe das Problem mit MySql-Konfiguration gelöst, in dem ich die "config.inc.php" geändert habe.
Das Problem mit der CSS-lose Darstellung bleibt, hat jemand ne Idee?
eurytheus
 
Posts: 12
Joined: 21. December 2007 13:36

Postby sari42 » 22. December 2007 12:31

Ich würd' mal in apache/logs suchen ...
... und verschiedene Browser probieren
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby eurytheus » 22. December 2007 13:04

viele Dank erste mal.
Was soll ich im Logs ändern bzw. wonach soll ich suchen?
Mit den verschiedenen Browser ist so nen ding, weil ich möchte dass jeder sich bei mir einloggen kann.
eurytheus
 
Posts: 12
Joined: 21. December 2007 13:36

Postby eurytheus » 22. December 2007 14:03

Wenn in einem CMS wie Joomla die CSS nicht verarbeitet wird liegt das meistens daran da der Pfad zur CSS falsch definiert wurde bzw. die Angaben im BASE-Tag nicht stimmen.
Kontrollier im Joomla-Backend nochmals alle Angaben.
-das scheint mir auch eine gute lösung zu sein, obwohl ich alles andere irgendwie hingekriegt habe, ich weiß gar nicht wo ich diese Einstellungen ändern kann...
Ein weiterer Fehler, der öfters auftritt; stimmt die Syntax in der CSS nicht kann es schon mal passieren das ab dem Fehler alles in der CSS ignoriert wird.
CSS kontrollieren.
-das Problem ist, dass die Seite in Lan wunderbar angezeigt wird
Und dann noch: Browser-Cache löschen, Verlauf löschen, Cookies löschen, und, falls Joomla Daten cached, auch diesen Cache löschen.
Mache ich immer..[/list]
eurytheus
 
Posts: 12
Joined: 21. December 2007 13:36

Postby eurytheus » 22. December 2007 14:49

sorry wenn ich noch mal frage, aber wie mache ich das?
eurytheus
 
Posts: 12
Joined: 21. December 2007 13:36

Postby DocFR » 22. December 2007 16:11

Pfade kannst Du am besten mit dem Firefox und der Extension "FireBug" überprüfen. Die bekommst Du am einfachsten auf erweiterungen.de.

Gruß, DocFR
Every landing you walk away is a good landing.
User avatar
DocFR
 
Posts: 9
Joined: 24. July 2003 16:38
Location: Earth->Dortmund

Postby eurytheus » 22. December 2007 16:38

vielen herzlichen Dank
eurytheus
 
Posts: 12
Joined: 21. December 2007 13:36

Postby DocFR » 22. December 2007 18:31

@wole:

Zumindest kann man sich mit Firebug die CSS-Styles für einzelne Objekte anzeigen lassen, und wenn man das net-Modul nutzt, zeigt er die Pfade zu den Objekten oder auch zu Script-Dateien.

Mir hat das Teil schon einiges Suchen erleichtert.


GRuß - DocFR
Every landing you walk away is a good landing.
User avatar
DocFR
 
Posts: 9
Joined: 24. July 2003 16:38
Location: Earth->Dortmund


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests