1und1 Domainweiterleitung auf vHost funktioniert nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

1und1 Domainweiterleitung auf vHost funktioniert nicht

Postby Cuba2006 » 18. December 2007 14:18

Hallo zusammen,

ich habe folgendes Problem, auf meinem lokalen Webserver laufen 4 name based vHost.

1x Strato Domain
1x No-IP.biz
2x 1und1 Domains.

Ich kann die ersten beiden Domains ohne Probleme aufrufen. Aber die Domains gehen direkt auf den defualt vHost. Konnte über http watch nichts rausfinden. Die Domains sind jeweils HTTP Weiterleitung auf meinen Server bzw. IP Adresse des Servers.

kennt jemand diese Phänomen oder bildet 1und1 da eine Sonderlocke?! Als nächstes würde ich mal direkt am Port 80 den Stream abhören um zu schauen was da rein kommt, wobei ich da nicht wirklich zuversichtlich bin.

Schon mal danke im voraus.
Grüße,
Maik.
Cuba2006
 
Posts: 4
Joined: 17. December 2007 23:36

Postby Scory » 18. December 2007 15:13

Mit absoluter Sicherheit hat das mit 1und1 nicht das geringste zu tun, sondern Du hast einen Fehler in der Konfiguration. Leider können wir Deine vhost-Konfiguration nicht sehen, das schließt weitere Hilfe aus.

Grüße
Scory
Scory
 

Postby Cuba2006 » 27. December 2007 13:27

Sorry, blöd von mir. Ich revidiere auch mein erstes Posting, dass es Probleme mit 1und1 gibt, es ist wohl ein generelles Problem meiner Installation.

Es wurde ein normaler XAMPP Web Server auf eine Win Server2003 Kiste installiert. Es funktioniert auch alles Wunderbar, wenn ich die entsprechenden Domains auf dem Server ausführe, auf dem auch der Apache läuft. Rufe ich die Domain ausserhalb des Netzwerks auf bzw von einem anderen Rechner, dann endet es immer im Default host, in diesem Fall in localhost. Kann mir das einer erklären.

Wenn ich den Server mit apache -S starte bekomme ich folgende Meldung,
-------------------------------------------------------------------------------------
D:\Programme\xampp\apache\bin>apache -S
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
_default_:443 localhost (D:/Programme/xampp/apache/conf/extra/httpd-ssl.conf:74)
*:80 is a NameVirtualHost
default server localhost (D:/Programme/xampp/apache/conf/extra/httpd-vhosts.conf:2Cool
port 80 namevhost localhost (D:/Programme/xampp/apache/conf/extra/httpd-vhosts.conf:2Cool
port 80 namevhost www.eco-systemix.com (D:/Programme/xampp/apache/conf/extra/httpd-vhosts.conf:42)
port 80 namevhost www.air-albatros.de (D:/Programme/xampp/apache/conf/extra/httpd-vhosts.conf:56)
port 80 namevhost abrechnung.no-ip.biz (D:/Programme/xampp/apache/conf/extra/httpd-vhosts.conf:70)
Syntax OK

D:\Programme\xampp\apache\bin>

-------------------------------------------------------------------------------------
Das error.log schaut so aus:

[Tue Dec 18 00:51:52 2007] [notice] Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.4 configured -- resuming normal operations
[Tue Dec 18 00:51:52 2007] [notice] Server built: Sep 21 2007 00:29:38
[Tue Dec 18 00:51:52 2007] [notice] Parent: Created child process 2208
[Tue Dec 18 00:51:54 2007] [notice] Child 2208: Child process is running
[Tue Dec 18 00:51:54 2007] [notice] Child 2208: Acquired the start mutex.
[Tue Dec 18 00:51:54 2007] [notice] Child 2208: Starting 250 worker threads.
[Tue Dec 18 00:51:54 2007] [notice] Child 2208: Starting thread to listen on port 443.
[Tue Dec 18 00:51:54 2007] [notice] Child 2208: Starting thread to listen on port 80.

-------------------------------------------------------------------------------------
und das ist die httpd-vhosts.conf
#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
NameVirtualHost *:80

<VirtualHost *:80>
ServerName localhost
ServerAdmin meine@mailadresse.de
DocumentRoot "D:/Programme/xampp/htdocs"
<Directory "D:/Programme/xampp/htdocs">
Options IncludesNoExec
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName www.systemix.com
ServerAdmin webmaster@systemix.com
DocumentRoot "/Programme/xampp/htdocs/Sys"
<Directory "D:/Programme/xampp/htdocs/Sys/">
Options Indexes +FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName www.air-albatros.de
ServerAdmin webmaster@air-albatros.de
DocumentRoot "/Programme/xampp/htdocs/Albatros"
<Directory "D:/Programme/xampp/htdocs/Albatros/">
Options Indexes +FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName abrechnung.no-ip.biz
ServerAdmin meine@abrechnung.no-ip.biz
DocumentRoot "/Programme/xampp/htdocs/xampp"
<Directory "D:/Programme/xampp/htdocs/PilotsPortal/">
Options IncludesNoExec
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

-------------------------------------------------------------------------------------
In der hosts Datei steht folgendes
127.0.0.1 abrechnung.no-ip.biz
127.0.0.1 air-albatros.de
127.0.0.1 eco-systemix.com
127.0.0.1 localhost

-------------------------------------------------------------------------------------
in der httpd.conf ist das include zu vhost unkommentiert.

Danke & einen guten Rutsch,
Maik.
Cuba2006
 
Posts: 4
Joined: 17. December 2007 23:36


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests