Java Bridge

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Java Bridge

Postby lidl » 14. December 2007 18:14

Hey, versuche gerade die Java/PHP Bridge unter XAMPP 1.6.3a zu installieren.

Habe mir dazu die Version 3.2.1b der Bridge von Sourceforge.net heruntergeladen und die php_java.dll sowie die javaBridge.jar in das ext Verzeichnis kopiert.

Beim Starten von Apache wird nun der folgende Error geloggt:

PHP Warning: PHP Startup: java: Unable to initialize module\nModule compiled with module API=20050922, debug=0, thread-safety=1\nPHP compiled with module API=20060613, debug=0, thread-safety=1\nThese options need to match\n in Unknown on line 0


Auf folgender Seite http://www.dsl.uow.edu.au/~sk33/phpjava.htm gibt es nun ein inoffizielle Kompatiblitätsliste, wonach die aktuellste Bridge maximal mit der Apache Version 2.0.59 funktioniert.

muss ich nun wirklich sowohl Apache als auch PHP "downgraden", oder hat jemand eine Lösung gefunden?

Danke & lg
PS:
Apache 1.6.3a enthält PHP 5.2.3 und Apache 2.2.4

Edit:
Die php.ini wurde natürlich entsprechend angepasst.
lidl
 
Posts: 1
Joined: 14. December 2007 18:02

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests