absoluter pfad für .htaccess

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

absoluter pfad für .htaccess

Postby ritter1st » 08. December 2007 13:47

hallo,
hab ´ne frage zu .htaccess (oder mehrere):
ist es grundsätzlich überhaupt möglich passwortgeschützte bereiche mit xampp (windows xp, prof.) lokal zu testen?
ich hab mich mal ein bißchen belesen und auch ei paar tipps bekommen, aber es geht nicht vorwärts. ich hab die vermutung, dass mit dem pfad was nicht stimmt.
die datei .htaccess sieht momentan so aus:

AuthType Basic
AuthName "admin"
AuthUserFile C:\xampp\htdocs\.htaccess
require user benutzer

ist der pfad falsch? muss die .htaccess-datei in den zu schützenden ordner und muss dieser dann mit in den pfad?

die datei .htpasswd sieht so aus: benutzer:21kbnW6px/USM
ich hab in eine site ein "admin"-seite eingebaut, die ich schützen möchte. die .htpasswd datei liegt im "admin"-ordner der site.
die .htpaccess-datei hab ich in den htdocs-ordner kopiert. ist das soweit korrekt? ich bekomme, wenn ich lokal teste keine passwortabfrage. woran liegt das?
danke schonmal für die hilfe.
ritter1st
 
Posts: 3
Joined: 08. December 2007 12:16
Location: Oranienburg

Postby Stepke-DSL » 09. December 2007 00:37

Schönen guten abend,

Also, Punkt 1:
Die .htaccess gehört in das zu schützende Verzeichnis.

Punkt 2:
Die .htpasswd (die Passwortdatei) kann irgendwo auf dem Rechner liegen.

Punkt 3:

Probier mal folgenden Pfad: AuthUserFile C:/xampp/htdocs/.htpasswd
(Wenn ich mich richtig erinnere, muss in der Pfad mit Slash und nicht mit Backslash angegeben werden.

Punkt 4:

Falls immer noch keine Abfrage kommt, schau mal in die httpd.conf und such nach AllowOverwrite, steht da None kann es nicht funktionieren.
Für diesen Fall, ersetz das None mal durch All und starte den Server neu.

Hoffe, dass ich dir weiter helfen konnte.

MfG Stepke
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
Operating System: Win XP Pro SP3 + SuSe Linux

Postby ritter1st » 09. December 2007 10:05

hallo stepke,
vielen dank für deine antwort.
ich hab jetzt noch nicht weiter probieren können, komm im moment an den rechner nicht ran. hab aber zu deinem schreiben noch n paar fragen. muss denn, wenn ich lokal teste, tatsächlich ein slash eingefügt werden? ich bilde mir ein, dass lokal der backslash "zählt". ich werds aber auf jeden fall ausprobieren. zum anderen: wie komme ich an "httpd.conf" ran?
"Die .htpasswd (die Passwortdatei) kann irgendwo auf dem Rechner liegen." meinst du hierbei irgendwo in der site?
mfg. ritter1st.
ritter1st
 
Posts: 3
Joined: 08. December 2007 12:16
Location: Oranienburg

Postby Scory » 09. December 2007 15:09

Der Backslash ist unter Windows der Standardirectory-Trenner, der Slash unter Linux. Aber Windows versteht auch den Slash (aber Linux nicht den Backslash), so dass man aus Kompatibiltätsgründen einfach immer nur den Slash benutzen kann.

Die httpd.conf liegt bei der Xampp Installation unter Windows im Ordner C:\Programme\xampp\apache\conf und bei der Linux Installation im Ordner /opt/lampp/etc

Die .htpasswd kann "irgendwo" auf dem Rechner liegen, d.h. auf irgendeiner Festplatte des Servers. "Irgenwo in der Site" ist keine treffende Beschreibung, weil sie im Dateisystem liegt und mit normalen Dateioperationen gelesen wird.

Grüße
Scory
Scory
 

Postby ritter1st » 09. December 2007 20:37

ist diese datei gemeint:
<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>
allerdings läss sich hier nicht auf "All" ändern. anders gesagt, nach dem neustart steh wieder "None" da.

hab dann noch diese zeilen gefunden:
#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
# Options FileInfo AuthConfig Limit
#
AllowOverride All
da steht "All", ist das gemeint?
was hat´s eigentlich mit dem ordner "forbidden" auf sich? ist der inhalt für meine .htaccess von bedeutung?
es will einfach nicht funktionieren. HILFE!
ritter1st
 
Posts: 3
Joined: 08. December 2007 12:16
Location: Oranienburg

Postby Stepke-DSL » 11. December 2007 20:35

Hast du die CONF auch gespeichert?
Es sollte sich eigentlich ändern lassen und nicht wieder automatisch zurück ändern.

Falls du den HTTP-Code 403 meinst, das kannst du auch in der CONF einstellen:
Code: Select all
#Ordnerinhalte anzeigen
Options +Indexes
#Ordnerinhalte verbergen
Options -Indexes


So long...
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
Operating System: Win XP Pro SP3 + SuSe Linux


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests