xampp-control.exe unter Vista

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

xampp-control.exe unter Vista

Postby ottogal » 26. November 2007 14:31

Hallo in die Runde,

ich habe ein seltsames Problem bei xampp 1.6.0a unter Windows Vista Ultimate:

Sobald das Programm xampp-control-exe läuft, blinkt im Sekundentakt der Warte-Cursor (also der Pfeil mit dem kreisenden Kringel) auf - dabei findet jedesmal offenbar ein Festplattenzugriff statt - ein unhaltbarer Zustand.

Dieses Phänomen ist unabhängig davon, ob Apache oder MySQL gestartet ist oder nicht - erst beim Schließen des Programms mit Exit hört der Spuk auf. Es hängt auch nicht davon ab, ob ich eine Installation von xampp auf der Festplatte (außerhalb des Ordners Program Files) oder im Root-Verzeichnis einer externen Festplatte benutze.

Ich habe die FAQ gelesen und viele Fundstellen in Google durchgeschaut - nirgendwo fand ich einen Hinweis auf dieses Verhalten.

Jetzt seid Ihr hier im Forum meine letzte Hoffnung...

Vielen Dank schon mal!
ottogal
ottogal
 
Posts: 4
Joined: 26. November 2007 13:59

gelöst

Postby ottogal » 28. November 2007 07:46

Nach dem Deinstallieren der alten (Installer-) Version habe ich mir die ZIP-Version von 1.6.4 geholt -seitdem ist das Problem behoben.
Hätte ich wohl schon eher drauf kommen können...

Gruß
ottogal
ottogal
 
Posts: 4
Joined: 26. November 2007 13:59

Doch noch ein Problem

Postby ottogal » 30. November 2007 07:10

Leider habe ich ein neues Problem. Da ich unter http://www.apachefriends.org/de/faq-xam ... html#vista gelesen habe, man solle unter Vista die Installer-Version nehmen, hab ich dann doch diese installiert - und zwar mit der Option, weder den Apache noch MySQL als Service laufen zu lassen. Es passiert aber nach wie vor Folgendes:

Beim Start von xampp-control.exe erscheint vor dem Apache die Checkbox Svc angewählt, obwohl ich ihn wie gesagt nicht als Dienst starten will. (Öffne ich das Fenster Service Settings, sind auch sämtliche Checkboxen unchecked.) Das Starten des Apache gelingt nicht, ich bekomme die Meldung ERROR: Apache service not started [-1].

Ich habe dann auf SCM geklickt, um den Service Control Manager zu öffnen. Dort fand ich in der Liste den Eintrag zu Apache2.2, in dessen Eigenschaften unter Allgemein bei "Pfad zur EXE-Datei" der alte Pfad meiner früheren Installation der Version 1.6.0 steht. Darin dürfte der Konflikt liegen (vermute ich mal).

Meine Frage ist nur: Wie kriege ich Vista dazu, diesen Pfad auf den korrekten der Neuinstallation zu ändern? Ich wäre sehr dankbar um eure Hilfe, denn ich brauche dringend wieder ein funktionierendes xampp...

Vielen Dank und Grüße
ottogal
ottogal
 
Posts: 4
Joined: 26. November 2007 13:59

Postby sari42 » 01. December 2007 21:04

in früheren Versionen stand auch schon mal in den .bat Dateien Apache2 statt Apache2.2 . Kontrolle ist angesagt.
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Problem gelöst

Postby ottogal » 02. December 2007 17:05

Dank eines Hinweises von anderer Seite konnte ich das Problem lösen:

Man muss im Verzeichnis Windows\Prefetch die Datei APACHE.EXE-....
(es folgt noch eine 8 Zeichen lange Ziffern-Buchstaben-Kombination) löschen.
Diese wird von Vista zwar anschließend wieder angelegt, aber der Fehler tritt nicht mehr auf.

(Vielleicht weiß hier auch jemand, was diese Datei eigentlich macht...)

Gruß
ottogal
ottogal
 
Posts: 4
Joined: 26. November 2007 13:59

Postby DocFR » 20. December 2007 20:59

(Vielleicht weiß hier auch jemand, was diese Datei eigentlich macht...)


Im Ordner prefetch werden die genutzen Programme nach ihrer Frequentierung gelistet. Das Ergebnis sieht man, wenn man auf das Start-Symbol klickt - die Leiste links isses.

Gruß
DocFR
Every landing you walk away is a good landing.
User avatar
DocFR
 
Posts: 9
Joined: 24. July 2003 16:38
Location: Earth->Dortmund


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests