Probleme mit der aktuellen XAMPP-Version / phpMyAdmin

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit der aktuellen XAMPP-Version / phpMyAdmin

Postby MK70 » 25. November 2007 16:02

Hallo,

seit einiger Zeit habe ich arge Probleme mit XAMPP.

Zu Beginn einer Neuinstallation erhalte ich den Hinweis, daß meine XAMPP-Version nicht sicher ist und ich ein Passwort setzen soll. Das habe ich auch gemacht. Seitdem komme ich nicht mehr in den phpMyAdmin rein, da der das Passwort scheinbar nicht akzeptieren will. Sprich das Login-Fenster bleibt einfach bestehen (mehrfache Änderung PW -> Anzeige -> erfolgreicher Passwortwechsel).

Desweiteren kann ich einige Scripte nicht mehr vernünftig installieren. Ich bekomme immer Fehlermeldungen, daß z.B. das Passwort eingestellt sein muß, ansonsten würde das Script nicht laufen (Aktuell bei der [u=http://www.kadiba.de/index.php?CURL=softwaredetails,softwaredetails,6,18]Kadiba Galerie[/u] ).

Desweiteren habe ich bei phpMyAdmin grafische Probleme. Bis vor einigen Versionen konnte ich die Optik auf den dunkel/orange - Style umstellen, das geht jetzt nicht mehr. Genauso wie die Schriftgröße ( in % ). Ich bekomme auch immer den Fehler angezeigt, daß Cookies erlaubt sein müssen. Die sind aber auch freigeschaltet.

Die Probleme habe ich mit dem IE7 und dem Firefox 2.0.0.9.

Hat wer vielleicht eine Idee woran das liegen alles liegen kann ? :roll:

Wie gesagt, hatte ich bis vor einigen Versionen (ich meine 1.6.1) keinerlei Probleme. Und ich hab schon mit den 0.x-Versionen gearbeitet...
Gruss MK
Wäre ich ein GENIE, würde ich selbst coden... ;o))
User avatar
MK70
 
Posts: 66
Joined: 26. November 2004 18:13
Location: 47809, Krefeld
XAMPP version: 5.6.24
Operating System: Win10 pro/home 32/64bit

Fehlermeldung beim Galerie-Script

Postby MK70 » 25. November 2007 16:18

Warning: mysql_connect() [function.mysql-connect]: Unknown MySQL server host '#localhost#' (11001) in D:\xampp\htdocs\gal_bv\classes\p_mysql_db.class.php on line 22

Warning: mysql_query() [function.mysql-query]: Access denied for user 'ODBC'@'localhost' (using password: NO) in D:\xampp\htdocs\gal_bv\classes\p_mysql_db.class.php on line 522

Warning: mysql_query() [function.mysql-query]: A link to the server could not be established in D:\xampp\htdocs\gal_bv\classes\p_mysql_db.class.php on line 522
Gruss MK
Wäre ich ein GENIE, würde ich selbst coden... ;o))
User avatar
MK70
 
Posts: 66
Joined: 26. November 2004 18:13
Location: 47809, Krefeld
XAMPP version: 5.6.24
Operating System: Win10 pro/home 32/64bit

Postby Aristoteles » 29. November 2007 16:14

Hi MK70
Deiner Fehlermeldung nach sucht mysql_connect nach einem Server '#localhost#', den es aber nicht gibt. Du solltest im php-code 'localhost' (ohne Anführungszeichen) verwenden, ohne die Gartenhage. Dann sollte es klappen.
User avatar
Aristoteles
 
Posts: 12
Joined: 02. January 2005 13:34

Postby MK70 » 29. November 2007 20:22

ich versteh gerade nicht was Du mir damit sagen willst... :oops:
Gruss MK
Wäre ich ein GENIE, würde ich selbst coden... ;o))
User avatar
MK70
 
Posts: 66
Joined: 26. November 2004 18:13
Location: 47809, Krefeld
XAMPP version: 5.6.24
Operating System: Win10 pro/home 32/64bit

Postby sari42 » 29. November 2007 23:51

ersetze

#localhost#

in D:\xampp\htdocs\gal_bv\classes\p_mysql_db.class.php on line 22 durch

localhost

ist das so schwierig?
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby MK70 » 30. November 2007 09:49

Nein, wenn man das so beschreibt, ist das ok.
Dank Dir für den Tipp. 8)

Sorry, aber ich habe bisher NICHT an den Dateien in Xampp rumgefummelt, da ich denke, daß der Programmierer weiß was er tut... :roll:
Gruss MK
Wäre ich ein GENIE, würde ich selbst coden... ;o))
User avatar
MK70
 
Posts: 66
Joined: 26. November 2004 18:13
Location: 47809, Krefeld
XAMPP version: 5.6.24
Operating System: Win10 pro/home 32/64bit

Postby sari42 » 30. November 2007 12:25

hmm,
"Kadiba Galerie" ist nicht Bestandteil von xampp, oder hab ich was versäumt? Die haben bestimmt ein "readme" oder 'ne Installationsanleitung, worin das beschrieben ist.
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby MK70 » 30. November 2007 15:43

Nein, Kadiba ist eine eigenständige Software. Die, aber auch das WBBLite von Woltlab, liefen zuletzt nicht mehr. Daher meine Anfrage hier.

Ich hab eben auch nochmal was rumgebastelt. Seit ca. einer Stunde laufen die Programme zumindest mal wieder auf dem Lappy, PC muß ich noch testen.
Dazu hab ich meine Firewall runtergeschmissen, wodurch scheinbar auch andere Probs gelöst wurden (langsames rauf- und runterfahren des PC, rödeln bis zum Abwinken usw.) Ich glaub da ist ein Update bei Zonealarm fehlerhaft... :shock:
Gruss MK
Wäre ich ein GENIE, würde ich selbst coden... ;o))
User avatar
MK70
 
Posts: 66
Joined: 26. November 2004 18:13
Location: 47809, Krefeld
XAMPP version: 5.6.24
Operating System: Win10 pro/home 32/64bit

Postby sari42 » 01. December 2007 21:00

Zonealarm ist selbst ein Virus ;)
(zahllose Berichte hier im Forum)
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby MK70 » 02. December 2007 12:37

Ja, habe ich auch des öfteren gelesen, aber auch genauso viele Berichte mit anderer Meinung. Wie überall, gehen da die Meinungen weit auseinander. Werde mich aber auch mal nach was anderem umsehen... 8)
Gruss MK
Wäre ich ein GENIE, würde ich selbst coden... ;o))
User avatar
MK70
 
Posts: 66
Joined: 26. November 2004 18:13
Location: 47809, Krefeld
XAMPP version: 5.6.24
Operating System: Win10 pro/home 32/64bit


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests