XAMPP nicht im LAN

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP nicht im LAN

Postby phaziz » 14. November 2007 11:10

Hallo!

Xampp läuft auf einem Windows 2003 R2 - lokal funktioniert alles wunderbar. Blos wenn man versucht eine Seite im Lan aufzurufen bekommt man einen 403 Fehler Sie haben keine Berechtigung...Xampp läuft in der selben Domäne, etc.... muss man noch was anpassen, bevor der Xampp-Server im Lan erreichbar wird?

MFG
Christian
phaziz
 
Posts: 3
Joined: 14. November 2007 11:07

Postby Scory » 14. November 2007 11:20

Es gibt kein Xampp und keinen Xampp-Server. Du meinst Apache und einen Apache-Server. Bitte verwechselt das nicht immer wieder, Xampp ist nur eine Abkürzung für eine Sammlung verschiedener Werkzeuge und Programme.

Was genau versuchst Du und was gibst Du genau wo in der Browserzeile als URL ein und wie ist die 100%ige Fehlermeldung?

Grüße
Scory
Scory
 

Postby phaziz » 14. November 2007 12:07

ENTSCHULDIGUNG!

Also ich versuche den Apache Webserver, der mit der außerordentlichen Software Wampp (Xampp für Windows) auf einem Windows 2003 Rechner - der als Server fungiert - über das Lan zu erreichen.

Die Internetseiten liegen in einem Unterordner und ich versuche aus dem Browser eines anderen Computers im Lan folgendes: http://IP.DES.WIN.2003/VERZEICHNIS/index.php und es kommt eine Serverfehlermeldung 403 Sie besitzen keine Zugriffsrechte...

Im selben Netz hängen etliche andere Server (Windows CRM auf eigenem Windows Server, Win MySQL auf einem eigenen Server) ... alle sind erreichbar nur nicht der Apache aus WAMPP.... ich hoffe ich habe das jetzt besser erläutert?
phaziz
 
Posts: 3
Joined: 14. November 2007 11:07

Postby Scory » 14. November 2007 14:41

phaziz wrote:Die Internetseiten liegen in einem Unterordner und ich versuche aus dem Browser eines anderen Computers im Lan folgendes: http://IP.DES.WIN.2003/VERZEICHNIS/index.php und es kommt eine Serverfehlermeldung 403 Sie besitzen keine Zugriffsrechte...


So wie Du es beschreibst, machst Du es grundsätzlich falsch. Die Dateien dürfen nicht in irgendeinem Unterordner liegen, sondern MÜSSEN unterhalb des Ordners htdocs liegen (meistens c:\programme\xampp\htdocs).

Du kannst dort, unterhalb von htdocs einen Ordner "test" beispielsweise anlegen und darin die Datei index.php. Dann lautet die URL:

http://ip.des.win.2003/test/index.php

Grüße
Scory
Scory
 

Postby phaziz » 14. November 2007 16:40

Ob ich mein Verzeichnis jetzt - wie in meinem Beispiel VERZEICHNIS nenne, oder wie du es gerne hättest test ist doch wohl egal, oder?



Hast Du denn jetzt auch einen Vorschlag, an welcher Lan-Konfig es liegen könnte, das der Apache-Server nicht reagiert ;-)
phaziz
 
Posts: 3
Joined: 14. November 2007 11:07

Postby Wiedmann » 14. November 2007 19:24

an welcher Lan-Konfig es liegen könnte, das der Apache-Server nicht reagiert

Wenn unter dieser URI "http://IP.DES.WIN.2003/VERZEICHNIS/index.php" kein Server zu erreichen wäre, hättest du auch keinen 403 Fehler.

Ergo: Du kannst einen Server unter dieser URI erreichen.

- Ob das die richtige IP für deinen Server mit XAMPP ist, kann ich dir nicht sagen. (Ausgabe von "ipconfig" auf dem Server, und "nslookup"/"ping" auf dem Client vergleichen)

- Ob dieser Server der Apache vom XAMPP ist, kann ich dir auch nicht sagen. (Den Response-Header des Servers auswerten)

- Wenn es dann wirklich der Apache vom XAMPP ist, fehlen weitere Infos zum Helfen:
-- das derzeit definierte DocumentRoot
- die genaue Lage/Name der angeforderten Datei im Dateisystem
-- den für diesen Request dazugehörigen Eintrag im "error.log"/"access.log".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Scory » 14. November 2007 23:12

phaziz wrote:Ob ich mein Verzeichnis jetzt - wie in meinem Beispiel VERZEICHNIS nenne, oder wie du es gerne hättest test ist doch wohl egal, oder?




Das ist in der Tat egal - also ersetze in meinem Text den Wert 'test' durch den Wert 'VERZEICHNIS':

phaziz wrote:Hast Du denn jetzt auch einen Vorschlag, an welcher Lan-Konfig es liegen könnte, das der Apache-Server nicht reagiert ;-)


Hast Du denn jetzt auch einen Vorschlag, wo Du Dein VERZEICHNIS angelegt hast und ob es den Bedingungen aus meinem Beitrag genügt? Der Apacher-Server reagiert sehr wohl, er sagt Dir, dass Du Mist baust.

Du kannst auch gerne weiter rumpampen - ich habe keine solche Problem, die hast doch Du, oder?!
Scory
 


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests