xampp light seit gestern keine mailfunktion mehr

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

xampp light seit gestern keine mailfunktion mehr

Postby Promaetheus » 03. November 2007 19:38

ich hatte auf meinem usb stick immer das xampp lite laufen. in der php.ini habe ich einfach den smtp server meines providers angegeben und das hat gut funktioniert.

heute habe ich das ganze zeug neu installiert (auf dem usb stick) und jetzt funktioniert die mailfunktion nicht mehr.

es ist mir klar dass kein mailsystem dabei ist (mercury) aber mit der angabe des smtp servers in der php.ini müsste es doch funktionieren oder?
mfg Promaetheus
User avatar
Promaetheus
 
Posts: 25
Joined: 14. May 2003 14:08
Location: Vomp / Tirol / Austria

Postby Wiedmann » 03. November 2007 20:03

es ist mir klar dass kein mailsystem dabei ist (mercury) aber mit der angabe des smtp servers in der php.ini müsste es doch funktionieren oder?

Möglich...

und jetzt funktioniert die mailfunktion nicht mehr.

Warum nicht?

Dafür das Fehlerler/Warnungen von Mail angezeigt werden, musst schon du sorgen. Und uns diese dann mitteilen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Promaetheus » 03. November 2007 20:20

hab ich natürlich gemacht. sorry hatte vergessen die zu posten:
Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in O:\xampplite\htdocs\TCMS\modules\newsletter.php on line 104

hab dort den chello smtp server eingetragen: mgate.chello.at
mfg Promaetheus
User avatar
Promaetheus
 
Posts: 25
Joined: 14. May 2003 14:08
Location: Vomp / Tirol / Austria

Postby Wiedmann » 03. November 2007 20:27

hab dort den chello smtp server eingetragen: mgate.chello.at

Wo "dort"?

Failed to connect to mailserver at "localhost" port 25,

Jedenfalls nicht in der "php.ini" die dein PHP benutzt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Promaetheus » 23. November 2007 01:51

doch. in der apache/bin/php.ini. nicht in der php/php.ini

wäre doch korrekt oder?
mfg Promaetheus
User avatar
Promaetheus
 
Posts: 25
Joined: 14. May 2003 14:08
Location: Vomp / Tirol / Austria

Postby Wiedmann » 23. November 2007 04:02

wäre doch korrekt oder?

100%ig kann ich dir das nicht beantworten. Da musst du schon in der Ausgabe von phpinfo() nachschauen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests