kann nur manche php dateien öffnen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

kann nur manche php dateien öffnen

Postby JuliusCaesar » 01. November 2007 18:29

Hey ich habe ein Problem,
ich habe das alte XAMPP deinstalliert und ne neue version installiert:
nun habe ich ein Problem:
ich kann mein in php geschriebenes Projekt nicht mehr öffnen
ich bekomme immer eine Datei zum download angeboten
Image

weenn ich eine php datei mit
Code: Select all
<?php
echo "bla";
?>

öffne wird das "bla" richtig angezeigt, wo leigt der fehler?
habt ihr da ideen?
JuliusCaesar
 
Posts: 14
Joined: 30. January 2007 12:15

Postby Wiedmann » 01. November 2007 18:38

Wo kommt dieses "application/x-httpd-php5" her? Das wird so jedenfalls nicht vom XAMPP konfiguriert.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby JuliusCaesar » 01. November 2007 23:00

ich habe keine Ahnung, es handelt sich bei der php datei um eine stink normale php datei, die ich von meinem webspace runtergeladen hab und ins htdocs Verzeichnis von XAMPP kopiert habe
auf dem webspace läuft das ohne Probleme....
und groß was geändert habe ich in XAMPP noch nichts
(nur halt passwörter geändert, aber ich habe nichts an der server config geändert)...
dieses Phänomen ist mir überhaupt noch nie begegnet, ich weiß gar nicht was das für ne datei ist....
wisst ihr das?
JuliusCaesar
 
Posts: 14
Joined: 30. January 2007 12:15

Postby Wiedmann » 01. November 2007 23:05

ich habe keine Ahnung, es handelt sich bei der php datei um eine stink normale php datei, die ich von meinem webspace runtergeladen hab und ins htdocs Verzeichnis von XAMPP kopiert habe

Es geht hier weniger um diese PHP-Datei, als um die Konfiguration des Apachen an sich. Evtl. hast du ja mehr runtergeladen als diese PHP-Datei? Eine ".htaccess" zum Beispiel?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby JuliusCaesar » 01. November 2007 23:59

wow, das ging ja schnell
im Hauptverzeichnis war ne htaccess dabei, habe die mal gelöscht
das Hauptverzeichnisses geht wieder
sobald ich aber
http://localhost/upload/si-stats/login
aufrufe kommt wieder die Meldung, obwohl dort keine htaccess ist (ich finde zumindest keine, habe auch mal nach einer .htaccess im gesamten htdocs Verzeichnis suchen lassen, ohne erfolg)
das merkwürdige
sobald ich aber ne Konkrete Datei angebe gehts wieder
http://localhost/upload/si-stats/login/index.php

hast du dafür auch ne Idee?
auf jedenfall schonmal danke für den Tip mit der htaccess 8)
JuliusCaesar
 
Posts: 14
Joined: 30. January 2007 12:15

Postby Wiedmann » 02. November 2007 00:58

(ich finde zumindest keine, habe auch mal nach einer .htaccess im gesamten htdocs Verzeichnis suchen lassen, ohne erfolg)

Sofern das nicht was aus deinem Browsercache ist...

Ich denke gescheiter ist es, den Inhalt aller Dateien nach "application/x-httpd-php5" zu durchsuchen und schauen wo es vorkommt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby JuliusCaesar » 02. November 2007 01:50

wow, geht ja echt schnell heir mit dem support 8)
es kam scheinbar tatsächlich aus dem browser cache, habe alle privaten Dateien mal gelöscht und jetzt gehts 8)
vielen dank für die schnelle Hilfe :!:
JuliusCaesar
 
Posts: 14
Joined: 30. January 2007 12:15


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests