Web-Dateien auslagern unter WinXP Pro

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Web-Dateien auslagern unter WinXP Pro

Postby DFR » 31. October 2007 20:52

Moin zusammen!

Ich habe folgendes Problem...
Nach Installation von xampp-win32-1.6.4 läuft an sich alles prima.
Der Apache ist als Service registriert und läßt sich sauber starten und beenden. Die restlichen Dienste benötige ich nicht, das Control Panel startet nicht als Dienst, sondern als Anwendung.

Nun halte ich zwecks Katastrophensicherheit das Betrübssystem und die Daten soweit wie möglich auseinander. Das System und die Programme liegen auf Platte C:, die Daten auf Platte D:. Dies soll auch so bleiben.

Sprich: In meinem System-Backup möchte ich xampp auf C: mit drinhaben, die angesprochenen Webdateien auf D: im Datenbackup.

Nun habe ich versucht, in der httpd.conf in Zeile 176 den Eintrag

DocumentRoot "C:/Programme/xampp/htdocs"

in

DocumentRoot "D:/Dokumente und Einstellungen/Dirk Frieborg/Homepage/root"

zu ändern.

Danach ließ sich Apache nicht mehr starten. Könnte dies ein Problem mit langen Dateinamen bzw. Leerzeichen sein?

Also gab es

#DocumentRoot "D:/Daten/Homepage/root"

Apache startete wieder, der Zugriff per Browser auf localhost jedoch brachte einen Error 403: Zugriff auf das Verzeichnis nicht möglich.

Kopiere ich meine Homepage lokal nach C:\Programme\xampp\htdocs, löppt alln's. Da will ich sie aber nicht haben.

Wie kann ich xampp sauber zum Laufen bringen, meine Daten jedoch dort (auch mit langen Namen!) dort einhängen, wo ich sie haben möchte?


System ist Windows XP Professional, SP2 und aktuelle Updates sind eingespielt. Die einfache Dateifreigabe wird verwendet, also keine Rechte einstellbar. Ja, ich habe Admin-Rechte. ,-)

Für einen Tip wäre ich sehr dankbar; Suche nach Hilfe für die aktuelle Version war bislang erfolglos...[/b]
So denn, das war's...
...DFR
DFR
 
Posts: 2
Joined: 31. October 2007 20:11

Postby Wiedmann » 31. October 2007 20:59

Da du nicht in die Logdateien geschaut hast, kann ich nur raten:

Code: Select all
DocumentRoot "D:/Dokumente und Einstellungen/Dirk Frieborg/Homepage/root"

Danach ließ sich Apache nicht mehr starten

Evtl. hat der Dienst keine Berechtigungen auf dieses Verzeichnis?

Also gab es
Code: Select all
#DocumentRoot "D:/Daten/Homepage/root"

Durch das "#" hat diese Zeile ja keine Wirkung. Welches DocumentRoot ist dann noch aktiv?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby DJ DHG » 31. October 2007 21:01

Moin Moin!

- Es muss das DocumentRoot und ServerRoot geändert werden!
- Leerzeichen sollten vermieden werden
- Ein Blick in die Logdatei(en) sind immer wieder aufschlussreich.

mfg DJ DHG

*edit*
Wieder zu langsam...
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Wiedmann » 31. October 2007 21:39

- Es muss das DocumentRoot und ServerRoot geändert werden!

Nein, den ServerRoot nicht, aber den Directory-Block der zum DocumentRoot gehört.

- Leerzeichen sollten vermieden werden

Wegen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby DJ DHG » 31. October 2007 21:45

- Leerzeichen sollten vermieden werden

Wiedmann wrote:Wegen?


Da ich die Anführungszeichen übersehen habe.

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby DFR » 01. November 2007 20:54

Moin!

DJ DHG wrote:- Es muss das DocumentRoot und ServerRoot geändert werden!


Das war's!
(...und funktioniert dan Anführungs- laternich auch mit Leerzeichen.)

Supi, herzlich Dank an alle Beteiligten! :D
So denn, das war's...
...DFR
DFR
 
Posts: 2
Joined: 31. October 2007 20:11


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests