phpAdmin startet nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

phpAdmin startet nicht

Postby super » 31. October 2007 10:47

guten tag zusammen
ich benutze windowsXP und habe xampp installiert

bei eingabe Localhost im explorer kome ich auch auf die seite XAMPP für Windows

wenn ich da links den link phpAdmin klicke kommt:
[i]phpMyAdmin - Fehler
Die Erweiterung mysql kann nicht geladen werden. Bitte ??ie Ihre PHP-Konfiguration. - Dokumentation

siehe:
http://super-skat.de/xampp/apachefriends_fehler.htm

:) habe das controlpanel mit angezeigt.

in den FAQ habe ich was gelesen von akualisieren einer dll , kann aber nicht nachvollziehen wie ich das machen soll.

ich hoffe es kann mir da jemand helfen das Problem zu lösen

vielen dank
roland_k

PS: kann ich das bild auch direkt hier einfügen (img) ? aber was gebe ich da dann ein ?
logik ist einfach, man muss sie nur verstehen:-)
super
 
Posts: 20
Joined: 31. October 2007 10:07

Postby Wiedmann » 31. October 2007 14:12

und habe xampp installiert

Wie genau?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby super » 31. October 2007 16:03

hi

was wie ??

habe den windows intaller runtergeladen und damit installiert

ich wuesste nicht wie isch das anders beantworten sollte

danke
gruss roland_k
logik ist einfach, man muss sie nur verstehen:-)
super
 
Posts: 20
Joined: 31. October 2007 10:07

Postby Wiedmann » 31. October 2007 16:10

habe den windows intaller runtergeladen und damit installiert

- Wohin hast du den XAMPP installiert?

- War auf dem Rechner schonmal ein PHP oder ein Zend Produkt?

- Das XAMPP Demo "CD-Datenbank" tut also auch nicht (und die Anderen?)?

- Welche "php.ini" benutzt dein PHP? (siehe phpinfo())
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby super » 31. October 2007 17:17

oh vielen dank an Moderator

also...irgendwie ist hier noch was anders faul, ich muss immer den
IIS admin unter verwaltung/dienste beenden, der immer beim neustart des PC gestartet wird, sonst startet der apache nicht

installiert habe ich nach:
C:\xampp\xampp-control.exe

laut PHP-Info ist das Version 5.2.4

wenn ich auf CD collection klicke kommt da was wie:

Code: Select all
selectFont('../../php/extras/pdf-related/Helvetica.afm'); $pdf->ezText('CD Collection',14); $pdf->ezText('© 2002/2003 Kai Seidler, oswald@apachefriends.org, GPL',10); $pdf->ezText('',12); $result=mysql_query("SELECT id,titel,interpret,jahr FROM cds ORDER BY interpret;"); $i=0; while( $row=mysql_fetch_array($result) ) { $data[$i]=array('interpret'=>$row['interpret'],'titel'=>$row['titel'],'jahr'=>$row['jahr']); $i++; } $pdf->ezTable($data,"","",array('width'=>500)); $pdf->ezStream(); exit; } ?>
"; die(); } mysql_select_db("cdcol"); ?
0) { echo " "; echo "  "; echo "
"; } echo " "; echo "  "; echo " ".$row['interpret']." "; echo " ".$row['titel']."  "; echo " ".$row['jahr']."  "; echo " [".$TEXT['cds-button1']."] "; echo "  "; echo "
"; $i++; } echo " "; echo "  "; echo "
"; ?> 


die andern links funtionieren anscheinend auch nciht


ja es kann sein dass ich PHP schon mal versucht habe zu instllieren

vor längerer zeit hatte ich schon mal XAMPP installiert, da ist das toll gelaufen, aber ich brauchte das nicht mehr drum habe ich das mal deinstalliert :-( :oops:

ich hoffe dass es ueberhaupt moeglich ist bei der konstallation Hilfe zu leisten...

aber mein system will ich im moment nicht komplett neu installieren

vielen dank

gruss roland_k
logik ist einfach, man muss sie nur verstehen:-)
super
 
Posts: 20
Joined: 31. October 2007 10:07

Postby Wiedmann » 31. October 2007 17:21

ich muss immer den IIS admin unter verwaltung/dienste beenden, der immer beim neustart des PC gestartet wird, sonst startet der apache nicht

Das ist normal. Du kann nur einen Webserver laufen haben, da beide den selben Port (80) für HTTP Anfragen benutzen.

Wiedmann wrote:- Welche "php.ini" benutzt dein PHP? (siehe phpinfo())

:?:
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby super » 31. October 2007 17:45

PHP Version 5.2.4

System Windows NT ROLAND 5.1 build 2600
Build Date Aug 30 2007 07:05:48
Configure Command cscript /nologo configure.js "--enable-snapshot-build" "--with-gd=shared"
Server API Apache 2.0 Handler
Virtual Directory Support enabled
Configuration File (php.ini) Path C:\WINDOWS
Loaded Configuration File C:\Programme\PHP\php.ini
PHP API 20041225
PHP Extension 20060613
Zend Extension 220060519
Debug Build no
Thread Safety enabled
Zend Memory Manager enabled
IPv6 Support enabled
Registered PHP Streams php, file, data, http, ftp, compress.zlib
Registered Stream Socket Transports tcp, udp
Registered Stream Filters convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, zlib.*

This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies

fonde nichts anderes ??


gruss roland_k
logik ist einfach, man muss sie nur verstehen:-)
super
 
Posts: 20
Joined: 31. October 2007 10:07

Postby Wiedmann » 31. October 2007 18:24

Loaded Configuration File C:\Programme\PHP\php.ini

Irgendwie hast du noch ein anderes PHP, oder ein altes PHP nicht korrekt deinstalliert.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby super » 31. October 2007 18:29

hm sicher ist da sowas im weg ...hinderlich ?

wie koennte ich da zum ziel kommen ?

xampp deistallieren ....?

aber wie kann ich alles im zusammenhang von php installationen rückgängigmachen ?

:arrow: ansonsten vielen dank für deine Muehe

gruss roland_k
logik ist einfach, man muss sie nur verstehen:-)
super
 
Posts: 20
Joined: 31. October 2007 10:07

Postby Wiedmann » 31. October 2007 18:38

hm sicher ist da sowas im weg

Dieser Satz soll genau was bedeuten?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby super » 31. October 2007 18:44

na ja ich nehme an dass ich hier auf dem rechner

eine php installation nicht sauber entfernt habe

frage ist eben was koennte ich tun,,,,

einträge in der reg suchen ...und loeschen ?? wenn ja welche

oder was koennte ich machen damit das zum laufen kommt ?

danke
gruss
roland_k

ansonsten schoenen Feiertag
logik ist einfach, man muss sie nur verstehen:-)
super
 
Posts: 20
Joined: 31. October 2007 10:07

Postby Wiedmann » 31. October 2007 18:46

einträge in der reg suchen ...und loeschen ?? wenn ja welche

http://de.php.net/manual/en/configuration.php
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby super » 31. October 2007 19:28

tja danke

damit kann ich aber nicht viel anfangen :-(

mit engl..habe so meine prbleme

aber trotzdem danke
gruss
roland-k
logik ist einfach, man muss sie nur verstehen:-)
super
 
Posts: 20
Joined: 31. October 2007 10:07

Postby Wiedmann » 31. October 2007 20:11

mit engl..habe so meine prbleme

http://de.php.net/manual/de/configuration.php
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby super » 05. November 2007 08:00

guten morgen

es geht alles auf einmal?

danke für die Erklärungen

gruss roland_k
logik ist einfach, man muss sie nur verstehen:-)
super
 
Posts: 20
Joined: 31. October 2007 10:07


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests