Apache stürzt bei Aufruf eines PHP-Scriptes ab

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache stürzt bei Aufruf eines PHP-Scriptes ab

Postby Arborshate » 18. October 2007 16:13

Hi,

ich hatte bereits vor ein paar Wochen XAMPP bei mir installiert. Jedoch stürzte Apache immer, wenn ich die PHPInfo oder ein anderes PHP-Script aufrief, ab. Windows sagte zwar, dass ein Fehler aufgetreten wäre und Apache beendet werden muss und wollte mir einen Problembericht andrehen, jedoch lief Apache nach kurzer Zeit wieder an.
Als ich das Script "index.php" im Ordner htdocs aufrief bekam ich eine Ausgabe, dass etwas nicht in Ordnung wäre mit der XAMPP-Installation.
Originaltext:
Code: Select all
Something is wrong with the XAMPP installation :-(

Aber anscheinend war nur Apache abgestürzt, denn wenn PHP nicht mehr laufen würde, müsste der PHP-Code, der vor dieser Ausgabe stand und das Script abbrach, eigentlich nicht ausgeführt, sondern ausgegeben werden.
Außerdem wurde XAMPP nicht richtig geladen. Entweder braucht es ziemlich lange zum laden, oder es stellt sich kein Fortschritt ein.
Deshalb beschloss ich, XAMPP zu deinstallieren.

Heute Morgen dachte ich mir, dass XAMPP noch eine zweite Chance verdient hätte. Doch nach der erfolgreichen Installation traten die selben Fehler erneut auf.

Ich würde mich freuen, wenn jemand mir helfen könnte...

EDIT: kleiner Rechtschreibfehler wurde berichtigt... :oops:
Arborshate
 
Posts: 1
Joined: 18. October 2007 15:35

Postby Marcus24 » 08. January 2008 20:58

ich habe das gleiche problem.
ich bitte DRINGENDST um eine Sösung bzw einen Tipp um den Fehler zu beheben.

Danke
Marcus24
 
Posts: 6
Joined: 23. December 2007 20:40

Postby Scory » 08. January 2008 21:14

Marcus24 wrote:ich habe das gleiche problem.
ich bitte DRINGENDST um eine Sösung bzw einen Tipp um den Fehler zu beheben.


Formatiere C: und installiere Windows neu. Danach sofort Xampp - und wenn es dann nicht funktioniert (was ich bezweifele), dann ist es ein Problem für dieses Forum.

Ansonsten installiere DANACH Stück für Stück die ganze Software, die Du brauchst. Wenn es Xampp dann irgendwann nicht mehr tut, hast Du den Schuldigen gefunden.

Bitte
Scory
 

Postby Marcus24 » 08. January 2008 21:56

tja, da haben wir ein problem.
ich habe schon einmal meine platte formatiert und als erstes xampp installiert. trotzdem bleibt es bei diesem fehler.

habe jetzt 3 tage mit xampp problemlos gearbeitet.
heute hat es seinen geist aufgegeben. warum ? keine ahnung.
ich habe weder irgendwas installiert noch verändert.
habe jediglich nur an meinen template also .tpl dateien vom projekt geschraubt, sonst nix.

also, wo ist nun das problem ?
Marcus24
 
Posts: 6
Joined: 23. December 2007 20:40

Postby Scory » 08. January 2008 22:19

Dann lösche doch einfach die index.php aus dem htdocs Ordner - die wird sowieso nicht benötigt.
Scory
 

Postby Marcus24 » 08. January 2008 22:35

wie kommst du denn darauf das ich die nicht benötige?
hast schonmal ne html datei mit ner datenbank kommunizieren sehen ?
Marcus24
 
Posts: 6
Joined: 23. December 2007 20:40

Postby Marcus24 » 08. January 2008 22:38

ich sende hier mal die log datei aus dem apache ordner:

[Tue Jan 08 22:30:58 2008] [notice] Child 3380: Starting thread to listen on port 443.
[Tue Jan 08 22:30:58 2008] [notice] Child 3380: Starting thread to listen on port 80.
[Tue Jan 08 22:31:51 2008] [error] [client 127.0.0.1] script 'C:/xampp/htdocs/single/index.php' not found or unable to stat
[Tue Jan 08 22:32:16 2008] [error] [client 127.0.0.1] script 'C:/xampp/htdocs/single/index.php' not found or unable to stat
[Tue Jan 08 22:36:06 2008] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/single/templates/active/images/blue_window_3_bars.jpg, referer: http://localhost/single/login.php
[Tue Jan 08 22:36:06 2008] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/single/templates/active/images/module_head.jpg, referer: http://localhost/single/templates/active/default.css
[Tue Jan 08 22:36:12 2008] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/single/templates/active/images/blue_window_3_bars.jpg, referer: http://localhost/single/login.php
[Tue Jan 08 22:36:13 2008] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/single/templates/active/images/module_head.jpg, referer: http://localhost/single/templates/active/default.css
[Tue Jan 08 22:36:18 2008] [notice] Parent: child process exited with status 3221225477 -- Restarting.
Marcus24
 
Posts: 6
Joined: 23. December 2007 20:40

Postby Scory » 09. January 2008 00:14

Marcus24 wrote:wie kommst du denn darauf das ich die nicht benötige?


Stelle Dich nicht noch blöder an als nötig: schau doch einfach in die index.php hinein, dann würdest Du nicht so einen Mist schreiben, sondern begreifen. Diese index.php gibt die "Fehlermeldung" aus, die Dich so verunsichert.

Du brauchst die index.php nicht, die in htdocs liegt. Immer noch nicht.
Scory
 


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests