Mercury Tutorial -> keine Verbindung im Thunderbird

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Mercury Tutorial -> keine Verbindung im Thunderbird

Postby vamp » 02. October 2007 19:21

Hallo zusammen,

ich habe mir vor längerer Zeit mal Mercury erfolgreich eingerichtet, nachdem ich nun meinen rechner neu installieren musste habe ich mir auch die aktuelle version von Xampp installiert.

ich habe das tutorial von Heini_net
http://community.apachefriends.org/f/viewtopic.php?t=7915&postdays=0&postorder=asc&highlight=mercury&start=15
zur Hilfe genommen.

Sitze seit etwa 4 Std. und gehe die Anleitung Schritt für Schritt durch, aber
leider bekomme ich Mercury nicht mehr ans laufen...

Ich poste mal die einzelnen schritte die ich durchgeführt habe, vielleicht hab ich ja einen Fehler drin.

1.) Configuration -> Mercury Core Module

Internet name for this system: testxampp.de

dann auf dem Register "Local domains"

Local host or server: testxampp
Internet name: testxampp.de


2.) Configuration -> MercuryS SMTP Server

Announce myself as: testxampp.de

dann auf dem Register "Connection Control"
ein Häkchen bei "Don not permit SMTP relaying of non-local mail" und "Authenticated smtp connections may relay mail" gesetzt


Punkt 3 der Anleitung (Relay Service) habe ich übersprungen.

3.) Configuration -> MercuryE SMTP Client

Announce myself as: testxampp.de

Name Servers: dieses Feld habe ich frei gelassen, da ich nicht wußte was dort rein muss. Ich habe es aber auch mit der IP 127.0.0.1 versucht, leider ohne Erfolg.

4.) Configuration -> Manage local Users

einen neuen User mit folgenden Angaben erstellt

Username: Webmaster
Personal Name: testxampp.de Webmaster
Password: 123456

dann habe ich das Mercury Admincenter geschlossen und mercury neu gestartet.


Nun habe ich im Thunderbird wie folgt ein Postfach erstellt.

1.) "E-Mail-Konto" ausgewählt
2.) Ihr Name: Webmaster
3.) Email: webmaster@testxampp.de
4.) Posteingang-Server: pop.testxampp.de
5.) Postausgang-Server (SMTP): smtp.testxampp.de
6.) Posteingang-Server Benutzername: webmaster
7.) Postausgang-Server Benutzername: webmaster
8.) Kontobezeichnung: webmaster@testxampp.de


Das war alles was ich gemacht habe !!

Wenn ich jetzt über Thunderbird die Mails abrufen möchte erscheint folgende Fehlermeldung.

"Konnte nicht mit dem Server pop.testxampp.de verbinden"


Ich hoffe mir kann jemand helfen, ich verstehe nicht warum das jetzt nicht funktioniert.

Muss dazu sagen, dass ich davon keine ahnung habe und nur das tutorial durchgearbeitet habe.


Ich möchte auch keine Mail ins internet schicken... ich brauche es nur zum testen von php-scripten !!

Sorry für den langen Text, dachte je ausführlicher desto besser...

Vielen dank schon mal für eure Hilfe

Markus
vamp
 
Posts: 14
Joined: 02. October 2007 18:43

Postby Wiedmann » 02. October 2007 19:55

4.) Posteingang-Server: pop.testxampp.de
5.) Postausgang-Server (SMTP): smtp.testxampp.de

Gibt's denn diese 2 Host/Domainnamen, und zeigen diese auf die IP von dem Rechner mit deinem Mercury?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby vamp » 02. October 2007 19:58

Hallo Wiedmann,

wenn ich ehrlich bin kann ich dir das nicht sagen :oops:

wo kann ich das rausfinden bzw. wo müßte ich das eintragen.

bin mir fast ziemlich sicher, dass ich das damals genau so gemacht habe.

Wäre super nett von dir wenn du mir helfen könntest !

Vielen Dank schon mal !

Markus
vamp
 
Posts: 14
Joined: 02. October 2007 18:43

Postby Wiedmann » 02. October 2007 22:13

wo kann ich das rausfinden

z.B. mit "nslookup".

bzw. wo müßte ich das eintragen.

In deinem DNS-Server oder in der Datei HOSTS.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby vamp » 02. October 2007 23:51

Hallo Wiedmann,

sorry, aber damit kann ich absolut nichts anfangen,
ich versteh nicht was du damit meinst.

ich hab mercury damals ja schon mal am laufen gehabt, funktionierte einwandfrei ! Aber ich habe noch nie was "nslookup" oder mit "HOSTS" gemacht.

Ist mein oben beschriebener Weg den soweit in Ordnung, also sollte es so funktionieren? oder habe ich vielleicht doch irgendwas was vergessen?

nur um sicher zu gehen...

Viele Grüße
markus

PS: Brauche ich den überhaupt einen DNS Server, wenn ich nur "in Xampp" mails verschicken will. Hatte ja oben geschreiben, dass ich keine Mail ins Internet schicken oder von Internet bekommen will...
vamp
 
Posts: 14
Joined: 02. October 2007 18:43

Postby vamp » 04. October 2007 16:40

Hallo zusammen,

ich habe mich mal in google umgeschaut und einiges gefunden...

ich habe ein tutorial gefunden und zwar dieses
http://www.selbstverwaltung-bundesweit. ... yhilfe.pdf

habe alle einstellungen vorgenommen, bekomme im Thunderbird immernoch den gleichen fehler, dass keine verbindung hergestellt werden kann.

ich habe darauf über start -> ausführen -> telnet 127.0.0.1 25
folgendes herausgefunden.

220 localhost ESMTP server ready.

zusätzlich habe ich über mercury -> file -> send mail message
eine testmail an einen user geschickt den ich unter Configuration -> Manage local user angelegt habe

diese mail wurde einwandfrei verschickt und unter Xampp -> MercuryMail -> MAIL -> testuser abgelegt...

soweit ich das verstanden habe sollte mercury doch richtig eingerichtet worden sein, oder?

wo liegt der Fehler, dass Thunderbird und Outlook keine verbindung herstellen können?

Ich hoffe ihr könnt mir helfen !!

viele grüße
Markus
vamp
 
Posts: 14
Joined: 02. October 2007 18:43

Postby vamp » 04. October 2007 17:21

Hallo zusammen

ich habe gerade noch ein bisschen gelesen und durch zufall was gefunden was mein problem löste....

ich habe im outlook und im thunderbird immer folgendes eingetragen

pop3.localhost
smtp.localhost

nachdem ich bei beiden feldern nur 127.0.0.1 eingetragen habe funktionierte es einwandfrei ! also gar kein pop oder smtp schreiben... nur die IP...

Viele Grüße

Markus (mit 1000 grauen Haaren mehr, aber zufrieden :-)
vamp
 
Posts: 14
Joined: 02. October 2007 18:43


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests