VirtualHost - bin etwas ratlos

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

VirtualHost - bin etwas ratlos

Postby chapolote » 18. August 2007 14:06

Ich habe in der httpd-vhosts.conf folgendes definiert:

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    ServerName localhost
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin webmaster@localhost
    DocumentRoot "d:/Webserver/htdocs"
    ScriptAlias /cgi-bin/ "d:/Webserver/htdocs/cgi-bin/"

    <Directory "d:/Webserver/htdocs">
    Options Indexes FollowSymLinks
    Options +Includes
#   Options +
    AllowOverride FileInfo
#    AllowOverride None
    Order allow,deny
    Allow from all
    DirectoryIndex index.php index.html index.htm
    </Directory>

</VirtualHost>

<VirtualHost *:80>
    ServerName meinesite.local
    ServerAlias w..w.meinesite.local
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin webmaster@localhost
    DocumentRoot "d:/Webdesign/Projekte/MaSu/Website"
    ScriptAlias /cgi-bin/ "d:/Webdesign/Projekte/MaSu/Website/cgi-bin/"

    <Directory "d:/Webdesign/Projekte/MaSu/Website">
    Options Indexes FollowSymLinks
    Options +Includes
#   Options +
    AllowOverride FileInfo
   
    Order allow,deny
    Allow from all
    DirectoryIndex index.html index.htm index.php
    </Directory>

</VirtualHost>

NameVirtualHost 127.0.0.1:8001

<VirtualHost 127.0.0.1:8001>
    ServerName 127.0.0.1
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin webmaster@localhost
    DocumentRoot "d:/Webserver/htdocs/oxylbox/www"
    ScriptAlias /cgi-bin/ "d:/Webserver/htdocs/cgi-bin/"
    RewriteEngine on
    RewriteRule ^/(.*)/([0-9][0-9][0-9])*.vdr.mpg$ /$1/$2.vdr
    RewriteRule ^/config(.*) /oxylstart.php [R]
    ErrorDocument 403 /common/error.php?error=403

    <Directory "d:/Webserver/htdocs/oxylbox/www">
    Options Indexes FollowSymLinks
    Options +Includes
#   Options +
    AllowOverride FileInfo
    AllowOverride None
    Order allow,deny
    Allow from all
    DirectoryIndex index.php index.html index.htm
    </Directory>
   
    Alias /lwc/ "C:/"
    Alias /lwd/ "D:/"
    Alias /lwe/ "E:/"
    Alias /lwf/ "F:/"
    Alias /lwg/ "G:/"
    Alias /lwh/ "H:/"
    Alias /lwi/ "I:/"
    Alias /lwj/ "J:/"
    Alias /lwk/ "K:/"
    Alias /lwl/ "L:/"
    Alias /lwm/ "M:/"
    Alias /lwn/ "N:/"
    Alias /lwo/ "O:/"
    Alias /lwp/ "P:/"
    Alias /lwq/ "Q:/"
    Alias /lwr/ "R:/"
    Alias /lws/ "S:/"
    Alias /lwt/ "T:/"
    Alias /lwu/ "U:/"
    Alias /lwv/ "V:/"
    Alias /lww/ "W:/"
    Alias /lwx/ "X:/"
    Alias /lwy/ "Y:/"
    Alias /lwz/ "Z:/"
    Alias /root/ "/"
    Alias /UNC/ "//"   

</VirtualHost>


Außerdem habe ich in der httpd.conf noch Listen 8001 angegeben.

Der letzte vhost ist, wie man ja sieht, für oxyl definiert, und genau da hab ich jetzt plötzlich ein Problem:

Gebe ich im Browser als Adresse localhost:8001 ein, wird mir auch anstandslos die Startseite von Oxyl präsentiert, so weit, so gut.
Versuche ich jetzt aber mit meiner entfernten Auvisio-Box über das Netzwerk auf 192.168.178.xx:8001 zuzugreifen, wird mir die Xampp-Startseite, präsentiert, dasselbe passiert auch über meinen Browser, sobald ich anstatt localhost die IP meines Rechners einsetze.

Ich bin jetzt etwas ratlos, weil zumindest mit oben angegebener httpd-vhost.conf vor nicht all zu langer Zeit auch der Zugriff über die IP funktioniert hatte. In der error.log wird auch nichts aufgeführt.

An welcher Schraube muß ich da jetzt drehen, bzw. wo muß ich anscheined was verändert haben, daß eine Anfrage an ip:8001 nicht mehr ins Oxyl-Verzeichnis führt.

Vermute mal, daß das was ganz simples ist, aber ich steh wohl auf dem Schlauch. Weiß jemand Rat?

Danke und Gruß,
chapolote
chapolote
 
Posts: 8
Joined: 17. July 2007 10:37
Location: Karlsruhe

Postby Wiedmann » 18. August 2007 14:14

Gebe ich im Browser als Adresse localhost:8001 ein, wird mir auch anstandslos die Startseite von Oxyl präsentiert, so weit, so gut.
Versuche ich jetzt aber mit meiner entfernten Auvisio-Box über das Netzwerk auf 192.168.178.xx:8001 zuzugreifen, wird mir die Xampp-Startseite, präsentiert, dasselbe passiert auch über meinen Browser, sobald ich anstatt localhost die IP meines Rechners einsetze.

Du bindest diesen VHost ja auch explizit an die IP 127.0.0.1 (bzw. localhost)...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby chapolote » 18. August 2007 14:24

Wiedmann wrote:Du bindest diesen VHost ja auch explizit an die IP 127.0.0.1 (bzw. localhost)...


Ich sags doch, ich steh wohl auf dem Schlauch:

Für mich als "Laie" ist 127.0.0.1 = localhost = ip des Rechners. Ist das so nicht richtig?
Oder anderst gesagt:
egal ob ich im Browser 127.0.0.1 oder localhost oder 192.168.178.xx eingebe, immer lande ich auf der Startseite von Xampp.
Wenn ich aber 127.0.0.1:8001 oder localhost:8001 eingebe, lande ich bei Oxyl, bei ip:8001 aber bei Xampp.

Also, Deine Antwort hört sich für mich so an, wie wenn mir sofort ein Licht aufgehen müßte, aber anscheinend ist bei mir die Birne futsch... :lol:

Und wie oben erwähnt: ich schwör Stock und Stein, daß die httpd-vhost.conf so schon funktioniert hat, daß es also an ner anderen Schraube liegen müßte, aber vielleicht lieg ich da doch falsch...
chapolote
 
Posts: 8
Joined: 17. July 2007 10:37
Location: Karlsruhe

Postby chapolote » 18. August 2007 14:33

Ok, ok, in meinem Alter dauerts halt ein wenig länger :lol:
hab den entsprechenden Part folgendermaßen abgeändert, und jetzt geht's natürlich auch:

Code: Select all
...
NameVirtualHost *:8001

<VirtualHost *:8001>
    #ServerName 127.0.0.1
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin webmaster@localhost
....


Eine Frage bleibt noch: ServerName hab ich auskommentiert. Ist das so richtig, d.h. den Parameter brauch ich hier doch nicht? Oder was was sollte da jetzt stehen?

Danke für den guten Tipp,
chapolote
chapolote
 
Posts: 8
Joined: 17. July 2007 10:37
Location: Karlsruhe


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests