[Vista] mod_rewrite lässt sich nicht mehr aktivieren

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

[Vista] mod_rewrite lässt sich nicht mehr aktivieren

Postby burnersk » 16. August 2007 12:49

Hallo.

Ich habe auf meinem Windows Vista Home Premium XAMPP 1.6.3a installiert. Nach einer Bearbeitung der httpd.conf auf Port 8080 (Skype ist installiert) funktioniert der Server auch.
Nun wollte ich mod_rewrite aktivieren in der httpd.conf und der Server stützt ab.

Installationsverzeichnis: D:\server\ (ohne XAMPP. Ist das XAMPP Verzeichnis)

Folgende Änderungen wurden durchgeführt:
httpd.conf:
Code: Select all
ServerName localhost:8080


extra/httpd-vhosts.conf:
Code: Select all
################################################
# VirtualHost's
################################################

NameVirtualHost 127.0.0.1

<VirtualHost 127.0.0.1>
    ServerName localhost
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin webmaster@localhost
    DocumentRoot "D:/server/htdocs"
    ScriptAlias /cgi-bin/ "D:/server/cgi-bin/"

    <Directory "D:/server/htdocs">
 
      Options Indexes FollowSymLinks
 
       AllowOverride FileInfo
 
       Order allow,deny
 
       Allow from all
 
       DirectoryIndex index.php index.html index.htm
    </Directory>
</VirtualHost>

<VirtualHost 127.0.0.1>
    ServerName www.dev5-media.lh
    ServerAlias dev5-media.lh
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin webmaster@dev5-media.lh
    DocumentRoot "D:/server/vhosts/dev5-media.de/httpdocs"
    ScriptAlias /cgi-bin/ "D:/server/vhosts/dev5-media.de/cgi-bin/"

    <Directory "D:/server/vhosts/dev5-media.de/httpdocs">
    Options Indexes FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    DirectoryIndex index.php index.html index.htm
    </Directory>
</VirtualHost>


Mit diesen Einstellungen funktioniert XAMPP - nur nicht mit mod_rewrite.
burnersk
 
Posts: 2
Joined: 16. August 2007 12:43

Postby Wiedmann » 16. August 2007 13:18

Nun wollte ich mod_rewrite aktivieren in der httpd.conf und der Server stützt ab.

Geht das genauer?
- Fehlermeldung
- Apache error.log
- Windows Ereignislog
usw.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby burnersk » 16. August 2007 13:21

Leider nicht.
Server stürzt beim booten ab und hat noch keinen Zugriff auf die Logfiles von Apache.

WinEvent:
Code: Select all
- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" />
  <EventID Qualifiers="0">1000</EventID>
  <Level>2</Level>
  <Task>100</Task>
  <Keywords>0x80000000000000</Keywords>
  <TimeCreated SystemTime="2007-08-16T11:40:25.000Z" />
  <EventRecordID>970</EventRecordID>
  <Channel>Application</Channel>
  <Computer>KORNSOR-NTBK-03</Computer>
  <Security />
  </System>
- <EventData>
  <Data>apache.exe</Data>
  <Data>2.2.4.0</Data>
  <Data>45ebef86</Data>
  <Data>ntdll.dll</Data>
  <Data>6.0.6000.16386</Data>
  <Data>4549bdc9</Data>
  <Data>c0000005</Data>
  <Data>00062086</Data>
  <Data>1ec4</Data>
  <Data>01c7dff9ea331b12</Data>
  </EventData>
  </Event>
burnersk
 
Posts: 2
Joined: 16. August 2007 12:43


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests