Umstellung von TSW auf XAMPP macht Probleme

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Umstellung von TSW auf XAMPP macht Probleme

Postby Farmer » 03. August 2007 18:05

Hallo
habe von TSW auf Xampp umgestellt und dementsprechend die vhost mit kopiert.
funktioniert eigentlich alles so weit so gut, nur ein kleines Problem gibt es.
im TSW hatte ich in vhost
folgendes stehen:

<VirtualHost *:80>
ServerName www.Dietldorf.dnet
ServerAdmin Administrator@dietldorf.net
DocumentRoot e:\Homepage\Dietldorf-Net
<Directory "e:\Homepage\Dietldorf-Net">
AllowOverride All
AuthType Basic
AuthName Dietldorf-Net
AuthUserFile /Programme/TSW/Apache2/Daten/.htpasswd
AuthGroupFile /Programme/TSW/Apache2/Daten/.htgroup
Require group Administratoren Dietldorf-Net MC-Grafenberg
Order allow,deny
Allow from 192.168.
Allow from 172.16.0
Satisfy any
Options +IncludesNoExec -Indexes
IndexIgnore .htaccess
</Directory>
</VirtualHost>

mit der funktion, das nur die Rechner im Intranet (192.168.*.* oder 127.16.0.*)
uneingeschrenkten zugriff hatten und alle anderen nur mit Benutzernamen und passwort rein kamen.

aber bei Xampp funktioniert es nicht, egal von welchem Rechner ich es Probiere es wird immer Benutzername und Passwort abgefragt.
wenn ich auf Allow from all umstelle können alle ohne Abfrage rein, aber umgekehrt geht es nicht

an was kann es liegen,
ich hoffe irgendjemand kann mir weiterhelfen.


mfg
Farmer
Farmer
 
Posts: 13
Joined: 03. August 2007 17:33
Operating System: win2008 RC2

Postby Farmer » 03. August 2007 19:07

im Xampp sieht es dann so aus

<VirtualHost *:80>
ServerName www.Dietldorf.dnet
ServerAdmin Administrator@dietldorf.net
DocumentRoot e:\Homepage\Dietldorf-Net
<Directory "e:\Homepage\Dietldorf-Net">
AllowOverride All
AuthType Basic
AuthName Dietldorf-Net
AuthUserFile /xampp/Daten/.htpasswd
AuthGroupFile /xampp/Daten/.htgroup
Require group Administratoren Dietldorf-Net MC-Grafenberg
Order allow,deny
Allow from 192.168.
Allow from 172.16.0
Satisfy any
Options +IncludesNoExec -Indexes
IndexIgnore .htaccess
</Directory>
</VirtualHost>
Farmer
 
Posts: 13
Joined: 03. August 2007 17:33
Operating System: win2008 RC2


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests