XAmpP: UserDir (Dauerbrenner-Thema)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAmpP: UserDir (Dauerbrenner-Thema)

Postby SvenLittkowski » 31. July 2007 19:05

Hallo.

Ich habe gestern recherchiert, um Loesungen fuer meine gewuenschte Konfiguration des UserDirs der HTDocs zu bekommen, und habe ja auch was gefunden. Ich habe die Loesungen uebernommen, aber habe trotzdem Problem, meine Websites im gewuenschten Verzeichnis zu oeffnen.

Mit Sicherheit mein Fehler. Daher bitte ich Euch um Hilfe.

In der "conf/extra/httpd-userdir.conf" habe ich den Pfad entsprechend geaendert, aber es klappt so nicht:

Code: Select all
UserDir Scripts/Websites


sowie

Code: Select all
Directory "L:/Scripts/Websites"


Mein Ziel ist es, mit https://localhost/Websites meine Websites oeffnen zu koennen.
SvenLittkowski
 
Posts: 11
Joined: 09. December 2004 02:01
Location: Germany / Jamaica

Postby martinpre » 31. July 2007 20:28

Du hast da was falls verstanden die "UserDirs" gehören zu diesem Apache Mod: http://httpd.apache.org/docs/2.0/mod/mod_userdir.html

Was du suchst ist der DocumentRoot: http://httpd.apache.org/docs/2.0/de/mod ... cumentroot
martinpre
 
Posts: 405
Joined: 22. May 2006 16:14
Location: Nähe Tulln / Österreich

Postby SvenLittkowski » 31. July 2007 22:52

Vielen Dank, werde es gleich ausprobieren!
SvenLittkowski
 
Posts: 11
Joined: 09. December 2004 02:01
Location: Germany / Jamaica

Postby SvenLittkowski » 13. August 2007 18:15

Hmmm..... Und es funktioniert NOCH IMMER nicht! Es ist sicher, dass ich irgendwo noch was falsch mache, aber ich weiss nicht, was.

Hier der Stand der Dinge:

ich will mit dem ALIAS MOD arbeiten, um auf PC-Verzeichnisse zuzugreifen. Also erstellte ich so ein Alias, ungefaehr so (aus dem Kopf, da entsprechender PC nicht hier):

Alias /LGW l:/scripts/websites/clients/lgw
<Directory l:/scripts/websites/clients/lgw>
Order allow,deny
Allow from all
</Directory>

1. Das Verzeichnis wird zwar gefunden, aber auf den Inhalt darf nicht zugegriffen werden, irgendwelche Rechte, vermute ich. Obwohl ich viel im DIRECTORY-Teil ausprobiert habe, unter anderem auch das, was oben steht. Ebenfalls habe ich ausprobiert, die PC-Pfade in Anfuehrungszeichen zu setzen (hatte es irgendwo gesehen), aendert aber nichts. Auch habe ich das Oeffnen von home.htm und home.html erlaubt.

2. Ausserdem gibt es ein Problem mit dem Zertifikat des PHPMyAdmins an sich, es scheint abgelaufen zu sein. Wie kann ich die Fehlermeldung im Browser verhindern bzw. das alte Zertifikat (2006 abgelaufen trotz neuem Download und Installation) durch ein neues ersetzen?
SvenLittkowski
 
Posts: 11
Joined: 09. December 2004 02:01
Location: Germany / Jamaica

Postby TTP » 14. August 2007 16:40

zu 1: Probier mal:

Code: Select all
Alias /LGW l:/scripts/websites/clients/lgw
<Directory l:/scripts/websites/clients/lgw>
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>


vielleicht hilft´s

zu 2: joa n neues Zertifikat kaufen, kostet bei den meisten Provider so ca. 70-120 € / Jahr

Mehr Info
Place
ohne Apachefriends wär ich in meiner Entwicklung weiter zurück ;)
User avatar
TTP
 
Posts: 310
Joined: 30. August 2003 19:38
Location: Wolfsburg


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests