NameVirtualHost immer der erste eintrag

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

NameVirtualHost immer der erste eintrag

Postby BrianFFM » 26. July 2007 13:04

hallo

ich habe im meiner v-host.conf meine Virtuellen hosts eingetragen

NameVirtualHost *:80

<VirtualHost *:80>
DocumentRoot /xampp/htdocs/mysite
ServerName mysite.local
</VirtualHost>

in der hosts datei natürlich auch den Eintrag mysite.local auf den localhost

...

schön funktioniert..

das dumme ist nur, wenn ich mehrere vhosts anlege nimmt apache immer den ersten vhost. auch localhost geht jetzt auf den vhost.

wie kann ich das denn fixen??

thanx, Brian
BrianFFM
 
Posts: 4
Joined: 26. July 2007 12:49

Postby Stepke-DSL » 26. July 2007 13:29

Moin,

Ist ja auch logisch, da du mit
Code: Select all
<VirtualHost *:80>


alle Anfragen auf dieses Verzeichnis weiterleitest.

Versuch mal folgendes:

Code: Select all
<VirtualHost dein.Host:80>
DocumentRoot /xampp/htdocs/mysite
.
.
.


Und leg einen 2. virtuellen Host an mit:

Code: Select all
<VirtualHost *:80>
DocumentRoot /xampp/htdocs
.
.
.


Somit werden alle Anfragen, die an dein.Host gehen in dein mysite weitergeleitet und alle anderen Anfragen in das htdocs Verzeichnis...

MfG Stepke
Stepke-DSL
 
Posts: 313
Joined: 12. July 2007 16:08
Operating System: Win XP Pro SP3 + SuSe Linux

Postby BrianFFM » 26. July 2007 14:04

logisch ja ... :) das versuche ich gleich mal ..

ich bedanke mich aber schon mal ganz artig für die Hilfe ..

Gruß, Brian
BrianFFM
 
Posts: 4
Joined: 26. July 2007 12:49

Postby Last-Riddick » 27. July 2007 09:08

Hallo
ich verstehe das mit den dein.host nicht so richtig habe auch so ein ähnliches problem der xampp nimmt ja die domain die ich zu den server dazu habe aber cih weiss nicht wie ich der hompage die domian geben kann ich verzweifel hier noch.
Wäre sehr Dankbar wenn mir jemand helfen kann.

MFG Last-Riddick
Last-Riddick
 
Posts: 21
Joined: 27. July 2007 08:39
Location: Erfurt

Postby glitzi85 » 27. July 2007 10:57

Hallo,

der Tipp von Stepke-DSL ist quatsch. vHosts müssen auch so funktionieren, wie du sie eingerichtet hast. Entscheidend ist die Angabe von ServerName. Poste doch mal die Konfiguration von ALLEN vHosts, dann liese sich vielleicht was klären. Und bitte auch die hosts-Datei posten.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Last-Riddick » 27. July 2007 16:32

Habe doch noch garkeine V-Hosts geschrieben wusste nicht genau ob das mein Problem lösen tut.
Danke
MFG Last-Riddick
ICQ 331103441
Last-Riddick
 
Posts: 21
Joined: 27. July 2007 08:39
Location: Erfurt

Postby BrianFFM » 27. July 2007 20:26

ha die Antwort (sorry) war quatsch. es hatte mich schon etwas gewundert, weil es auf meinem Linux Server ja funzt. und das Problem besteht immernoch bei mir.

ok, du wolltest noch mal meine Vhost.conf sehen:

die Domains uind verzeichnisse habe ich mal gegen X ausgetaausch.

Code: Select all
#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
NameVirtualHost *:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ServerName or ServerAlias in any <VirtualHost> block.
#
##<VirtualHost *:80>
##    ServerAdmin webmaster@dummy-host.example.com
##    DocumentRoot /www/docs/dummy-host.example.com
##    ServerName dummy-host.example.com
##    ServerAlias www.dummy-host.example.com
##    ErrorLog @rel_logfiledir@/dummy-host.example.com-error_log
##    CustomLog @rel_logfiledir@/dummy-host.example.com-access_log common
##</VirtualHost>

##<VirtualHost *:80>
##    ServerAdmin webmaster@dummy-host2.example.com
##    DocumentRoot /www/docs/dummy-host2.example.com
##    ServerName dummy-host2.example.com
##    ErrorLog @rel_logfiledir@/dummy-host2.example.com-error_log
##    CustomLog @rel_logfiledir@/dummy-host2.example.com-access_log common
##</VirtualHost>


<VirtualHost *:80>
DocumentRoot /xampp/htdocs/X
ServerName X.local
php_admin_flag register_global On
</VirtualHost>

<VirtualHost *:80>
DocumentRoot /xampp/htdocs/XXX
ServerName XXX.local
</VirtualHost>

<VirtualHost *:80>
DocumentRoot /xampp/htdocs/XXXXX
ServerName XXXXX.local
</VirtualHost>



<VirtualHost *:80>
DocumentRoot /xampp/htdocs
ServerName localhost
</VirtualHost>
BrianFFM
 
Posts: 4
Joined: 26. July 2007 12:49

Postby BrianFFM » 27. July 2007 20:33

ich habe das Problem gefunden.


es ist die Reienfolge ..

in dem Beispiel in der Datei ist es falsch drin ..

es muss vor der Document Root der Server Name kommen

Code: Select all
<VirtualHost *:80>
ServerName XXX.local
DocumentRoot /xampp/htdocs/XXX
</VirtualHost>


so geht es :D

Cheers, Brian
BrianFFM
 
Posts: 4
Joined: 26. July 2007 12:49

Postby Last-Riddick » 31. July 2007 16:37

Ja ich probiere das mal bei mir geht zwar jetzt die domain aber wenn ich vom server aus localhost eingebe da kommt nur noch zugriff verweigert weiss auch nicht was da falsch ist.

Danke erstmal für deine mühen.

MFG last-riddick
Last-Riddick
 
Posts: 21
Joined: 27. July 2007 08:39
Location: Erfurt


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests