Umlaute in Domains

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Umlaute in Domains

Postby stephan489 » 19. July 2007 05:27

Hallo,
ich hab folgendes Problem:
ich will über meinen Xampp server einer domain mit umlauten per Vhosts eine Webseite zuordnen wir haben das alles so gemacht wies laut Anleitung gemacht werden sollte! bei allen anderen Domains die wir reserviert haben die keine umlaute enthalten funktioniert das sehr gut nur bei der Domain mit ü drin kommt der Error das er die logfiles nicht finden kann(wenn wir den Xampp Server starten wollen) und dann beendet er sich gleich wieder! Aber wenn wir den Eintrag für die Umlautdomain rausnehmen dann startet der Server wieder ohne Probleme!

das ist einer der vhosts einträge den ich in meiner httpd-vhosts.conf hab:

<VirtualHost *:80>
ServerAdmin webmaster@dummy-host2.example.com
DocumentRoot c:/xampp/htdocs/buethfleth
ServerName buetzfleth-hafen.de
ServerAlias www.buetzfleth-hafen.de
ErrorLog c:/xampp/apache/logs/error_buetzfleth.log
CustomLog c:/xampp/apache/logs/custom_buetzfleth.log common
</VirtualHost>

Die dazugehörige Seite ist:
http://www.buetzfleth-hafen.de

Nach dem Muster des oben gepostetem vhosteintrag hab wir noch 2 weitere Seiten die auch gut funktionieren:
http://www.rjpublikationen.de(das ist die Hauptseite)
http://www.elbblick-stade.de

Das hier ist der vhosteintrag für die Domain [url]www.bützfleth-hafen.de[/url](edit:wiso werden denn die [url] tags net ausgewertet?):

<VirtualHost *:80>
ServerAdmin webmaster@dummy-host2.example.com
DocumentRoot c:/xampp/htdocs/buetzfleth
ServerName bützfleth-hafen.de
ServerAlias www.bützfleth-hafen.de(edit:hier wird die url auch net
ausgewertet!
)
ErrorLog c:/xampp/apache/logs/error_bützfleth.log
CustomLog c:/xampp/apache/logs/custom_bützfleth.log common
</VirtualHost>

Nur wenn wir den eintrag in die vhosts config datei einfügen und dann den apache server neustarten kommt der oben erwähnte error!

Wir benutzen als Srrver Betriebssystem Windows 2003 Server Edition und die aktuelle Xampp version(per windows installer installiert).

Sorry das ich nochmal ein extra Topic erstellt hab aber die topics/posts die ich über die Forumsuche erhalten hab haben mir nicht weiter geholfen!
Ich bedanke mich schonmal im vorraus für Hilfe!

kann es vielleicht sein das die forensoftware keine umlaute mag?
stephan489
 
Posts: 3
Joined: 05. May 2007 09:21

Postby DJ DHG » 19. July 2007 07:26

Moin Moin!

Umlaute müssen nach Punycode konvertiert werden.
Siehe FAQ.

kann es vielleicht sein das die forensoftware keine umlaute mag?

Richtig.

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby glitzi85 » 25. July 2007 21:09

Hallo,

wiso werden denn die [url] tags net ausgewertet?

Vielleicht weil bei dir unter der Nachrichtentextbox "BBCode in diesem Beitrag deaktivieren" aktiviert ist?

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby DJ DHG » 25. July 2007 21:29

glitzi85 wrote:Hallo,

wiso werden denn die [url] tags net ausgewertet?

Vielleicht weil bei dir unter der Nachrichtentextbox "BBCode in diesem Beitrag deaktivieren" aktiviert ist?

mfg glitzi


Nicht wirklich. Es liegt an den Umlaute.

Beipsiele:

http://www.123456789.de
[url]www.üüüü.de[/url]
[url]www.öüäöäü.de[/url]

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby glitzi85 » 25. July 2007 21:51

Oooooh, da hab ich wohl geschlafen :oops:

Ich glaub ich sollte dringend Feierabend machen ;-)

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby DJ DHG » 25. July 2007 22:10

glitzi85 wrote:Oooooh, da hab ich wohl geschlafen :oops:

Ich glaub ich sollte dringend Feierabend machen ;-)

mfg glitzi


Wenn ich mir so ansehe, was du heute Abend alles geschrieben hast, dann darfst du auch müde sein. :wink:

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby KingCrunch » 25. July 2007 23:50

/sign
Den wird man net mehr los ;)
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby glitzi85 » 26. July 2007 00:33

Hehe, vielleicht sollte ich meinen Nick in "Plage aus dem Schwabenländle" umbenennen ;-)
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby stephan489 » 26. July 2007 05:56

Kann man das auch auf einem Lokalen Xampp server testen mit der umlautdomain?

bitte nur sachen die etwas mit dem thema zutun haben posten(aslo bitte zum spammen ein anderen topic benutzen)
stephan489
 
Posts: 3
Joined: 05. May 2007 09:21

Postby DJ DHG » 26. July 2007 09:06

stephan489 wrote:Kann man das auch auf einem Lokalen Xampp server testen mit der umlautdomain?


Ja, kannst du. Siehe FAQ :wink:

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests