Virtual-Host Problem

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Virtual-Host Problem

Postby chapolote » 17. July 2007 10:58

Hallo,

ich versuche, leider erfolglos, bei meiner Xampp-Installation (1.6.2 auf WinXP) Virtual-Hosts einzurichten, und obwohl ichs exakt nach der Anleitung auf der Xampp-Website gemacht habe, funktioniert es nicht richtig. Auch weitere Recherchen bringen mich nicht weiter. Kann da bitte mal jemand drüberschauen, vielleicht hab ich ja was übersehen:

Also: Xampp liegt bei mir unter
D:\Webserver\xampp

Die Website, die ich als Virtual Host einrichten will liegt unter:
D:\Webdesign\Projekte\MaSu\Website

Folgendes hab ich nun gemacht: (w...w steht natürlich für www)
die host Datei im system32\drivers\etc editiert mit:

127.0.0.1 familienaufstellung-web.local w...w.familienaufstellung-web.local

und dann die httpd-vhosts in xampp folgendermaßen editiert:

<VirtualHost 127.0.0.1>
ServerName localhost
AddType text/html .shtml
AddHandler server-parsed .shtml
ServerAdmin webmaster@localhost
DocumentRoot "d:/Webserver/xampp/htdocs"
ScriptAlias /cgi-bin/ "d:/Webserver/xampp/htdocs/cgi-bin/"

<Directory "d:/Webserver/xampp/htdocs">
Options Indexes FollowSymLinks
Options +Includes
# Options +
AllowOverride FileInfo
AllowOverride None
Order allow,deny
Allow from all
DirectoryIndex index.html index.htm index.php
</Directory>

</VirtualHost>

<VirtualHost 127.0.0.1>
ServerName w...w.familienaufstellung-web.local
ServerAlias familienaufstellung-web.local
AddType text/html .shtml
AddHandler server-parsed .shtml
ServerAdmin webmaster@localhost
DocumentRoot "d:/Webdesign/Projekte/MaSu/Website"
ScriptAlias /cgi-bin/ "d:/Webdesign/Projekte/MaSu/Website/cgi-bin/"

<Directory "d:/Webdesign/Projekte/MaSu/Website">
Options Indexes FollowSymLinks
Options +Includes
# Options +
AllowOverride FileInfo
AllowOverride None
Order allow,deny
Allow from all
DirectoryIndex index.html index.htm index.php
</Directory>

</VirtualHost>


Alles gespeichert, Apache neu gestartet. Wenn ich jetzt w...w.familienaufstellung-web.local aufrufe, erscheint die "It works"-Seite aus dem htdocs-Verzeichniss meiner apache-Installation, was ja wohl bedeutet, daß apache w..w.familienaufstellung-web.local nicht auflösen kann. Aber warum?

Hier komm ich nicht mehr weiter, man kann sich Virtual-Server-Anleitungen bis zum Nimmerleinstag ansehen, alle sagen quasi das gleiche, d.h. leider, ich mach was falsch, komm aber nicht dahinter.

Wäre für jeden Tip sowas von dankbar,
Gruß, chapolote
chapolote
 
Posts: 8
Joined: 17. July 2007 10:37
Location: Karlsruhe

Postby DJ DHG » 17. July 2007 11:39

Moin Moin!

Hab es zwar nur überflogen, aber versuch mal so.

Code: Select all
<VirtualHost *>
[...]


Dann vermisse ich noch folgende Zeile:
Code: Select all
NameVirtualHost *


Und die Datei heißt doch "hosts"?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby chapolote » 17. July 2007 13:09

@DJ DHG

zuerst einmal: ja, die Datei im windows/system32/drivers/etc heißt natürlich hosts

dann: es läuft jetzt endlich :-), was ich genau gemacht hab:

erst einmal die fehlenden Einträge für NameVirtualHost *:80 nachgetragen und die VirtualHost so eingeleitet:
Code: Select all
<VirtualHost *:80>


Dann hats aber immer noch nicht funktioniert, ich erklärs mal kurz genauer, weil das anderen Usern vielleicht auch weiterhilft:

Was mir in der Grundkonfiguration wie in meinem 1. Thread nicht aufgefallen war, war, daß im error.log folgender Eintrag stand:

VirtualHost 127.0.0.1:80 overlaps with VirtualHost 127.0.0.1:80...


Also hab ich im zweiten Teil, indem die Website als VirtualHost definiert wird, den Eintrag so geändert:

Code: Select all
<VirtualHost *:80>
[...]


danach hat es immer noch nicht funktioniert, obwohl das error.log jetzt sauber war, trotzdem konnte apache w..w.familienaufstellung-web.local nicht auflösen und sprang immer ins htdocs-Verzeichniss.
Meine Vermutung ist jetzt, bitte korrigiert mich, wenn das Quatsch ist, daß man wohl ip-basierte und namensbasierte VirtualHosts nicht vermischen kann. Wie dem auch sei letztendlich sieht meine Konfiguration so aus und damit funktioniert es auch:

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    ServerName localhost
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin webmaster@localhost
    DocumentRoot "d:/Webserver/xampp/htdocs"
    ScriptAlias /cgi-bin/ "d:/Webserver/xampp/htdocs/cgi-bin/"

    <Directory "d:/Webserver/xampp/htdocs">
    Options Indexes FollowSymLinks
    Options +Includes
#   Options +
    AllowOverride FileInfo
    AllowOverride None
    Order allow,deny
    Allow from all
    DirectoryIndex index.php index.html index.htm
    </Directory>

</VirtualHost>

NameVirtualHost *:80

<VirtualHost *:80>
    ServerName familienaufstellung-web.local
    ServerAlias w..w.familienaufstellung-web.local
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin webmaster@localhost
    DocumentRoot "d:/Webdesign/Projekte/MaSu/Website"
    ScriptAlias /cgi-bin/ "d:/Webdesign/Projekte/MaSu/Website/cgi-bin/"

    <Directory "d:/Webdesign/Projekte/MaSu/Website">
    Options Indexes FollowSymLinks
    Options +Includes
#   Options +
    AllowOverride FileInfo
    AllowOverride None
    Order allow,deny
    Allow from all
    DirectoryIndex index.html index.htm index.php
    </Directory>

</VirtualHost>


Man beachte noch, daß im ersten Thread ein Dreher bei ServerName und ServerAlias war.

Jedenfalls, jetzt tuts :-), danke für Deine Hilfe
chapolote
 
Posts: 8
Joined: 17. July 2007 10:37
Location: Karlsruhe

Postby glitzi85 » 25. July 2007 20:30

Hallo,

IP-basiert bedeutet, dass du für jeden Host eine eigene IP hast. Das kannst du natürlich mit Namesbasierten vHosts nicht mischen. Allerdings hat das weglassen von NameVirtualHost dazu geführt, dass dein Apache in den IP-basierten vHosts Modus geschalten hat. Und da du zwei gleiche IP-Adressen (127.0.0.1) für beide Hosts vergeben hast, kann das natürlich nicht klappen (das hat dir auch die Fehlermeldung gesagt). Du kannst allerdings auch die IP als ServerName (im Namebased-Modus) angeben, dann kannst du die IP auch als zusätzlichen Host benutzen.

Außerdem kannst du das zweite NameVirtualHost *:80 in deiner Konfiguration weglassen.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby chapolote » 25. July 2007 22:22

Ja, richtig, ich hab mich dann gewundert, warum im error.log immer folgende Meldung auftauchte:

NameVirtualHost *:80 has no VirtualHosts

Das kam von dem zweiten NameVirtualHost *:80 in meiner Konfiguration.

Gruß, chapolote
chapolote
 
Posts: 8
Joined: 17. July 2007 10:37
Location: Karlsruhe


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests