Windows 2003 und Xampp

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Windows 2003 und Xampp

Postby Kampfwurst_Hugo » 04. July 2007 13:48

Hallo

Ich wollte Xampp auf einem Windows 2003 Enterprise Server installiern um eine Bilderdatenbank für das Intranet anzulegen. Nun was muss ich beachten wenn ich Xampp unter Windows 2003 installiere??

Meine Freunde sagten mir das von ich IIS von Windows den Port umändern muss.
Danach muss ich IIS von Windows abschalten.
Danach Xampp installieren und auf einen anderen Port als 80 legen.

Und kann ich auch irgendwie einstellen das ich z.B. http://namedesServers/Gallery auf die Gallerie zugreifen kann also nicht über die IP Adresse???


MFG Christoph
Kampfwurst_Hugo
 
Posts: 3
Joined: 04. July 2007 13:41

Postby KingCrunch » 04. July 2007 14:03

Meine Freunde sagten mir das von ich IIS von Windows den Port umändern muss.
Danach muss ich IIS von Windows abschalten.
Danach Xampp installieren und auf einen anderen Port als 80 legen.
Gib deinen Freunden ruhig die goldene Himbeere :D

Also, mal der Reihe nach. Sollte (und auch nur dann) der IIS installiert sein und laufen, reicht es ihn abzuschalten (beenden, Autostart nicht vergessen). Dann sind die Ports frei. Vorher die Ports vom IIS zu ändern, ergibt keinen Sinn, weil er sie sowieso nicht belegt, solange er nicht läuft. Sollte er nicht laufen oder sollten die Ports geändert sein, dann wiederum brauchste auch nicht die Ports vom Apachen zu ändern, weil die ja dann natürlich frei sind ;)
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby Kampfwurst_Hugo » 04. July 2007 14:06

ok danke
so werd ich wenn bevor ich Xampp installiere den IIS Dienst abschalten
Kampfwurst_Hugo
 
Posts: 3
Joined: 04. July 2007 13:41

Postby Kampfwurst_Hugo » 04. July 2007 15:04

so habe nun den IIS Dienst unter dienste deaktiviert und nun kommt bei jedem Windows Start einen Fehlermeldung das ein dienst nicht gestartet wurde.

Hab ich was falsch gemacht??

Und wie kann ich es anstellen das ich das mit dem namen auf die INTRANET Seite komme und nicht nur mit der IP??
Kampfwurst_Hugo
 
Posts: 3
Joined: 04. July 2007 13:41

Dinste

Postby hawkmaster » 04. July 2007 15:34

Es gibt einmal den Dienst
IIS Admin
und dann irgend etwas mit
WWW Veröffentlichungsdienst ..??

wenn ich mich recht erinnere.

Die gehören beide zum IIS.
Sollten beide deaktiviert sein.
Gruss
hawk

Kampfwurst_Hugo wrote:so habe nun den IIS Dienst unter dienste deaktiviert und nun kommt bei jedem Windows Start einen Fehlermeldung das ein dienst nicht gestartet wurde.

Hab ich was falsch gemacht??
hawkmaster
 
Posts: 94
Joined: 22. January 2004 12:33
Location: Stuttgart

Postby kschroeder » 04. July 2007 18:20

Kampfwurst_Hugo wrote:Und wie kann ich es anstellen das ich das mit dem namen auf die INTRANET Seite komme und nicht nur mit der IP??


Damit eine IP auch unter einem Namen gefunden werden kann, ist ein DNS-Eintrag notwendig. Wenn Du Deinen Webserver NUR für das Intranet brauchst, reicht ein Eintrag in der Hosts für jeden Rechner (c:\windows\system32\drivers\etc\hosts).
Kannst natürlich auch einen eigenen DNS-Server betreiben, dann muss aber bei jedem PC dieser als DNS-Server in der IP-Konfig eingetragen werden.

Wenn's doch nicht nur das Intranet werden soll, sondern doch auch mal das Internet, dann kannst beispielsweise bei no-ip.com ne Subdomain für lau bekommen und auf Deinem PC läuft ein Tool, dass der Domain regelmäßig Deine aktuelle IP mitteilt, damit die anderen Dich auch finden können.

Alles klar? :wink:
kschroeder
 
Posts: 254
Joined: 11. May 2007 13:33


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests