XAMPP 1.6.1 keine OCI8 bei php5

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP 1.6.1 keine OCI8 bei php5

Postby amneff » 22. June 2007 14:31

hallo zusammen,

unter php4 läuft die oci8 unterstützung einwandfrei, sobald ich via php-switch auf php5 umschalte läuft oci8 nicht mehr und wird auch bei phpinfo() nicht mehr angezeigt. ich habe das forum schon durchforstet aber nichts gefunden...
das ganz läuft unter xp sp2.

mir wäre php5 lieber, weil wir halt produktiv auch damit arbeiten.

vielen dank für die hilfe!


amneff
NACHTRAG
ich habe gerade im error.log von apache das gesehen:
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\xampp\\xampp\\php\\ext\\php_oci8.dll' - Die angegebene Prozedur wurde nicht gefunden.\r\n in Unknown on line 0 die php_oci8.dll liegt aber genau dort!
bei phpinfo wir der Pfad auch angezeigt: extension_dir C:\xampp\xampp\php\ext\ C:\xampp\xampp\php\ext\
ich versteh das echt nicht!? :(
Nachtrag2 Inzwischen habe ich herausgefunden, dass die php_oci8.dll mit php5 an den Oracle10 Client gebunden ist, ich aber einen 9er Client aus kompatibilitätsgründen installiert habe, so ein mist :evil:
amneff
 
Posts: 2
Joined: 24. March 2004 11:51
Location: Stuttgart

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests