wer ist oder war gerade auf meinem Server

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

wer ist oder war gerade auf meinem Server

Postby WeissA » 17. June 2007 11:01

Hallo zusammen,

auch auf die Gefahr hin, dass diese Frage zu einfach sein sollte, erlaube ich mir, sie hier doch mal zu stellen, da ich nirgends fündig geworden bin: gibt es eine Möglichkeit (Freewareprogramm, Modul oder was auch immer) , an der man sehen kann, wer gerade auf meinem Server ist oder war?

Also zur Info: bin kein Experte auf dem Apachengebiet, hab es allerdings immerhin geschafft, den Indianer samt PHP, MySql und was dazugehört, mit Hilfe von Tutorials, Xampp etc. zum laufen zu bringen. (War gar nicht so einfach, aber interessant;-)
Da ich selbstverständlich nicht möchte, dass jetzt jemand mein "Werk" vernichtet, möchte ich zumindest wissen, wieviel Leute sich auf dem Server tummeln und welche IP-Adresse, um entsprechend reagieren zu können. Ich könnte mir vorstellen, dass es da bestimmt irgend ein Programm gibt, das dies ermöglicht.
Kann mir da jemand einen Tipp geben?


Danke im Vorraus.
WeissA
 
Posts: 18
Joined: 17. June 2007 10:36

Postby Wiedmann » 17. June 2007 12:28

Da musst dudir im einfachsten Fall nur das access.log anschauen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby WeissA » 17. June 2007 13:15

Ja, das ist ja schon mal ein Anfang;-)


Danke
WeissA
 
Posts: 18
Joined: 17. June 2007 10:36

Postby WeissA » 17. June 2007 15:44

Hallo nochmal

ich hätte da noch eine Zusatzfrage:
wenn ich die Log-File richtig interpretiere, dann habe ich ganz links die IP.
Bei mir wird lediglich die 0.0.0.0. angezeigt, obwohl ich sicher bin, dass noch jmd. anders darauf zugegriffen hat. Mein Zugang zum Netz geht über den Speedport-Router. Hat dies was damit zu tun, oder welche Einstellung muss ich wo machen, dass die IP bei mir richtig gelogt wird?

Danke nochmals im Vorraus.
WeissA
 
Posts: 18
Joined: 17. June 2007 10:36

Postby Memory » 18. June 2007 07:32

Das ist ein Apache Feature
Hier ist die ein Beitrag hierzu
http://community.apachefriends.org/f/viewtopic.php?t=24741

Gruß Freddy
-------------
Das ist kein Bug das ist ein Feature :D
Memory
 
Posts: 42
Joined: 10. May 2007 15:36

Postby WeissA » 18. June 2007 19:53

Hallo Freddy,

guter Tipp, funktioniert so einwandfrei.


Danke
Andreas
WeissA
 
Posts: 18
Joined: 17. June 2007 10:36

Postby Memory » 20. June 2007 09:32

Ähhh weiterlesen
Wenn du das einschaltest schmiert dir der Apache irgendwann ab !!!!
Memory
 
Posts: 42
Joined: 10. May 2007 15:36

Postby WeissA » 20. June 2007 17:43

Hallo Freddy,

also bis dato habe ich keine Speicher- oder anderweitige Probleme.
Werd´s mal weiter beobachten.
(WK2, Windows 5.0 build 2195 Plattform 2 pack 4 , Xampp Panel Version 2.5)

Wie hast Du denn das Problem jetzt gelöst?

Gruß
Andreas
WeissA
 
Posts: 18
Joined: 17. June 2007 10:36

Postby Memory » 21. June 2007 06:49

Ich verzichte auf die IP Adresse
Das Problem tritt bei mir auf wenn auf dem installierten Mediawiki gearbeitet wird. Aber auch andere PHP Seiten haben das Probelm.

Warum das so ist steht hier. Dort kannst du nachschauen ob du betroffen bist.
http://community.apachefriends.org/f/viewtopic.php?t=24741

Greetz
Memory
 
Posts: 42
Joined: 10. May 2007 15:36


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests