port ändern

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

port ändern

Postby Fire-Fighter » 11. June 2007 17:33

Hallo miteinander!

Ich habe ein riesiges Problem! Ich MUSS den HTTP und HTTPS Port für meinen Apache ändern!

Ich ändere das [i]Listen 80[/i] und [i]Listen 443[/i] in der httpd.conf und in der httpd-ssl.conf!
So, der Server startet nicht mehr und gibt immer wieder die gleiche Meldung aus, dass er nicht 0.0.0.0:445 abhören kann oder so! (445 ist mein neuer Port)

Das Problem ist jetzt das, dass ihr immer gute Tipps habt, wie man alles andere ändern kann, aber ich hab noch nichts gefunden, wie man den Port vom Apache Server ändern kann!!!


XAMPP: 1.6.2
Win xp Prof bzw. Win 2003 Server SB

Vielen Dank schon mal im Voraus für euere Hilfe...


mfg Fire-Fighter
User avatar
Fire-Fighter
 
Posts: 10
Joined: 08. June 2007 16:53
Location: Steiermark-AUT

Postby Wiedmann » 11. June 2007 17:44

und gibt immer wieder die gleiche Meldung aus, dass er nicht 0.0.0.0:445 abhören kann oder so!

Was ist "oder so"?
(Die korrekte Fehlermeldung die du hast zu posten wäre wirklich nett...)

(445 ist mein neuer Port)

Wobei diser natürlich etwas daneben ist. Wenn du selber Ports vergibst, sollte der auf jeden Fall ab 1024 sein. (Ganz sicher liegtst du immer zwischen 49152 und 65535)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Fire-Fighter » 11. June 2007 19:05

stimmt, das wäre klug von mir gewesen...

so, also, das problem ist jetzt ein neues! ich habe XAMPP neu installiert und dann wieder alle Ports geändert! 8080 für HTTP und 1024 für HTTPS!
Jetzt startet XAMPP, laut control auf port 80, ABER man kann in der portcheck.exe keinen laufenden Dienst erkennen, und meine Ports werden gar nicht angezeigt, als ob ich sie nirgends konfiguriert hätte!!!

WO muss ich denn die Ports überall ändern?
httpd.conf, httpd-ssl.conf, php.ini?

mfg
User avatar
Fire-Fighter
 
Posts: 10
Joined: 08. June 2007 16:53
Location: Steiermark-AUT

Postby Fire-Fighter » 11. June 2007 19:07

noch eine kleine ergänzung:

die fehlermeldung ist

[i](OS 10048)Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder
Anschluss) nur jeweils einmal verwendet werden. : make_sock: could not bind to
address 0.0.0.0:8080
no listening sockets available, shutting down
Unable to open logs[/i]


mfg
User avatar
Fire-Fighter
 
Posts: 10
Joined: 08. June 2007 16:53
Location: Steiermark-AUT

Postby Wiedmann » 11. June 2007 22:37

Jetzt startet XAMPP, laut control auf port 80,

Zu diesem Programm kann ich nichts sagen.

ABER man kann in der portcheck.exe keinen laufenden Dienst erkennen, und meine Ports werden gar nicht angezeigt,

Dieses Tool testet, so wie in der ausgabe des Tools auch angegebn, nur die Standardports 80, 443, usw. (Eben um zu schauen, warum ein Standard-XAMPP evtl. nicht starten kann)

WO muss ich denn die Ports überall ändern?

httpd.conf: Port für HTTP (Standard 80)
httpd-ssl.conf: Port für HTTPS (Standard 443)

(OS 10048)Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder Anschluss) nur jeweils einmal verwendet werden. : make_sock: could not bind to address 0.0.0.0:8080

Es läuft schon ein Programm auf Port 8080. (Oder du hast versucht den Apachen doppelt zu starten)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Fire-Fighter » 12. June 2007 07:20

danke für deine aw!

du hast recht, der Apache wurde doppelt gestartet!
das mit der portcheck hab ich gestern auch selbst nach 2 Stunden alles rausgefunden, aber meine Frage ist noch, ob man was in der php.ini auch noch ändern muss, weil da auch der Port 443 steht!

mfg Fire-Fighter
User avatar
Fire-Fighter
 
Posts: 10
Joined: 08. June 2007 16:53
Location: Steiermark-AUT

Postby Wiedmann » 12. June 2007 08:55

ob man was in der php.ini auch noch ändern muss,

Nein.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests