Umlaute... mal wieder

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Umlaute... mal wieder

Postby cyxxon » 26. May 2007 12:48

Hallo,

ich habe leider nix im Internet zu meiner speziellen Variante des Umlautproblems mit XAMPP gefunden... alle Posts, die ich fand, drehen sich darum, dass PhpMyAdmin falsch eingestellt ist o.ä. - das läuft bei mir aber alles wunderbar. Nur meine eigenen Dateien machen Murks und zeigen encodierte Zeichen an, nicht die Umlaute selber.

Xampp-Installation ist erst ein paar Tage alt (Rechner neu installiert), also neueste Version. MySQL-Datenbank ist in UTF8, im Header der PHP-Dateien gebe ich das Meta-Tag

<meta http-equiv=\"Content-Type\" content=\"text/html; charset=UTF-8\">

aus. PhpMyAdmin zeigt die Daten in der DB wunderbar an und zeigt auch an, dass das System auf UTF8 eingestellt ist. Firefix zeigt im Browser unter Seiteninformation an, dsas vom Server UTF8 kommt, aber zeigts dann nicht wie gewünscht an. Wenn ich in Firefox manuell einstelle, dass die Zeichen in ISO-8859-1 encodiert sind, passt es.

Irdenwo werden also meine Seiten trotzdem falsch encoded - aber nur die Sachen, die ich aus der DB ziehe! Direkt in die Webseiten geschriebene Umlaute kommen korrekt an.

Für mich seltsam - in der DB stehen korrekte UTF8-Umlaute, die PhpMyAdmin auch im UTF8-Mode korrekt anzeigt. Meine PHP-Dateien, die als Dateien selber auch UTF8 sind, und als Charset UTF8 mitgeben, werden auch richtig angezeigt, nur dass, was diese Dateien aus der DB holen, ist fehlerhaft.

Hat da irgendwer eine Idee zu?

In C:\Programme\Xampp\php\php.ini habe ich auch schon
default_charset = "utf8"

und in C:\Programme\Xampp\mysql\bin\my.cnf
default-character-set=utf8
character-set-server = utf8
collation-server = utf8_bin

eingetragen... (richtige Pfade?)

Grüße
Thomas
cyxxon
 
Posts: 2
Joined: 26. May 2007 12:34

Postby Wiedmann » 26. May 2007 12:57

MySQL-Datenbank ist in UTF8, ... irgendwo werden also meine Seiten trotzdem falsch encoded - aber nur die Sachen, die ich aus der DB ziehe!

http://dev.mysql.com/doc/refman/5.0/en/ ... ction.html
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cyxxon » 26. May 2007 13:36

Whoa... willst du mich heiraten? :wink:

Wie auch immer, perfekt! Das ich da nie drüber gestolpert bin... gibt es eine "sinnvollere" Methode, als das stumpf im Kopf meiner PHP-Datei als
mysql_query("SET NAMES 'UTF8'");
abzusetzen? Ich tippe mal nicht...

Tausend Dank!
Thomas
cyxxon
 
Posts: 2
Joined: 26. May 2007 12:34


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests